PDA

View Full Version : Touchpad disabled in BIOS->Keyboard Toast



fostert
12-28-2011, 02:48 PM
Quirky behaviour of my G74...when I disable the touchpad in the BIOS, the keyboard works right up until the Windows login screen appears, and then is locked (mouse still works). All works normally in Linux whether or not the touchpad is disabled, so its gotta be a Windows software issue. I have BIOS 203, updated atheros wifi drivers, and ATK 14.

Anyone else see this?

BrodyBoy
12-28-2011, 06:42 PM
Yeah, others have reported this as well. I've never tried it to experiment myself, and I don't recall anyone posting a workaround. (It's been a problem for some owners who never use the touchpad and wanted to completely disable it.)

Thail
12-28-2011, 08:18 PM
I'm glad I happened across this as my Keyboard was unresponsive. I had disabled my touchpad because it keeps activating while I'm trying to play games etc, even with an external USB mouse connected, and the setting set to disable when USB mouse detected. I have to keep going into the settings disable the feature, apply then re-enable the feature. So I disabled the touchpad in the BIOS and then booted into windows and everything worked fine. Upon restarting however the keyboard stopped functioning in windows. I was able to use the onscreen keyboard to get into windows and look around check drivers etc, but couldn't find the problem. Enabling the touchpad in the BIOS did fix the problem though.

Currently I have only installed Steam and Steam games, have not uninstalled any software, and have only performed the updates that pop up in the update manager for both Windows and ASUS. When I was in the BIOS I noted the version as 202. Does 203 do anything to correct the issues I'm having with the touch pad, is there another pressing reason to flash the BIOS?

Or.... Maybe I can just tape some cardboard over the thing? >.<

BrodyBoy
12-28-2011, 09:08 PM
@Thail: Is it your intention to not use the touchpad at all? If I would try disabling it in Device Manager. Or you could uninstall the TP driver software, so that Windows installs the generic MS driver (and even disable that, if you want). I think the MS driver is much simpler and less prone to all these fancy functions going haywire.

fostert
12-29-2011, 01:29 PM
Yeah, others have reported this as well. I've never tried it to experiment myself, and I don't recall anyone posting a workaround. (It's been a problem for some owners who never use the touchpad and wanted to completely disable it.)
So this one remains unresolved eh? Drat.
As I say its gotta be a windows thing, so I'm hopeful that some driver update one day to the pad or windows itself will fix this.
For now I'm running Linux 90% of the time, so its a non-issue for me really. Oh well, I kept the clear cellophane cover that was on the touchpad when the laptop shipped. Guess I'll just cover it up while I'm at home (always use an external mouse except when travelling).

PILGRIM
12-29-2011, 02:30 PM
Hi, Thail,

Didn't it help if/when you just disable/enable the touch pad by pressing fn+f9, so as not to interfere while gaming or typing?

Thail
12-30-2011, 08:18 PM
@Pilgrim - FN+F9 did not work because the trackpad is already disabled, and the shortcut only disables, it's not an on/off toggle. Although for testing purposes I have enabled the trackpad and used the FN+F9 shortcut to disable it. I will see if it re-enables itself now.

@Brodyboy - My intention is to use my Razer gaming mouse most times, and only use the touchpad when I am mobile and don't have time/room to set up my mouse. So I don't want to uninstall the driver, but I after I finish testing the FN+F9 If that fails I will attempt t disable the touchpad using the device manager. My concern with that was the ease of re-enabling it when I don't have my mouse out. (Going into the BIOS is pretty straight forward and quick).

My ideal situation would be that the trackpad automatically disables itself every time I plug in my USB mouse, and then stays disabled and doesn't re-enable itself until I unplug the mouse (IE the way that it's supposed to work! lol).

Thanks for the helpful responses. =)

BrodyBoy
12-30-2011, 09:22 PM
My ideal situation would be that the trackpad automatically disables itself every time I plug in my USB mouse, and then stays disabled and doesn't re-enable itself until I unplug the mouse (IE the way that it's supposed to work! lol).

Thanks for the helpful responses. =)
I think getting this to function as designed will require a driver that actually works.

Thail
05-27-2012, 06:00 PM
I never responded to this after I got it working but since I was on the forums today for another issue realized that and wanted to correct that mistake.

What I did to ultimately resolve the issue was enable the trackpad in the bios, then use the FN+F9 as indicated by pilgrim. Strangely enough this has worked marvelously where disabling in the bios or by actually clicking the menu option did not.

I don't know why disabling this way works while the others don't, but I'm happy it's doing what I want it to!

dstrakele
05-27-2012, 07:22 PM
If you have the Sentelic touchpad in your G74SX, uninstalling your current touchpad driver from "Control Panel -Uninstall a program", REBOOT, and install Sentelic driver version 9.1.7.7, it will allow disabling the touchpad in the BIOS without the keyboard also being disabled. It has also resolved the "touchpad re-enabing* issue after it is disabled with Fn-F9 or attaching a USB Mouse. See http://rog.asus.com/forum/showthread.php?9045-G74SX-a-few-issues