PDA

View Full Version : ASUS G55VW Display Problem



Aaren Gibson
07-18-2016, 02:40 PM
Context:
I had to get my HDD replaced and I installed windows 10 and a few drivers:
Nvidia 660m Drivers
Asus Power4Gear
Asus InstantOn
VIA Audio

The Issue:
Whenever I turn on the pc, the screen shows the ROG loading screen and once it finishes loading, the screen goes black. I can only view windows if I plug in a external monitor. Howerver, if I plug in the external monitor and then unplug it, the laptops screen will display windows.

If anymore information is needed, just ask. Thanks

Aaren Gibson
07-24-2016, 01:56 PM
Update: it will display perfectly in safe mode

Also, it works if I disable the graphics card in the Device Manager

So I guess it's a issue with the graphics card drivers, I tried the one listed on the official G55 page (https://www.asus.com/support/Download/3/397/0/1/3yWw7QOsOfFxPNjq/30/)
and the latest drivers on the Nvidia website, but none solved the issue. Anyone have any ideas?

Aaren Gibson
07-29-2016, 03:36 PM
FINALLY AFTER 2 MONTHS OF TRYING TO FIX THIS PROBLEM I HAVE COME UPON A SOLUTION

I did a few things to solve this and since I have been unable to replicate the issue, so I can't say for sure which thing I did fixed it. I suspect the issue was that windows thought that the laptop lid was closed on startup when it wasn't.

Here's what I did:
1. Right click the battery icon at the bottom left of your screen and select "power options"

2. On the left hand side, click on "Choose what closing the lid does"

3.Now here's where I changed multiple things:
i. I changed the "when I press the power button" part to "shut down" on battery and plugged in
ii. I changed the "when I close the lid" part to "do nothing" on battery and plugged in
iii. Under "shutdown settings" I turned on fast startup (If you cant select this, press the "change settings that are currently unavailable" button at the top of the page)

Hope this helps :)