View Full Version : G53JW Touchpad Problems

12-29-2011, 10:26 AM
Hello everybody !!! (A Merry Christmas and a Happy New Year in advance)

First of all, thanks a lot for running this forum. I have learnt many things here and have been following many of the posts about problems posted by many ROG users.

The reason I have to post this thread is because, I have not found many posts with G53 users having a non-responsive touchpad problem. To be comprehensive, I am gonna write the history of my machine till now.

[History] (Impatient ones may skip this section) :p

I bought my G53JW in January 2011. After about 2 months, my charging pin was stuck inside the adapter (which I later knew was a manufacturing defect). (VISIT 1) I took it to the authorized service center in Delhi (the city that I work in) who refused to take it under warranty because they said it was physical damage. Then the guys told me the motherboard will have to be changed and would cost me quite a sum. Well, I wrote a huge mail to ASUS India after which they accepted my laptop under warranty.

I got my laptop back after a month (painful). I used it for a couple of days and realized that my keyboard lights were not working. (VISIT 2) This time I was in my hometown and took it to the ASUS service center there. The guys opened the laptop up and let me know that the service center where I had given it earlier had broken some plastic pins trying to open it up. They had used glue to stick it together. I was shocked but couldn't do much then.

The service center didnt know what to do about the lights and hadn't seen such a laptop before it seems. They ordered new keyboards, then new motherboard and finally understood it was some hardware ID issue and made it alright and gave it back in about a week. After a day, I realized that my webcam was not working. (VISIT 3)I took it there again and they connected it and gave it back in a day. In a couple of days (thanks to dxdiag), I realized only 4gb out of my 6gb ram was detectable. (VISIT 4) I again took it there and they corrected the problem and gave it back to me in a day.

After using it for about 3 days, I realized that my 3D emitter was not working (the service center guys weren't aware there was supposed to be a emitter there). I was back in the old location now, but was so shocked at the service center there that I didn't want to go there. So I waited till I got to my hometown (VISIT 5) I took it back again and then they took a week to repair it. (VISIT 6) While checking, I saw that the lights (CAPS etc.) were not working so gave it back to them without taking it.

This time, while servicing, they broke some small power cable which took them another week to get parts to. So I got it and was relieved that finally, I could use my laptop again. A few days and I began to realise that my laptop was missing some random keystrokes and my touchpad was not working sometimes (It would stop working sometimes and would work after restarting a random number of times, later stopped working completely).

This time, I was so frustrated that I wrote a huge mail again to the service head in India about how the first service broke my laptop body and how I had faced problems. (VISIT 7) I got a call from the service head in Delhi who asked me to submit the laptop and promised that they would change the body and completely repair it for good. It took 2 COMPLETE MONTHS for them to do that and finally, I got my laptop back. Now atleast it doesnt look like it has gone through all that stuff in the one year.

[PROBLEM] (Thank you patient ones)>

Now after I got my laptop, I formatted it and installed Windows Professional and installed drivers. Well, the problem is the touchpad stopped working soon after. Now my 'ALT' key is not working too. It's been almost a year since I had this laptop and I guess the warranty is soon gonna be over. I hate to give it to the service center cuz half of this year, my laptop was not with me. Also, I am very confused as to if the problem is a software issue or a hardware issue. It is quite improbable that the touchpad would go bad so soon after it was replaced.

I have tried :
1. Formatting and doing a clean install of all drivers
2. Updating the bios with the easy flash method and updating synaptics pointing device and other drivers.
3. Many things ...

Though the forum is full of people who have had a similar problem with a G73, I didn't find anyone with the same problem in a G53. I wonder what I should do. Just to be completely sure, I am thinking about formatting it yet again and installing all drivers from scratch and hoping that something miraculous would happen and deliver me from these problems. It is kinda frustrating (to say the least) to suffer so just because I chose ROG over alienware :'(. I love my machine yet. I have been able to play some amazing games on this whenever I have had a chance to do so (quite rarely).

So can you suggest something ? Should I give it back to the service center yet again ? Or might it be a driver issue ?

12-29-2011, 11:46 AM
Hi Ssshhiivv,

What bittersweet love affair you've had with your G53!..

Bitter,.. because of those sad experiences. And yet sweet,.. because you still love it, in spite of them. :)

I agree with you about your last sentiment. Try to do a fresh install of the Windows OS, then use only
the essential updated/newer drivers.

I would suggest for you not to use the outdated Driver CD (if it's what you're using).
Instead, use the newer drivers that are in the other threads in this forum (if you haven't done it yet).

Best of luck..

12-29-2011, 11:59 AM
Thanks PILGRIM. Yeah, I will do that now then. And come back and report what happens. Its kinda weird because I thought once you format and reinstall windows, the touchpad was supposed to work by default. This one doesn't however. Lemme see this one more time. And yeah, I really do love this machine, though my buddies call it a bad decision :P

12-29-2011, 12:26 PM
Glad to be of conversation with you..

No matter what, I still believe the ASUS G-Series laptops are really affordable and quality ones.
And can even compete with the other high-end brands, provided they are assembled well, and have the apt software to run them smoothly.

It's just that sometimes, things don't happen the way we want them to be.

12-30-2011, 03:13 AM
Tried formatting, Installed windows and put in the following drivers :

Intel 6 Series Chipset Driver
Intel RST
Asus ATK package
Nvidia Graphics driver
Realtek HD Audio driver
Fresco USB 3.0 driver
Touchpad driver
Realtek Ethernet driver
WLAN driver
Bluetooth driver
Realtek multiCard Reader driver

and still the touchpad won't work and also, the keyboard won't detect the 'Alt' key. Even the 'Delete' and 's' key goes undetected unless i really press it hard.

Anyone has any ideas ??? :(

12-30-2011, 03:21 AM
Hmm that is weird..

You did a full fresh install and all the necessary drivers are in too hmm..

Try disable and then enable it again for the touch pad -----> Go to your control panel under mouse properties / device settings / synaptics touch pad v7.4

12-30-2011, 03:38 AM
I tried doing what you said. This is what I got. An error message. Should I install the touchpad again ?


I am currently using an external mouse to work.

12-30-2011, 03:51 AM
Yes, reinstall the driver again.

you can find the driver list over http://rog.asus.com/forum/showthread.php?5224-Drivers-Apps-and-How-to-s

12-30-2011, 03:54 AM
As for the "ALT" issue try reinstall the driver too from the link given

12-30-2011, 04:13 AM
I uninstalled it and reinstalled "Synaptics Scrybe Driver v 15.2.20 - from Synaptics" as given in the link. The sentillac driver refused to be installed. still I get the same error. Is there another driver conflicting ? How do I know which one it is. Also, for the ALT issue, which driver do I need to reinstall ?

P.S. I also tried reinstalling the "Synaptics" driver. Still the same error.

12-30-2011, 04:21 AM
I uninstalled it and reinstalled "Synaptics Scrybe Driver v 15.2.20 - from Synaptics" as given in the link. The sentillac driver refused to be installed. still I get the same error. Is there another driver conflicting ? How do I know which one it is. Also, for the ALT issue, which driver do I need to reinstall ?
Uninstall all existing touchpad drivers, then go into device manager and look at the hardware ID for the touchpad device. Once you know the correct one, only install that driver.

Sentelic touchpads have hardware IDs that start with STLC, while Synaptics touchpads have IDs that start with with SYN. Here's an example:


12-30-2011, 04:30 AM
I tried that now. The problem is there is nothing like a touchpad there. Attaching screenhot. Does this mean it is a hardware issue ?

12-30-2011, 06:37 AM
I assume, from your response, that the HID-compliant device is your external mouse?

If I have followed this correctly, the touchpad had no issues until after a recent clean installation. Then it suddenly became completely unresponsive, and has been so ever since? Is that right?

If that description is correct, it appears that Windows is not detecting a touchpad at all. I don't think that's a driver problem, because (as you already noted) WIndows should detect the PS/2 pointing device and install its own driver by default. I think the two likely causes of this are:

The internal pointing device has been disabled in the BIOS.
One end of the TP cable (or both) has come loose. With all of the disassembly that this unit has been through, it's entirely possible that the M/B end of the cable has been damaged, or that the last time it was re-assembled, it wasn't seated properly. (I've disassembled TPs many times, and this is surprisingly easy to overlook.)

Obviously, you can check the BIOS setting pretty easily. Just make sure the internal pointing device is "Enabled." As for the cable, there's no other way to check it than to open up the computer and look. If you aren't comfotable doing that, it sounds like it's time for another service call. :(

12-30-2011, 07:16 AM
BrodyBoy thanks for your help :)

Appreciated much