View Full Version : Strix DSP not working on windows 10

07-19-2016, 09:05 AM
Hai, I'm having trouble with my headset and I need some solution.

I boutgh Strix DSP headset around March 2015. I'm using it with windows 7 and it works awesome, and then at early this year I upgrade to windows 10.. and it still works awesome.
But around 2 months ago, the headset started not working anymore. After turning on the PC usually the leds around the volume knob on the control pod lit around it,
but this time it doesn't. Only one led flashing and that was it.
I thought the headset were dead, but it's not. Tried it on my cellphone, still works (using the analog extension)
As it turns out, the control pod which connected via usb to the PC isn't recognized by windows. the pop=up message It always say device malfunction.

Tried it with two other computers in my house with windows 10, still no avail. And then I tried it on friend's computer that still using windows 7,
it works perfectly.

I've tried many solution regarding unrecognizable USB that I can find on the web, still doesn't work.

I bought another headset from month, works fine. It's a Logitech G633,

But still, I want my Strix DSP working again. It's more comfortable on my head.

Any solution?
Oh, its also recognized when I plugged it in when I'm browsing my UEFI bios, but it's gone as soon as I enter windows.

01-24-2017, 02:24 PM
The same problem is also available Is there any explanation about this? For the solution. I returned to windows 7 but it did not work again but my friend worked on windows 7 system. I have not tried any of the tests on different windows 10 operating system computers. I used it pretty well 4 months ago. I do not understand what happened. I think this is the crime of ASUS. I will never buy or take away asus products from now onI will tell people about this problem in all the forums and I will raise suspicions into people.