PDA

View Full Version : Windows 10 upgrade messed up colors



Vince11
07-27-2016, 04:27 PM
Hi, so I recently upgraded to windows 10 from 8.1(I upgraded it the normal way no special procedure ASUS G750JM) and everything is fine except for the colors, it looks pretty dull and the whites hurt my eyes, before windows 10 colors were very normal and easy on the eyes. I've done alot of searching and fortunately i'm not the only one experiencing this problem, here are a few threads below.


https://rog.asus.com/forum/showthread.php?72661-Windows-10-on-G751JT-colours-have-lo-fi-look-in-desktop-mode
https://www.reddit.com/r/pcmasterrace/comments/3t0kpq/the_new_windows_10_update_resets_rgb_color_range/
https://www.reddit.com/r/Windows10/comments/3i605e/dullwashedout_colors_after_win_10_upgrade_nvidia/
http://answers.microsoft.com/en-us/windows/forum/windows_10-performance/my-laptop-automatically-updated-to-windows-10-last/2b2d2361-be0b-460f-847a-ee98eb3ac365
https://rog.asus.com/forum/showthread.php?86506-Rog-g750-windows-10-graficos-color
https://www.reddit.com/r/nvidia/comments/3f3xay/windows_10_limited_rgb_problem/
Last link might not be relevant
https://rog.asus.com/forum/showthread.php?48764-750JM-Display-Problem/page2

I belive it roots down to either

1) Full RGB color range turned off in win 10( I cannot find the option to change this)
2) some sort of color profile was changed in win 10

In the first link someone posts that they had sucess in bringing back the normal colors however they claimed to install windows 10 from a usb drive, how exactly would that differ from a normal install?

Thanks to anyone that can offer help or insight into this problem!

Clintlgm
07-27-2016, 06:59 PM
Yes windows 10 is big into high contrast colors, simply change the theme to something other than High contrast.
USB would be a normal way to upgrade or install, far faster than any Optical disk and mostly more reliable.

Vince11
07-28-2016, 12:53 AM
Thanks, However how exactly does this usb method differ from just upgrading to win 10 from your pc? With the usb method aren't you just opening the setupfile from the usb while the computer is running normally? I don't see how this would be different from just simply opening the setupfile stright from my pc.
Also for the high contrast setting I don't belive that is the issue my high contrast is already set to none.

Clintlgm
07-28-2016, 02:28 AM
The USB method was developed early on with windows 8, and 8.1 mainly because of the speed of the USB over Optical, for a full detail of all this jump over to the 10 forums (http://www.tenforums.com/tutorials/), the USB method just has fewer failures and or issues.
So if your issue is not related to High contrast, you must be having an issue with your graphics driver. Have you installed an official Asus or NVidia driver? Windows 10 wants to install there default drivers Asus Support Downloads (http://support.asus.com/download/options.aspx?SLanguage=en&type=1) Try they latest in the windows 10 section, Be sure to Use Manual Install and then select Clean Install

Vince11
07-28-2016, 02:37 AM
I haven't installed anything yet in fear that if this fails and I chose to revert back to windows 8.1 that the problem will carry over. If I start installing all of these drivers won't it affect the roll back to 8.1? Thanks again.

Gps3dx
07-28-2016, 12:39 PM
Before you revert back to win8.... try the following on your win10:

For any ROG laptop Asus released a splendid with unique *.ICM file.
first get on of the oldsplendid installers from the download page FOR YOUR UNIQUE MODEL, for Win8.
extract and browse into "\data\ColorTable" folder and get your UNIQUE *.ICM file FOR YOUR MODEL.

Then get one of the latest splendid for win10, then extract evrything from the zip you download, enter the extracted folder then into "\data\ColorTable" folder, remove any foreign *.ICM file, copy&paste YOUR MODEL.ICM file into tha folder -> then install setup.exe.

Then press "win"/start button and search "color management", open it up -> goto last right tab and make sure under "Device Profile" that your unique .icm file name is selected.

After that just run splendid (open it up also by pressing fn+V or C, I think ) then choose your favorite color profile.
( also from the same tab of "color management" you can initiate "calibrate disply" proccess )

Lastly, I presume in this small guide that your graphics drivers are installed from nvidia site ( NOT ASUS !) for your unique GPU.

Please report back if that helped/not helped.

Vince11
07-29-2016, 01:57 AM
Thanks so much for this, a couple things I noticed right away was that upon opening color management I see no profiles listed here http://i.imgur.com/8138Tb8.jpg (I don't know if this is normal or not).

Secondly I noticed that default was selected (I have no clue if this is normal or not) http://i.imgur.com/3ooc3cT.jpg

Thirdly the thing I noticed was that I had a ton of color profiles and one was named ASUS_G750JM http://i.imgur.com/2vS3LYF.jpg which is my computer model is this suppsoed to be the correct icc profile?

Lastly after I clicked on the ASUS_G750JM profile and closed color management I could not see any differences in color, does this require a restart or have I missed something? Thanks again.

Edit: Oh yeah, I forgot to mention that I already switched back to windows 8.1 and the problem seems to still be here, also some of my computer functions like searching for files also does not work, but I believe I need to rebuild my index.

Gps3dx
07-29-2016, 08:42 PM
I seems that restart is needed in order to apply the color changes.
after you've set your *.icm file for your model, reboot, then launch Splendid and play with its profiles... you should see color chances immediately.
P.S Splendid comes with installed OEM windows of ROG laptops, thus you probably got used to watch the screen when one of its profile was applied and enabled.