View Full Version : G751JM - How do I find the scancode for my "print screen" button?

08-18-2016, 10:39 PM
I posted this here too: https://www.reddit.com/r/techsupport/comments/4y9jry/i_cant_remap_my_print_screen_button_no_matter/

There is a game I play where the "print screen" button automatically saves a screenshot to a folder. There is no way to remap it in the game settings. Using a program like Autohotkey and triggering {PrintScreen} does not work. Using a command line program like Nircmd to save a screenshot just saves a picture of my desktop with a black box. Using Joy2key or "Microsoft mouse and keyboard center" to trigger "Print Screen" using a gamepad or mouse button does not work.
Why do I need this to work? I use an external keyboard with no "Print Screen" button (a small mac keyboard). The Bootcamp drivers use "function+shift+F11" to trigger print screen. But this only works if you have the F keys act as special buttons. If you check the box that lets them work as normal F1 through F12 keys (rather than volume, brightness, etc) the screenshot hotkey no longer works.
And here's the kicker: I tried using SharpKeys to remap "print screen" in my registry. If I open my laptop lid and press "Print Screen" it can't detect what button I'm pressing. If I remap an unused button ("right windows button") to the "Prt Scr" option in SharpKeys, it half works. It will copy the screen to the clipboard, but it seems to be doing it in the same way an autohotkey {PrintScreen} would. The game won't detect it and won't save a screenshot, and if I exit the game and paste I get the black box again.
The only solution seems to be FRAPS, but it's an old game and running things like FRAPS risks causing it to crash (which is why I tried Nircmd and was sad when it didn't work).
tl;dr is there a way to re-map my "true" print screen button using the registry? Why did my registry hack not work in the first place?
EDIT: I didn't explicitly mention it, but opening my laptop lid and pressing Print Screen on my actual laptop keyboard DOES work in the game.

08-21-2016, 12:27 PM
hi there...
I can advise to you to try to use my hack of ATK driver ( aka AsusNbKeys ) to reap fn+other button to behave like printscreen.
( see my sig for a link )
other then that, if sharpkeys doesn't resolve your issue... it much deeper then that, as scan codes @desktop vs @games works DIFFERENT ( some does equal and some doesn't- which is pain in the *** ... that i've learn when i've reprogrammed AsusNbKeys ).