PDA

View Full Version : Asus Rog Sonic Studio not working after update to win 10 10th anv



wcoffee
08-25-2016, 07:17 AM
hi to all of the ROG family.

So i just upgraded my pc to all new parts.. so far happy has hell :D
but some asus rog programs on installation i got this error " not comptable with our version"
so i end up by updating my win 10 to the new win 10 "10th ann".
then all the software strated working fine but no sonic studio.

Allready uninstalled and re-installed all drivers .. no sucess.

can you guys help?

thanks in advance

raodk
08-26-2016, 05:43 PM
Hi

Supreme-Fx HIFI DAC wont work(neither software nor audio output)
Sonic studio application wont launch.(but you do get audio)
I have done lot of messing around with drivers and there seems to be some sort of device clash between these two.
The only stand by solution was to disable supremefx hifi DAC in device manager.
Then sonic studio app will launch.

Micro**** messed up with this build of windows.
We need to wait until Micro**** or Asus(They don't seem to care anyways) provides update.

There are other issues as well here and therte. So i rolled back to build 1511. I wont update to AU until for next 2 months atlest :P

//DK

wcoffee
08-26-2016, 09:13 PM
this is so F*cked up. i just bought all these new parts costed me a fortune and somethings don't even work.
i rolled back to win 10 but after that all my asus graphics card stoped working... " not compatible with this system" thanks a lot asus or microsoft.
so back again to new update and all works fine but still no sonic studio.

i can't even hear quality music on my logitech speakers.

:mad:

scgt1
08-26-2016, 09:25 PM
Here I thought I was the only one with this problem. I just went through hell trying reinstall the Realtech drivers. Kept going to the uninstall and reboot then right back to install yet it would uninstall and reboot. Finally had to remove the Realtech hardware and drivers then run the realtech install again to keep windows from interfering and installing the drivers on reboot which made the Asus realtech driver install just go right back and uninstall then reboot cycle all over again.

So nice to know it was the Anniversary update that killed Sonic Studio from opening. I click the image and nothing happens. :-( I was on win 7 with it working fine. Upgraded to a Samsung 950 Pro 512GB m.2 drive for my OS and installed Win 10 and the anniversary update and viola no more Sonic Studio. :-(

In the process of this I've lost the control panel and Sonic Suite icons and can't seem to find them anymore. Can someone tell me where exactly the files are for these two programs so I can add them back to easy access on my start menu. I don't know why they didn't show up with reinstalling the realtech drivers. Probably something with that right click and do not show in this list deal with Windows 10. So now they are hidden and I don't know how to get them back after reinstalling and loosing the icons on the right side of the start menu. :-(

raodk
08-27-2016, 07:37 AM
Here I thought I was the only one with this problem. I just went through hell trying reinstall the Realtech drivers. Kept going to the uninstall and reboot then right back to install yet it would uninstall and reboot. Finally had to remove the Realtech hardware and drivers then run the realtech install again to keep windows from interfering and installing the drivers on reboot which made the Asus realtech driver install just go right back and uninstall then reboot cycle all over again.

So nice to know it was the Anniversary update that killed Sonic Studio from opening. I click the image and nothing happens. :-( I was on win 7 with it working fine. Upgraded to a Samsung 950 Pro 512GB m.2 drive for my OS and installed Win 10 and the anniversary update and viola no more Sonic Studio. :-(

In the process of this I've lost the control panel and Sonic Suite icons and can't seem to find them anymore. Can someone tell me where exactly the files are for these two programs so I can add them back to easy access on my start menu. I don't know why they didn't show up with reinstalling the realtech drivers. Probably something with that right click and do not show in this list deal with Windows 10. So now they are hidden and I don't know how to get them back after reinstalling and loosing the icons on the right side of the start menu. :-(

Hi

for your driver re-installation issue please look at these blogs to prevent auto installation of drivers by MS when restarting windows as a part of driver installation

http://www.makeuseof.com/tag/take-back-control-driver-updates-windows-10/

hope it helps.

//DK

scgt1
09-04-2016, 04:11 AM
Anyone come up with anything yet? I ran into a different thread that lead directly to current Realtech drivers but Sonic Studio still doesn't work. Upon reinstalling the drivers I still don't have icons for the Asus audio stuff anymore either. Along with loosing the Realtech Audio control panel Icon. I've right clicked on the the audio device in device manager removed the drivers. Then even installed the Realtech drivers off the original cd and still nothing.

I don't have sonic studio or what ever the other audio icon is that installs from Asus, The Realtech control panel is now gone under control panel. This is a joke. $400 board and no support from Asus on this matter or a fix yet.

wcoffee
09-05-2016, 05:43 AM
i've just finished a new clean windows intallation...just figured out

to have sonic sound working perfectly i've perfmormed a clean windows installation to the previous win 10.. after that i installed all drivers except nvidia
and aura / gputweek from asus (to my graphics card).
only then i did the update to windows 10 anniv update.

till there all worked just fine

after that a new update from windows screwed up sonic studio but everything else works fine..

so my conclusion is do a clean install put everything to together and after update to win 10 anniv version do not activate the windows update
until a newer version of realtek/sonic studio comes out

Bahz
09-06-2016, 08:54 AM
I sent you guys a PM with new driver that we hope will fix this issue, please let me know if it resolves the issue for you.

MEGVAGYHADNAGY
09-11-2016, 04:13 AM
I've got the same problem.Can u pls send me that new driver?

MrAgapiGC
09-14-2016, 12:55 AM
just to let all know. the new acumulative update from today in windows 10 stop sonic studio again. i am trying to fix these. if i can.

Gentleman
09-14-2016, 10:59 AM
have same issue....

at this time ROG and supreme FX software is rly bad

I bought ASUS MAXIMUS VIII to get 3 years of peace of mind, but I see that it will be trouble every week

MrAgapiGC
09-14-2016, 05:32 PM
have same issue....

at this time ROG and supreme FX software is rly bad

I bought ASUS MAXIMUS VIII to get 3 years of peace of mind, but I see that it will be trouble every week

I am getting frustrated with asus in these areas. i will try to make the 2011 update and make the same procedures in order to make it work again. Asus please get together.

BIG UPDATE. IF you have your logitech webcam please UNPLUG IT
sonic radar start to work again. Holly bananas on la playa

update/ SADLY again crash. trying to get the webcam working. i am done with it. tomorrow a clean install. if these does not work i am going bag to mac and RMA all.:mad:

Gentleman
09-15-2016, 11:28 AM
agree, if I unplug Logitech HD Pro Webcam C920 - Sonic Studio II works!

So my conclusion is:

Sonic Studio II is a very bad APP - making conflicts with DOOM, if SSII is workind then DOOM will crash, when Logitech Webcam is plugged in then SSII not working

hope u fix this ; /

MrAgapiGC
09-15-2016, 05:06 PM
agree, if I unplug Logitech HD Pro Webcam C920 - Sonic Studio II works!

So my conclusion is:

Sonic Studio II is a very bad APP - making conflicts with DOOM, if SSII is workind then DOOM will crash, when Logitech Webcam is plugged in then SSII not working

hope u fix this ; /

MIne start to work from nothing. i am felling worry. on these case since we did have a bad weather today, i turn off my pc PSU. I am making my last attempt to make all work making a clean installation.

I bet all these issues that i spend hours is a mix, windows issues most. But also the webcam is trash so no games. on Logitech forums are blaming MS cause some h something codex.

Gentleman
09-17-2016, 02:30 PM
OK... sadly I must announce my point of view:

I decided to switch from AMD FX8350 + ASUS SABERTOOTH 990FX to intels i7 6700k + Z170 chipset... my choice wasn't easy, many motherboards on marked have worst and older realtek codec than this one on SABERTOOTH 990FX - ALC892 wchich is 7.1+2 Channel HD Audio Codec with Content Protection, even flagship micro-ATX Z170M-PLUS mobo uses ALC887 (almost ten years old chipset) only 7.1 without support for playback protected high definition audio in full resolution. Because my pc is a multipurpose machine office + entertainment I need a lot of USB ports, again Z170M-PLUS have less usb ports on back panel 2x usb 3.0 and 2x usb 2.0 + useless ps2 ports for keyboard and mice...... LOL !!!!! Old Sabbertooth have 8x USB 2.0 and 2x USB 3.0.... YYYY! 10x USB on back panel just ready to use!!

That why I decided to pay almost twice more and buy MAXIMUS VIII GENE: better, newest audio with support for content protected fullres audio and almost so many usb ports as I need.... OK...

Hovewer im rly disspointed because u claimed your audio is "Best gaming audio – reinvented SupremeFX 2015 with intuitive Sonic Studio II".... it past one year since M8GENE landed on market and still it have childhood issues... TT x1
I must now plug and unplug and plug again camera to Skyping or gaming or streaming... TT x2
I must close Sonic Suit II when going to gaming because it crashing games like DOOM... TT x3
Described issues of Sonic Suite are nothing new, just look around, many forums proves my words about SSII, and proves ASUS do nothing with it...
http://steamcommunity.com/app/379720/discussions/0/350532795335351966/
https://www.reddit.com/r/darkestdungeon/comments/41yh8z/darkest_dungeon_hates_my_sonic_suite_2_app/
http://community.battlefront.com/topic/123274-why-does-sonic-suite-2-prevent-cmbs-and-cmrt-from-launching/
etc.
TT x4
I made a ticket to tech support, almost week ago, and today still NO ANSWER! WTM20160913043944677
TT x5

ANSWER ME why u advertise your MOBO as gaming, and Sonic suite as a gaming, while it is ANTY-gaming?

my conclusion is:

I WANT MY CASH BACK ASAP! Come here take your M8GENE and give me my money.

luckael
09-18-2016, 02:17 AM
you can fixed your problem just follow the steps on this thread below page 11.

https://rog.asus.com/forum/showthread.php?86774-Sonic-Studio-won-t-open-in-WIndows-10-v1607/page11

Bahz
09-21-2016, 01:06 AM
Thanks for sharing the additional details on these issues, I'll pass all of this information over to our software team to review. We'll try to replicate the issues and will work on new version to address these issues.

Wohlever
09-22-2016, 10:07 PM
I can get Sonic Studio to work with the Realtek card inputs, but I can not get it to work with my SupremeFX headphone DAC.
It worked great before the anniversary update with the headphone DAC.
I get an error in Sonic Studio "the default selected audio device will not work with Sonic Studio" (If I unplug my headphones from the supremeFX DAC and plug
them into my onboard headphone jacks (Realtek) then it works fine.
However, I specifically bought the REV5 Edition 10 to get the headphone DAC.

What can I do? I have been pulling my hair out, uninstalling, reinstalling drivers, changing the order of installs. Nothing works except to not use
my headphone DAC.

FezzyIsFoxy
09-22-2016, 11:51 PM
I'm having the same issue too. I only installed the anniversary update yesterday, and since, Sonic studio stopped working. i still have the icon in the windows tray though.

After installing the anniversary update, my audio had horrific reverb applied to it, and i couldn't open SS to turn it off!

However, after seeing the suggestions above about a Logitech webcam being the culprit i tried some things of my own.

I have a Logitech USB Headset always connected, i just switch the output device when i want to use it, and a Blue Snowball mic.

After unplugging both of these, closing SS in the tray and re-opening, Voila! Sonic studio opened and worked fine.

Seems like this might be caused by having an input device connected maybe ??

it's also weird that the windows update applied the reverb effect in sonic studio to max.

Arthurs
09-25-2016, 12:45 AM
I have exact same problem as everyone else here after updating Windows 10 to 10th anniversary. However, thanks to matgalli for uploading working version.

I can confirm that this version works like a charm.
http://www.file-upload.net/download-11853942/SonicStudio2.2.28Realtek7904.rar.html

1. uninstall the old driver! There is no AsusSetup in the rar-Archive. I have used the "old" AsusSetup from the last driver-package to uninstall while disabled Internet-connection, so Windows cant install driver by its own. After the windows-restart cancel the Installer.
2. install the Realtek Driver from the file-upload download
3. install SonicStudio from the file-upload download (open the setup as Admin)

Gentleman
09-25-2016, 11:38 AM
Thanks for sharing the additional details on these issues, I'll pass all of this information over to our software team to review. We'll try to replicate the issues and will work on new version to address these issues.

i found another interaction SSII, this time with microtorrent 3.4.8 b42576 LOL until I shut SSII, micro torrent have WAITING FOR RESPOND state : )))

SSII is a piece of.... u know what ; p

frankieviray
01-18-2017, 04:36 AM
I sent you guys a PM with new driver that we hope will fix this issue, please let me know if it resolves the issue for you.

please send me link to the driver? thank you.

scgt1
01-18-2017, 04:54 AM
please send me link to the driver? thank you.

This may be it

https://www.asuswebstorage.com/navigate/s/E038FB7E6EFE43B2941F6444C1125404Y

It's what I had in my inbox from him on 9/6/16 but I was in direct contact with him asking questions about my problem so not sure if they sent messages more recent with newer drivers or not.

I always forget to even turn the thing on anymore. I actually went to try it about a week ago right before I started Doom. Well Doom loaded with no sound. Yet I could tab back to windows and play something and have sound. Yea spot on with this software. Asus has gone down hill. Yet they still charge a premium for their products. Wish I didn't sell my soundblaster Z. Would take it any day over the onboard with buggy ass half way/no working software. They should stop making their own stuff and team with Creative. Let Creative handle the hardware and software. Their stuff actually works.

MyDNA
04-18-2017, 10:56 PM
Can someone tell me where exactly the files are for these two programs so I can add them back to easy access on my start menu. I don't know why they didn't show up with reinstalling the realtech drivers. Probably something with that right click and do not show in this list deal with Windows 10. So now they are hidden and I don't know how to get them back after reinstalling and loosing the icons on the right side of the start menu. :-(


When you just install the realtek HD audio drivers and not the sonic studio application from ASUS, then you will not get the sonic studio suite installed. To install sonic studio, use your original motherboard [MB] CD and install just the sonic studio suite from there. If you have updated your drivers so that you have newer drivers than what comes on the MB CD, you can search for "SetupSonicSuite_R2.exe" on the MB CD and run that file to just install sonic studio suit, while keeping the updated audio drivers intact.

You can also check your MB model at ASUS support webpage to download updated audio drivers and sonic studio suite, which is newer than what comes with the MB CD.