PDA

View Full Version : Bricked 880M on Asus Rog G750JZ, please help :|



navis995
08-25-2016, 10:51 PM
So, I was a retard and somehow managed to brick my 880M on Asus Rog G750JZ and now it doesn't get recognized anymore (The GPU) nor can I install drivers. I don't know what to do. Is there a way to get it back or did I done goofed?

Thanks the help.

Ancients
08-26-2016, 12:24 AM
Did you do anything to it or was it just working one day and not working the next, without you having done anything?

Areosjc
08-26-2016, 03:31 AM
Is not recognized inside device manager? At all?? If doesn't appear inside you got a hardware problem that's for sure. Check it and tell us if it does.

Good luck!!!

Bill@ASUS
08-26-2016, 09:24 AM
Hello navis995
Can you explain to us that how did you bricked your GPU?
Can you tell us the process?
Did your rig suffer any external impact?
Thank you

navis995
08-26-2016, 11:25 AM
FIXED. Hear all, hear all, I've fixed it and while at it went ahead and created a tutorial for those poor souls who suffer the same faith as I did.
Thanks for everyone who tried to help, I really appreciate it. The video will be uploaded soon and when it is I'll also link it here.

For those who just wonder what , I'll give you something to ponder on as well.

The problem: My gpu was bricked as it a) failed during the flash (Which I believe it did not) b) crashed after the successful flashing (Most likely), more specifically
after trying to launch Rise of The Tomb Raider game.

The state: Any attempt at trying to make the GPU recognizable again was in vain as it was simply broken and non existing (Inside the Windows environment). Meaning no drivers could
have been installed, it was not recognized by any software such as GPU-Z, MSI Afterburner, it was not shown in Device Manager, nothing, nada, it was completely missing and absent
, at least that's what Windows claimed. Even the attempt of flashing a new bios failed (Again inside the Windows environment).

The solution: Essentially installing it outside the Windows environment, that is in DOS to be exact. So there were many steps on how to do that (More in the video that will be uploaded),
and after that everything is back to normal.

The video will be uploaded in few hours so in case anyone else comes upon this thread, he can use it and save his poor GPU bios :)

navis995
08-26-2016, 03:29 PM
https://www.youtube.com/watch?v=qSlgOZZMKU8

winyl
11-03-2016, 07:01 AM
You should never flash your Vbios from Windows cmd. Do it from clean DOS. Do it from windows and you have 99% chance of bricking your graphic card. From what you say you where lucky enough to get video at all after cmd flash. This was probably a HWID mismatch. Image what might have happened, if you did not get video output at all. Blind Vbios flash :).