View Full Version : OS X El Capitan on G751JT (Partially working)

09-02-2016, 10:25 AM
Hello ROGers! It has been 4 months past after my last attempt trying to install OS X El Capitan on this monster laptop, I decided to give it one more try and boom! El Capitan installed successfully and booted into the home screen with nVidia Web Drivers installed. GTX970M fully working without any graphical issues (yay!)
I used a clean OS X El Capitan installer taken from my good old dusty 2011 MacBook Air (Finally, it's useful only for Hackintosh builds xD)

In this case, I used a clean OS X El Capitan installer taken from my good old 2011 MacBook Air (Finally, it's useful for Hackintosh builds xD) instead of using Niresh and iATKOS.

No 3rd party KEXTs/Drivers installed yet because I couldn't find working ones. Tried installing Niresh's AIO Audio Solution to get the audio working as told by this forum post and it does nothing until now lol.



What's working out of the box:
Sleep (Partially)
All 4 USB ports

What's not working:
WiFi + Bluetooth (Needs a hardware replacement, stock is unsupported)
On-Board Speakers and Mic (Will finding a solution to make these work)
Power+Battery Status/Management

Audio only works with an external device such as Corsair VOID USB, etc.

I will post screenshots/tutorial soon once i get the necessary stuff to work. Going to try installing OS X using iATKOS EL soon. I saw a post of it installed on a G751JT with almost everything working but that was Yosemite. Hopefully it'll be the same for El Capitan. Fingers crossed!

Feel free to ask any question if you're interested in this setup.
If any of you managed to get the necessary devices to work on-board audio and mic to work, it would be nice if you share it here :)

09-02-2016, 12:12 PM
Good luck with that!

09-02-2016, 05:29 PM
Update: I got the trackpad and keyboard to work...

06-13-2017, 10:05 PM
...why would you ever want to run an Apple OS on your laptop? D:

; ) (Quite cool in a way, are you still running it?)

06-14-2017, 02:40 PM
...why would you ever want to run an Apple OS on your laptop? D:

; ) (Quite cool in a way, are you still running it?)
Sure... I would love to have MAC on my G751jt...
last time I had tripleboot of win+ubuntu+mac was when I got my 1st ROG laptop: G51JX - around 6 years ago...

about the status of "sleeping" being "partial"...
AFAIK, this related to ACPI and/or CPU states ( like C-state ) which you need modded kext for that....
About Wifi...
apparently, there isn't any "intel wifi" support whatsoever... so if no official kext exist... no text mod can be exist either...
someone tried and have done a "port" ( from linux I guess )...
see HERE: ( it states that 7260 is supported ).
and its github HERE:
BUT the bad news is that its status is: "This driver does not yet actually connect to wireless networks."

I'd be happy to have a short guide describing of tools ( bootloaders ) and what did you checked in the setup screen during installation ( if any special buttons were chosen ).