View Full Version : G751JY Bios update help

09-02-2016, 04:47 PM
Whats up guys? so ive been trying to restore my bios back to stock. ive downloaded the normal bios from the asus website and tried to flash it via AFUWIN64 but keep getting an error saying bios sizes do not match. whats going on here? both bios, the new bios, and my current are for this model.

09-02-2016, 05:40 PM
mine is the 4720HQ version of the notebook.

09-02-2016, 05:47 PM
It's the Aptio signature at the beginning of the ROM. ASUS ROMs (your model in this case) is 6146KB and the modified versions will be 6144KB (invalidating signature = removed). You either can perform the Easy Flash BIOS Recovery method (CTRL+HOME) with a formatted FAT32 USB drive using the downloaded BIOS specific to your model or if you had made a backup (always make backups) before flashing a modified one, simply flash the backup with AFUWIN64; Saving your BIOS image with AFUWIN64 also removes the signature as well.

The error "sizes do not match" is due to that discrepancy with the signature capsule.

Another way to solve this is run UEFITool and open the downloaded ASUS BIOS image with it. Simply go to: AMI Aptio capsule -> UEFI Image -> Right-click it and select "Extract as is..." and save the ROM with a different name. What this does is remove the capsule signature so that the ROM is 6144KB just like your current one is. Now AFUWIN64 can be used to flash back to stock at any time (say if you forgot to make a backup for instance).

09-02-2016, 11:36 PM
awesome! it worked! quick question though, so in XTU if i do any intensive task, it says that only 2 cores are active. if i disable Hyper threading in bios, and run the XTU, it says 4 cores are active. this also happens with games and other things as well

09-04-2016, 08:40 AM
any idea? or do you think its just the program acting up?