PDA

View Full Version : Spatha 2.108 update woes



28BeersLater
09-05-2016, 11:07 AM
Has anyone else had issues with the latest ROG Armoury / Spatha update?.

I was an early adopter of this mouse, (ordered on release day, managed to find stock!) and so it's been excellent.. it feels solid, looks great and is accurate.

I had a few issues this morning though, when checking for updates via the Armoury application, "New update found" I figured I'd switch to "wired" mode to save being prompted later and ran the update (from the Armoury application itself).

All went as normal until the firmware upgrade, where I clicked "next" and lost mouse control, with nothing happening. I waited a few minutes not wanting to interrupt, (as sometimes these can look unresponsive) but in the end gave up, and instead of crashing out/ / rebooting and risking a partial firmware flash, I plugged in another mouse (standard USB mouse) and pressed "next" again, to my surprise the install then continued.. a bit odd I thought but left it too it.

Once the update had finished I had No wireless functionality, no lighting, and limited button use.

I rebooted tried again. I swapped to wired, and got another prompt to update firmware, and did so. same issue.

In the end I uninstalled Armoury, reverted to a previous version, installed it without the Spatha plugged in, plugged it in and let it update, it now seems to work, I then uninstalled that version, rebooted, installed the latest and it seems to work, but the profiles don't save properly (mainly lighting, but this was always slightly buggy).

Reported Versions are:
Software: 2.108
Dock Firmware: 1.24
Mouse Firmware: 1.49

(Are these firmware versions the latest? I'm sure that's what they were before)

Have other people experienced these issues?

PC Spec:

ROG Rampage V extreme (dock and mouse connected directly, no hubs)
i7-5930k @ 4.4 GHZ
Windows 10 Pro x64 "Anniversary" update
(rest of spec in my profile!)

Bahz
09-06-2016, 08:13 AM
I didn't experience this issue and I can confirm that you do have the latest driver and firmware. The profiles currently are not supposed to save after update as this is the design to make sure that all settings are cleared on the mouse once updated. I actually have mentioned this to our peripheral team and I was told unfortunately that there won't be any way to transfer over the profiles at this moment in time.

Which part of the lighting settings are you having issues with? Any additional information that you can provide will be very important for us.

Thanks,
Bahz

28BeersLater
09-06-2016, 11:09 AM
Thanks for the reply,

And it's good to know that I'm on the latest firmware.

Sorry I didn't clarify, I wasn't expecting "Pre Upgrade" settings from copying across, this is just from closing and re opening the Armoury Application.

The issues are:

Opening armoury and setting "light brightness" for wired usage. on re opening it, it has reset from the left but 1 setting to the left most (off). This doesn't seem to reflect the actual mouse value.

If I then click to other profiles in Armoury, and clock back to profile 1, (that I have edited) the colour (and possible other settings) from the previous profile that I clicked on are displayed, and no longer match the physical properties that the mouse is displaying, despite the fact that the "shown" profile does not match the actual profile, the "Save" button is greyed out.

On close inspection its probably more likely a Refresh issue on non default profiles on Armoury.

Yes I am the main Admin user, and UAC is turned off.
I get the same results of I close Armoury and run it as "right click admin"

It's more of an annoyance than a issue, (although the software upgrade "braking" it was an issue...)

Bahz
09-08-2016, 04:20 AM
Thanks for the additional details, I'll definitely share this information with our peripherals team.

lordofdarkness2006
02-13-2017, 08:19 PM
Hello to everyone, today i upgraded spatha firmware, after this my mouse doesn't work. It works only in wired mode, but armoury doesn't read my mouse in none mode. How I can solve? Thanks

update: I solved plugging usb to a back port (motherboard's one). Then my pc flashed firmware to spatha and everything works fine.

28BeersLater
12-27-2017, 04:38 PM
I just updated Armoury (Auto update didn't work, but there was a new version on the Asus website) and once again I am having exactly the same issues (no wireless functionality at all, and limited buttons working, no lighting).. I've rebooted, run as administrator, (UAC is off) The issues persist. I only went looking for an upgrade as the mouse sems unreliable anyway, and frequently needs the doc disconnecting and reconnecting.

What is the warranty on these Mice? Maybe it just needs RMAing.