View Full Version : ASUS G550JK Battery Charge Issue? solved?

09-15-2016, 02:33 AM
I have an ASUS G550JK that just stopped charging... The battery charge light flashes orange anytime the charger is connected. If the charger is connected, the laptop says "plugged in, not charging" so I am able to run the PC off of AC... but I am unable to charge. Any suggestions on what may be wrong? The issue started today. I have tried restarting the computer, that didn't help. Original charger and battery. Any suggestions would be great, I am fine changing the battery or charger if need be, but would rather only try one if there is a general concensus.


Note: I doubt it caused it.. but apparently there was a Windows update today according to my Windows update history. Might try uninstalling that one update and see if it does anything.

09-15-2016, 03:02 AM
Not sure how or why it happened, but I talked to ASUS support and they were able to help me out. They gave me some steps to follow and it ended up fixing the issue. I am posting them here in case anybody in the future may have the same/similar issue.

I have Windows 10, so these steps might be different on another version.

Steps taken:
1. Press the "WINDOWS key" and "X".
2. Please select "Device Manager" from the menus.
3. Please expand Battery. You should see Microsoft ACPI Compliant Control Method Battery.
4. Double click Microsoft ACPI Compliant Control Method Battery and under the driver tab you should see Uninstall.
5. Proceed to uninstall the driver and it prompts you to delete driver software, leave the "Delete Driver Software" box unchecked.
6. Please turn off the unit and remove the charger (power adapter).
7. Please oress and hold the Power button for about 60 seconds.
8. Connect the charger to the unit.
9. Please turn the unit on and quickly press the F2 key on keyboard to enter BIOS.
10. Please press the F9 key in the BIOS to load optimized defaults and select yes to confirm.
11. Please press the F10 key to save and exit.

The above steps fixed my issue. Just one note: I did not have a box titled "Delete Driver Software", so I had to skip that part of step 5. Still worked though!