PDA

View Full Version : G752VS Disable Touchpad when USB mouse connected



The Cool Dude
09-21-2016, 04:27 AM
Hello there.

Just got this laptop and I cannot set it to automatically disable the touchpad when I connect my USB mouse. I have to Disable the touchpad completely using Fn+F9. This is a workaround but I'd rather have it work properly.

I've reinstalled the touchpad drivers and the ATK package but nothing has solved this issue.

I have found an issue when I have my USB mouse disconnected and the touchpad enabled. If I go to the mouse settings, there is an option there called "Leave Touchpad on when a mouse is connected". When I turn this off, then the touchpad is completely disabled when the expected behaviour is that the touchpad should stay enabled.

Having it set this way should leave the touchpad enabled and then when I connect my USB mouse the touchpad should automatically disable but it does not.

Has anyone else noticed this?

Thanks in advance.

httuner
09-21-2016, 05:23 AM
I never knew there was such an option; Hmm I can't seem to find it_ I search touchpad / mouse settings but can't find the option your speaking of; I always thought this was normal to have to turn it off completely by yourself_

Would be a nice little feature to be able to disable it when a mouse is plugged in and enable it when mouse is unplugged.

warryabel
09-21-2016, 12:15 PM
it came with asus smart gesture in elan touchpad driver

The Cool Dude
09-22-2016, 02:10 PM
Hi there.

It sounds like your mouse settings are not the same as mine if you don't see this option. I'll include screenshots to help in the translation.

59536

When I go into the actual control panel, I don't have a touchpad tab where there are usually more options than what I currently have.

59537

Any assistance on how to correct this would be greatly appreciated.

Thanks!

warryabel
09-22-2016, 02:16 PM
Hi there.

It sounds like your mouse settings are not the same as mine if you don't see this option. I'll include screenshots to help in the translation.

59536

When I go into the actual control panel, I don't have a touchpad tab where there are usually more options than what I currently have.

59537

Any assistance on how to correct this would be greatly appreciated.

Thanks!

it would be cool when people more investigate hisself...error layer8 has u read what ive posted!? on win 8.1 and g751 the software called asus smart gesture!!!and now u need a screenshot..?

The Cool Dude
09-22-2016, 07:02 PM
A picture tells a 1000 words. Just trying to be helpful.

I have the G752VS-XB72K with Windows 10 Pro.

My G752VS didn't come with a gesture software package installed nor does it show up in the download section of the support page for my model if that makes a difference. It seems like it is built in to the driver for the touchpad because otherwise the gestures would not work in the first place.

Also, ASUS Smart Gesture is not for my laptop according to this from ASUS as my touchpad has physical left/right buttons. http://www.asus.com/support/FAQ/1009641/

warryabel
09-23-2016, 05:57 AM
lol...have physical left/right too....and now?59539

The Cool Dude
09-23-2016, 02:08 PM
warryabel, are you actually trying to be helpful? Every post on this thread from you have been nothing but condescending.

warryabel
09-23-2016, 04:57 PM
thats your meaning...not my problem when you cant see the info
cry more pls
p.s the info was my touchpad has two physical buttons and i use smart gesture+atk package without probs!
smart gesture isnt available as download,it comes with elan touchpadblabla and there are many infos on net about smart gesture and win10,especially aniversaryupdate!

i play the game try and error and you?

cl-Albert
09-23-2016, 06:08 PM
Just got this laptop and I cannot set it to automatically disable the touchpad when I connect my USB mouse. I have to Disable the touchpad completely using Fn+F9. This is a workaround but I'd rather have it work properly.


Hi The Cool Dude, and welcome to the forums.
Sorry I'm not able to confirm this on a G752VS unit first, but look for the touchpad icon in your taskbar notification area in the bottom right of the screen and double left-click on the icon if you see it.

Expect you're still using the original pre-installed Windows image, but if not, you may want to make sure the touchpad driver from the ASUS download site has been installed which should include the gesture software as you mentioned.

Hope you don't mind if I provide an unrelated link below for the picture, but post #6 has a screenshot of the touchpad icon for the G750JZ model if you're interested (I'm not sure right now if you will see it on the G752VS, but worth a try?).
http://rog.asus.com/forum/showthread.php?34995-Win8-Games-Minimizing-because-of-touchpad-solved&country=&status=

JustinThyme
09-24-2016, 05:58 AM
The operation of this has been flaky on all ASUS ROGs, every single one of them I have owned. Sometimes it works, others it does not. Right this moment on my G752VY it will turn off the touch pad but if I disconnect the mouse it wont enable as it should. The makes for a real PITA if you are using a wireless mouse and the battery dies.

The Cool Dude
09-24-2016, 07:34 PM
Thanks cl-Albert and JustinThyme.

Well I tried installing Asus Smart Gesture and rebooted. Although it is successfully installed, I have no icon for the touchpad in the notification area, and my mouse properties have not changed at all. So it would appear that ASUS's site was correct that the Smart Gesture software is not for the G752VS.

If I come up with a solution I'll post back. In the meantime, if there is anyone out there with a G752VS that has a solution, please let me know.

Also, I am still running on the stock Windows 10 build from ASUS. I was thinking of formatting and reinstalling Windows but I've only had this laptop a week and haven't had the chance.

Thanks everyone.

The Cool Dude
10-05-2016, 03:54 PM
Hello everyone.

I've formatted my drive on my G752VS and reinstalled Windows 10 clean and then reinstalled all the drivers and ASUS Utilities such as the ATK driver and the Gaming Center software.

The issue remains. This never happened with my G750JH.

I'm not sure if the issue is either with the drivers or the Asus Gaming Center software, but this is something that ASUS needs to have a look at.

The Cool Dude
10-15-2016, 01:04 AM
Hi there.

Installing ATK Package 1.0.0049 from here:

http://ivanrf.com/en/latest-asus-drivers-for-windows-10/

seems to have solved the issue with my touchpad.

Thanks!

The Cool Dude
10-16-2016, 02:13 AM
Looks like I spoke too soon.

Installing ATK Package 1.0.0049 is no better than 1.0.0044.

My touchpad is always enabled after waking from sleep. :-(

The Cool Dude
11-23-2016, 02:05 AM
Hello G752VS OC owners!

This is still an issue for me. Every time my G752VS OC edition wakes from sleep my touchpad is enabled even though I disable it with FN+F9.

Is anyone else having this issue?

I'm currently running:
ATK Package 1.0.0050
ASUS Precision Touchpad V11.0.13

I do not have the ASUS Gaming Center software installed as I am using ThrottleStop.

Looking forward to your reply.

MDFMac
11-23-2016, 02:57 AM
why would you put to sleep? that thing has never worked correctly since 3.1 lol on or off.... move on

Gabrielos1070
12-13-2016, 08:36 AM
i finaly find a way i desinstald all the sinaptic... ptp... smart gesture... etc from my computer afther very simple on windows update 10 serch for update and is instaling automatic the proper driver for the touch pad and if works new if i clouse the computer screen and coputer enters in sleep when i open it is working just fine with all the skils of the older smart gesture like 2 and 3 fingers zoom in / out .....etc

steam name: gabrielart hope was useful if not contact me

BogdanCiulei
12-13-2016, 09:28 PM
It seems that Microsoft released a Windows Update called "ASUS - Other hardware - ASUS Precision TouchPad"
This finally solved my issued with the touchpad.

Check that you have this . If still having issues, download the drivers for the touchpad from Asus , run them and choose uninstall ( or do it from Device Manager ).
At reboot, Windows should install the correct updated driver.