View Full Version : Upgrade to 372.20 or 372.90 nvidia drivers breaking fast boot at mine g751jy - solved

09-21-2016, 10:00 PM
Upgrade to 372.20 or 372.90 nvidia drivers (from 368.22) is breaking fast boot at mine g751jy Windows 8.1 home x64bit.
Tested twice... with DDU and without DDU...

At event viewer - System:
1. Fast boot failed - error 0xC0000001.
2. Last shutdown was unexpected.

param1 0x000000fc (0xffffe00197509090, 0x8000000155c009e3, 0xffffd00020bd9920, 0x0000000000000004)
param2 C:\Windows\MEMORY.DMP
param3 092116-22640-01

4. System has been started without clean shutdown.

Restoring the system to the previous state (before update of drivers) fixes the problem.

09-22-2016, 01:13 AM
Go to here; Control Panel\Hardware and Sound\Power Options\System Settings_

Uncheck; Turn on Fast startup(Recommended)

This way when it reboots you start fresh and not leave traces of old drivers behind.

09-22-2016, 06:54 AM
Thank you. I will try... However I doubt it will fix the problem as I have already tried sevaral times to use at cmd: "shutdown /s /f /t 0" - that is forcing full shutdown.... not hybrid one needed for fast boot...
So I presume this would remove "the traces".

And I really appreciate Fast Startup/Boot so I do not want to disable it permanently... as this is how I understand your advice/workaround.

Also to explain g751jy problem better:
When using 368.22 drivers if I start the default shutdown (hybrid one) then laptops shuts down little bit slowly.
But the startup is fast = few seconds... And both is expected...

When using 372.20 or 372.90 drivers if I start the default shutdown (hybrid one) then laptop shuts VERY fast... around 50% time faster then if using 368.22
And this in NOT expected.
But during the startup when I get: 1. Fast boot failed - error 0xC0000001. - it actually means BSOD IMHO!
However I can't see BSOD screen as the laptops instantly reboots again... giving few next errors at System Even Viewer:
2. Last shutdown was unexpected.
3.param1 0x000000fc (0xffffe00197509090, 0x8000000155c009e3, 0xffffd00020bd9920, 0x0000000000000004)
param2 C:\Windows\MEMORY.DMP
param3 092116-22640-01

And performs standard long lasting startup.
4. System has been started without clean shutdown. (due to: Fast boot failed - error 0xC0000001)

So I think the problem is actually that the default hybrid shutdown hibernation file created by the system during shutdown is somehow corrupted if using 372.20 or 372.90 as the shutdown if unexpectedly faster!

Anyone has similar problems?

09-22-2016, 10:36 AM
@Sanctrum - try to run in cmd with admin privileges, to turn OFF hybernation: "powercfg -h off"
this should eliminate the hiberfil.sys found on C: root folder.
run it again with "on" to enable it back.

Thus, I recommended that you disable them BOTH, and get a proper SATA III SSD for your G751JY - which will make your hole "desktop user experience" rocking to the roof AS BOOT AND RESUME FROM SLEEP WILL BE FAST ( 3 and 20 sec accordingly ).
I have a good experience with my samsung EVO 850 120GB, BUT I bought it 1 year ago, and today @the same price you can get the 250GB - which is FASTER !
( a general thumb rule in the ssd world is that the larger the capacity, the faster the Write and read sleep will be comparing to the lesser capacity from the same serie of product ).
Also, since you're already on win8, I suggest you upgrade ( it could still be free ) you win8>win10... win10 boot is faster, and compared to win8.1 its "desktop user experience" (ON THE SAME HW) is faster - IMHO.
Don't be afraid from UI changes for the "win"/start button, as there and many apps ( inc totaly free ones ) that can replace the appearance of the start menu.

if you'd like help from me about upgrade, you can post a reply in the sticky thread of mine about windows installation ( see my sig ).
Just please note since 29.7.16 had passed - it isn't 100% sure that win8/8.1->win10 upgrade is still possible (to be done for free) - but there are many reports on the web that it still is, although MS published otherwise.

09-22-2016, 12:41 PM
Thx. I will try out your hints and report back.

However as for upgrading to Win10, I am 100% convinced I will skip it as long as possible... as I do not like it (not because of Start Menu as I get used to it).

Win10 is at my understanding still "at beta" stage (no stable, few annoying bugs and "hick-ups", networking and driver problems, etc...) ... in comparison to Win8.1 and also is UGLY as hell :-).

09-23-2016, 06:09 AM
Fast boot is over rated. All you are doing is dumping whats in memory to hiberfil.sys which in my case equates to 64GB of unnecessary writes every time I shut down which I dont want on my SSD.
Then it just resumes dumping that back into ram. Its more like a renamed BS hibernate. Whatever problem you have when you shut down is still going to be there when it starts back up as drivers are the number one thing it dumps from the ram to the drive and the first to load coming back up.
I have it disabled on all my machines and my slowest boot time is on My G752VY at a whopping 10 seconds.

Do yourself a favor and turn that garbage off and leave it off.

I'm running Win 10 anniversary update on everything and have had zero issues from it.

09-23-2016, 12:55 PM
@JustinThyme - I appreciate your opinion.

I have only 8GB RAM. I have HDD, not SSD. I do not have M2 PCIE port.
So my standard boot time is around 30-45 seconds in comparison to fast boot 7-10 at average seconds at HDD - and no problems after 2 years of laptop usage - till today.
However I am performing full shutdown from time to time (twice per month) to "sanitize" the laptop.
Also during the hybrid shutdown AFAIK system is not dumping all RAM but only dumping/updating the small % section related with UEFI + kernel + drivers...
So the drivers are the most common root cause of fast startup problems.
As hybrid shutdown is not hibernation of all RAM - so it is faster and much better... as does not contain all other application related garbage from RAM.

I am also using Win10 with anniversary update at other laptop. It is working ok (with some annoying glitches - related with poor system GUI desing) but... NOT WORTH updating and losing my time for that.

P.S. I did not test ANY of all of you friends' hints above... due to lack of time. I will do it maybe next week, since currently everything works fine with 368.22.
Also I always prefer to fix things without any reinstallations/upgrades to new OS'es/third party tools that are mostly more spoiling than fixing- this approach is working for me since Windows XP release and is building knowledge...

Unfortunately both hints with disabling/enabling fast boot and disabling/enabling hibernation did NOT work.

However I have successfully downgraded (not using system restore point) from 372.90 to 368.22 with clean install and then upgraded from 368.22 to 368.81 also with clean install option... and fast boot is still working.
So there are several options: upgrade process from 368.22 to 372.90 is buggy; or my initial 368.22 installation was corrupted, or 372.90 drivers are buggy.
I will keep you informed... if I successfully (step-by-step) upgraded to 372.90 or not. If not, I will stay with 368.81 and I will wait for better drivers.

Fail... Also the upgrade from 368.81 to 372.90 spoils fast boot. So I am going back to 368.81 and wating for the FIX.
ALSO I have noticed strage thing with 372.90 ...

Sometimes when laptop starts just before the custom logon screen backround is loaded the default one is shown (this ugly "rainbow" stripes) for fraction of the second. And this is normal... but 372.90 they are acctually "changing" the default 8.1 logon screen backroud (this ugly "rainbow" stripes) to the solid blue color like at Win10 before the custom background loads... Why?

09-25-2016, 07:12 PM
I have reported the problem at nvidia official forum,

03-27-2017, 07:16 AM
Sorry for digging this out but it is working ok now.
Fast boot is no longer broken by Nvidia drivers at mine Win8.1 with 378.92

The short story:
I kept using 368.81 drivers (Geforce Experience 2) for a long time to make fast boot operational to avoid BSOD during the startup when it is enabled (since I am still using HDD so I also have fast boot enabled).
I kept trying upgrading from time to time (but skipping some versions) to check if this was fixed or not...
In the meantime I kept my Win8.1 always updated with all critical and optional patches except the Realtek drivers visible at Windows Update. Also my system had no errors at "sfc /scannow" and have no other issues ever except problems with Nvidia drivers after 368.81 version during the startup.
I am also still using the old BIOS (version 205 or 206 I believe) that was factory-loaded = I have never upgraded it.

So after the long break I tried to install 378.92 this Saturday. But THIS TIME I simply picked the option for express install (instead of the clean one) over 368.81... so it also upgraded GeForce Experience to ver 3.
After the reboot (and also after the full shutdown) my Geforce Experience 3 started to give the error: "Something goes wrong. Try restarting GeForce Experience".
I have fixed the above in no time by downloading both 32 and 64-bit versions of Visual C++ Redistributable Packages for Visual Studio 2013 here https://www.microsoft.com/en-us/download/details.aspx?id=40784 and selecting "Repair".

And that's it.
GeForece Experience 3 is working. 378.92 drivers are working way better than 368.81 at COD: infinite warfare and other newer games. I can use official Fast Sync instead of beta Fast Sync at 368.81 ... and what is most important fast boot is no longer causing BSOD during the system startup.

Maybe this will help someone with the same problem I had at Win8.1