PDA

View Full Version : Mad Catz R.A.T. 3 mouse laggy jerky movement on USB 3.0 port on Asus G751JY



korimitsu
09-25-2016, 01:26 PM
Ok this is the issue I've got with my Asus G751JY, latest BIOS and drivers:

When I connect my Mad Catz R.A.T. 3 mouse to any of the 4 USB 3.0 ports, the mouse pointer moves laggy and jerky. It happens on any situation, either browsing the web or playing games. The temporary freezing is periodic with the same pattern.
However, If I connect the mouse to a hub with has USB 2.0+3.0, on any of its ports, it just goes perfect.

Is this a problem of the mouse or of the computer, and how can I fix it?

Gps3dx
09-25-2016, 01:51 PM
if another mouse doesn't got that issue... so it is with the HW of the mouse OR the SW configuration of your windows... i.e driver ( maybe a special one is needed ) or software configuration....

I'm guess this mouse got a special config software....
also, goto the mouse manufacturer and search for FAQ or support...and look for that issue there.

korimitsu
09-26-2016, 03:16 PM
Ok, after further testing, there's definitive information about the issue:

The mouse freezing happens when I connect my Toshiba USB 3.0 external hard drive to any port USB, alongside with the Mad Catz RAT 3 mouse. No matter which one goes in what port.
However, if I only have the mouse connected, it works perfectly.

The result, I am afraid I'm having the infamous issue with the motherboard:

G751 - PROBLEM WITH USB3.0 PORTS (LEFT SIDE) AND EXTERNAL HD... ANYONE ELSE? (https://rog.asus.com/forum/showthread.php?53877-G751-Problem-with-USB3-0-ports-(left-side)-and-external-HD-anyone-else)
[G752VY, G751JY] EVERLASTING BUG OF USB 3.0 LEFT PORT RANDOMLY DISCONNECTING (https://rog.asus.com/forum/showthread.php?84635-G752VY-G751JY-everlasting-bug-of-USB-3-0-left-port-randomly-disconnecting)

korimitsu
10-01-2016, 09:50 AM
After further testing, I've found out that the issue happens even when only the mouse is connected, except that takes longer for the issue to happen.
So, although connecting some external usb drive makes it to happen faster, it happens too when only the mouse is connected.

- The operating system is Windows 10 64 bits
- Tested the Mad Catz RAT 3 mouse under ubuntu, + the Toshiba USB 3.0 external hard drive + Corsair GTX USB 3.0, and it works perfectly so far so good, so indeed looks more like a software issue.
- Connecting the mouse to an usb hub and then the hub to the computer makes the mouse work without issues, however if I connect an external hard drive to the same hub the transfer speed is very slow.

Here are some screenshots, using official drivers from Mad Catz and official Asus drivers for the G751JY from the official site, nothing patched or modified:

http://i65.tinypic.com/2ef0yur.jpg
Screenshot from device manager showing "Mice and other pointing devices" and "Universal Serial Bus controllers"

http://i67.tinypic.com/fxarlk.jpg
"Mad Catz R.A.T. 3 Mouse (HID)" driver properties
Driver Provider: Mad Catz
Driver Date: 7/18/2016
Driver Version: 7.0.57.16
Digital Signer: Microsoft Windows Hardware Compatibility Publisher

http://i66.tinypic.com/2s8jn2g.jpg
"Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)" driver properties
Driver Provider: Microsoft
Driver Date: 7/15/2016
Driver Version: 10.0.14393.0
Digital Signer: Microsoft Windows

http://i65.tinypic.com/9idc1j.jpg
"USB Root Hub (xHCI)" driver properties
Driver Provider: Microsoft
Driver Date: 7/15/2016
Driver Version: 10.0.14393.0
Digital Signer: Microsoft Windows

http://i65.tinypic.com/2cib87o.jpg
Placing a USB 3.0 hub between the external hard drive and the USB port (does not work well)

http://i66.tinypic.com/bhefmb.jpg
Connecting the external hard drive directly to any of the port of the G751JY (with either Mad Catz or Logitech, mouse issue happening or not, the transfer goes perfectly)

korimitsu
10-01-2016, 09:58 AM
More light on the issue:

I've bought a few hours ago a new mouse, the Logitech G502 Proteus Spectrum, and luckily it works always perfect directly on the USB 3.0 port. That leads me to think that the issue is probably with the Mad Catz mouse itself.
I'll try to install now the latest modded driver from WINRAID's forums + the signing key.

korimitsu
10-01-2016, 10:53 AM
Ok, after installing the modded Intel drivers, the issue happens exactly the same. Few minutes after connecting the Mad Catz, it freezes for a second and continues periocally. Definitely, this is an issue with either the mouse itself, or the mouse driver. It already surprised me from the beginning that both Logitech M325 and Logitech G502 Proteus Spectrum didn't experience the issue, neither with Microsoft drivers not with Intel drivers.

In order to be able to install the modded drivers, I've got to do two things:
1) Install Win-RAID CA Certificate. There's a "ImportCertificate.cmd" file that you need to run as administrator and will do the work for you. The certificate "Win-RAID CA.cer" is also included.

2) Enable Test Mode and Disable Driver Signature Enforcement. Some users says that it's not necessary once you have the certificate, but I had to do it, otherwise I get "Access denied" when trying to install the modded drivers.
Open command terminal as administrator and type:
bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS
bcdedit -set TESTSIGNING ON

- The file that includes the 64 bit modded version + certificate is the following:
* URL: http://www.win-raid.com/t834f25-USB-Drivers-original-and-modded.html
*File: "64bit Intel USB 3.0+3.1 Drivers v5.0.0.32 mod+signed by Fernando.rar"

Here are screenshots of the newly installed modded intel driver (keep in mind that the Mad Catz keeps failing anyway):

http://i65.tinypic.com/fmnpuf.jpg
Update Driver Software - Intel(R) USB 3.0 eXtensible Host Controller - 1.0(Microsoft)
Right click -> Update Driver Software -> Browse my computer for driver software (locate and install driver software manually) -> Let me pick from a list of devices in my computer -> Have Disk... -> Browse -> iusb3xhc.inf

http://i67.tinypic.com/2myzy9.jpg
Then, after a reboot, in Device Manager will appear an Unknown device, which will be the "USB Root Hub (xHCI)".

http://i64.tinypic.com/3808p.jpg
Then you select the Unknown Device and do the same as the previous step, but now choose iusb3hub.inf and reboot.

http://i65.tinypic.com/6z3t02.jpg
After a reboot and new drivers installed, this is how Device Manager looks like with the modded drivers.

http://i65.tinypic.com/102peu9.jpg
Concentrador raz Intel(R) USB 3.0 Properties (modded driver)
Driver Provider: Intel(R) Corporation
Driver Date: 8/18/2016
Driver Version: 5.0.0.32
Digital Signer: Win-RAID CA

http://i66.tinypic.com/210afqh.jpg
Controladora de host Intel(R) USB 3.0 eXtensible Properties (modded driver)
Driver Provider: Intel(R) Corporation
Driver Date: 8/18/2016
Driver Version: 5.0.0.32
Digital Signer: Win-RAID CA

Now I'll contact Mad Catz and see if they can help me to solve the issue.

korimitsu
10-01-2016, 11:55 AM
Looks like the issue has happened before!

Mad Catz R.A.T. 3 Mouse problems (USB PORTS PROBLEM) (https://rog.asus.com/forum/showthread.php?45509-Mad-Catz-R-A-T-3-Mouse-problems)

Definitely it's a mouse /mouse driver issue. I'll contact them on monday when live chat support is available, let's see if they can solve this mess once for all.

korimitsu
10-07-2016, 08:31 PM
After replacing the Microsoft drivers with the Intel ones, Ive got temporarily this error when connecting the Mad Catz to the G751JY:

http://i65.tinypic.com/nnmuwy.jpg

http://i68.tinypic.com/10f7wp1.jpg

No controllers found.
Plug in the device you wish to configure and run the program again.

You can report this error by emailing the text below to
http://support.madcatz.com/Tickets/Submit

Exception
Exception has been thrown by the target of an invocation.

InnterException
System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.
at IWshRuntimeLibrary.IWshShortcut.get_Description()
at Saitek.File.ShortcutInformation..ctor(IWshShortcut shortcut)
at Saitek.File.Shortcut.GetShortcutInformation(String shortcutFilename)
at Saitek.FileIcon.GetShortcutIcon(String path)
at Saitek.FileIcon.GetFileIcon(String Filename, Int32 index)
at Eclipse_Litetouch_Keyboard.ProgramItem.ProcessFile (String programming)
at Eclipse_Litetouch_Keyboard.ProgramItem.SetProgramm ing(String programming)
at Eclipse_Litetouch_Keyboard.PopulateProgramSelectio n.PopulateApplicationSelectionThreadSafe(String Filename)

SmartTechnology.exe has stopped working
A problem caused the program to stop working correctly.
Windows will close the program and notify you if a solution is available.

korimitsu
10-07-2016, 08:38 PM
Finally contacted Mad Catz support via live chat. The official response is that the R.A.T. 3 is only guaranteed to work correctly on USB 2.0 port. USB 3.0, although may work, it's not officially supported by the manufacturer.
So the workaround is to use some USB hub and that's it.
I complained to them that in the box doesn't mention anything like "USB 2.0" only or something like that, and I don't think on the website does it either.
No idea, but probably all mouses work best on native USB 2.0 ports? It is supposed to be compatible, but hey, at least there's an easy workaround.