View Full Version : G752VL: Sonic Suite 2 Won't Open

10-26-2016, 11:32 PM
I downloaded installed the V6.0.1.7831 update for the Realtek Audio Drivers last night. To my understanding, the SS2 is already bundled with the audio drivers upon installation. After installing, I wanted to open SS2 in order to config a few things, however, it wouldn't open. I tried reinstalling but still SS2 would not open. Sonic Radar opens fine, but not SS2. I've also tried a standalone installer for SS2 but it comes out as "installation could not proceed: the device is not supported". I'm stumped. Google hasn't helped so far.

Any tips on how to fix this? I've also tried system restore to no avail. If I can't get SS2 working, I'm just going to have to stick with DFX for now.

10-27-2016, 12:32 AM
here (https://www.sendspace.com/file/rcqku6) It seems that it is NOT bundle in driver.

Thanks to Dreamonic for the link :)

10-27-2016, 01:22 AM
Thanks! But I can't seem to install it. I keep getting the error: "installation could not proceed: the device is not supported" when the installer says "Checking the presence of APO".

EDIT: After retrying the installer over and over again, it just installed. Thanks again for the link! Got it up and running. :D