View Full Version : [G752vy] Buggy AHCI Mode in BIOS up to 2.13. Do not switch to AHCI on NVME SSD.

11-01-2016, 01:25 PM
Warning. Do not switch to AHCI.
The driver in BIOS is buggy or outdated. It won't properly detect and present M.2 NVME SSD to the system.
If you get "WINDOWS BOOT MANAGER" as a boot option without the name of your SSD trailing it, update to 1607 will BSOD with 0xc0000225 or 0xC1900101 - 0x20017 in Windows Setup. If you copy Win10 to NVME SSD and change to AHCI Mode Win10 will boot and work, but it won't be able to install major update like 1607 or do system reset.

If you only need AHCI Mode for a working Samsung Magician DO NOT SWITCH TO IT.You will cause yourself many problems.

1.Simple reenabling RAID driver in registry will not work,due to how Win 10 is installed.It will BSOD with INACCESSIBLE_BOOT_DEVICE.
2.Simple clean install on NVME SSD will NOT WORK due to IRQ_NOT_LESS_OR_EQUAL BSOD or WATCHDOG_VIOLATION BSOD when loading IRST RAID driver in WIndows Setup.

The solution is to reinstall it on the SATA3 drive and then copy/clone it back to NVME SSD, but without formatting or wiping the OS Partition. Just let it install it will say it will move current Windows folder to WIndows.old. There is a hidden folder Recovery, it contains usmt.ppkg with all factory ASUS drivers and apps. You can install your apps and drivers and make your own provisioning package (http://www.tenforums.com/tutorials/11769-provisioning-package-create-windows-10-a.html). Put the original Asus usmt.ppkg somewhere safe. You will need it when you sell your G752.

If you want to reenable the factory reset/RECOVERY WINRE.
You do that at YOUR OWN RISK. Your partitions may be different. If you break something do not blame ME.

You have to go to Admin Console and do

DISKPART> list vol
You can see 4 partitions:
1.System FAT32 Boot partition
[.MSR(Microsoft Reserved) Partition it will not show but it is there. Can be seen with Minitool Partition Magic.]
2.OS partition - C: drive hopefully
3.Data partition - D: drive
4.RECOVERY Partition

Now at this point if you get two recovery partitions,sometime Windows Setup will put a new one. You will have to delete the first partition after os C:. you better do that from MiniTool Partition Magic. You can extend you OS to deleted recovery. Remember you do that only if you get two recovery partitions. Original ASUS recovery should be always the last one. IF you get RAW instead of NTFS on Recovery, Explore the partition from Minitool PW and reboot Windows. Diskpart should now detect it as NTFS.

DISKPART>sel vol 4
DISKPART>assign letter R

Number of your recovery volume will be the last partition hopefully, mine is 4.
IF you get mixed up letters you have to do sel vol number and remove and assingn letter, so it lists OS as C, Recovery as R. Volume 0 will be cd drive hopefully.
If cd has no letter assign a E letter to it or assign E letter to your usb drive with windows 10 install.

DISKPART>sel vol 1
DISKPART> remove
DISKPART>assign letter c

If you ever did system reset you need Windows 10 1511 install media,as system reset will delete C:\$Windows.~BT\Sources. You have to copy sources folder from cd/usb to C:\$Windows.~BT\Sources. If you don't have $Windows.~BT input

mkdir $Windows.~BT
attrib +h $Windows.~BT
copy e:\sources c:\$Windows.~BT\Sources

Now if you copied or confirmed that you have install.wim in C:\$Windows.~BT\Sources and Recovery partition has letter S assigned, do in admin console:

reagentc /disable
reagentc /setreimage /path S:\Recovery\WindowsRE /target C:\Windows
reagentc /setosimage /path C:\$Windows.~BT\Sources /index 1
reagentc /enable

You should get answer "Operation successful" on all commands. Now you all set to do system reset. Just input systemreset in admin console.
Remember this will not work if you formatted or wiped the C: (OS) drive,as you deleted the hidden c:\Recovery folder which is a part of factory recovery at least in my case.

11-05-2016, 11:51 AM
There's a much simpler and faster option to switch RAID<->AHCI:

No need to edit registry.

1. Run Command Prompt as Admin
2. Invoke a Safe Mode boot with the command: bcdedit /set {current} safeboot minimal
3. Restart the PC and enter your BIOS during bootup with F2 (...note by Hexaae).
4. Change from RAID (...note by Hexaae) to AHCI mode then Save & Exit.
5. Windows 10 will launch in Safe Mode.
6. Right click the Windows icon (or use WIN+X ...note by Hexaae) and select to run the Command Prompt in Admin mode from among the various options.
7. Cancel Safe Mode booting with the command: bcdedit /deletevalue {current} safeboot
8. Restart your PC once more and this time it will boot up normally but with AHCI mode activated.

Discussed here: https://rog.asus.com/forum/showthread.php?84587-G752VY-issue-with-M-2-speed-after-resume-from-sleep&p=588732&viewfull=1#post588732

11-05-2016, 07:02 PM
Yeah I know. But I am switching AHCI -> RAID, because AHCI is buggy as hell. Read what I have written.

11-05-2016, 11:59 PM
And the process is the same, you just have to set RAID instead of AHCI in point 4 as a fact I've written RAID<->AHCI ;)
Please, notice also that in RAID mode the G752VY controller is buggy as well: after Sleepmode or Hibernation read/write speed will be halved (https://rog.asus.com/forum/showthread.php?84587-G752VY-issue-with-M-2-speed-after-resume-from-sleep&p=588732).
But I don't have G752VY anymore to test latest BIOS with Win 10 AU...

For very latest AHCI Intel RST drivers browser here: http://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=select&id=103&lang=en

11-06-2016, 08:04 PM
I know, just did not work for me. Got INACESSIBLE_BOOT_DEVICE, after trying to revert back to Raid. I don't know why, maybe because Boot folder in on the first partition and os on 3rd. I just had it with it and reinstalled and brought back the factory recovery online and reset my G752vy. Anyway thanks for trying to help.

11-06-2016, 10:49 PM
It's normal behavior. Unfortunately normal Windows boot, when you switch RAID <-> AHCI (or vice versa) from BIOS still tries to use the last installed drivers (e.g. AHCI, but you're booting in RAID mode now...). Only safe mode has this useful ability to "understand" what kind of disk driver is currently required.
Following step by step https://rog.asus.com/forum/showthread.php?88586-G752vy-Buggy-AHCI-Mode-in-BIOS-up-to-2-13-Do-not-switch-to-AHCI-on-NVME-SSD&p=615455&viewfull=1#post615455 you will skip the bluescreen INACESSIBLE_BOOT_DEVICE error.
The trick concept (and it works...) is based on the fact you use safe mode to let Windows adapt to the correct disk driver for normal boot (= no safe mode) without errors.

A similar situation can happen also to users that uninstall Intel RST AHCI drivers thinking that on next required reboot Windows will auto-switch to Microsoft AHCI drivers: but on next normal boot you may get INACESSIBLE_BOOT_DEVICE since there is no driver installed at all to pilot disks, for normal Windows boot routines. Bad OS design (for non tech-savvy users at least). Safe mode will do the trick.
There is also another way that doesn't require booting in safe mode: you have to MANUALLY FORCE the disk drivers you want from Device Manager and on required reboot you must access the BIOS and switch there the controller mode accordingly...

11-30-2016, 11:01 AM
i am also having this problem. cant revert back to raid from ahci. even with the invoke safemode. i wont pass and i always get a blue screen. can any1 please help me?

12-19-2016, 08:59 AM
I written in the first post what you have to do. What seeems to be the problem?
As per official Asus support reply: "You can reinstall win10 from usbpen, as reinstalling from CD will cause BSODs when loading Raid driver."

07-02-2017, 10:25 AM
So it turns out it was my Sammy 950Pro that died out somehow on me. First thing I noticed it was I could not install big updates like Anniversary Update(which in fact did install after a few retries),Creator update. That the 950PRO has not shown up in nvme controller in bios and sometimes my G752 would boot and sometimes it would not boot and show no boot device found error. So my 950PRO after almost (short 4days) 12 mths of usage died and it went on warranty and since 950PRO in not availabe in my store I am getting 960PRO instead. Nice :) Wonder how log this one will last.
Sorry for the stir up as I wasen't sure want is going on.

07-03-2017, 02:01 PM
Interesting first M.2 SSD I've heard of that failed. So the symptom are quite different from Spinners and S.M.A.R.T was no help either. I wonder did you run any diagnostic programs on it to see if it was failing? Which ones if you did and they failed to warn you or you just didn't believe the results? Or there just are none that understand these SSD to be able to evaluate them for failing conditions? I Guess we'll have to find one that can see and read the S.M.A.R.T on drives in RAID Mode?

07-08-2017, 01:43 PM

07-08-2017, 02:00 PM
There where no errors detected in test aps. 950PRO had the latest firmware. My G751vy would just sometimes not boot and display No BOOT DEVICE error. Most of the time it would boot. Most reoccuring error was 0xc0000225 BSOD (https://i2.wp.com/www.techinpost.com/wp-content/uploads/2016/05/Error-Code-0xc0000225.png) when installing major update to Windows 10. Installer could not detect it on reboot. Then I looked inside nvme screen of bios and it was empty,like there was no NVME2 SSD, but inspite of this my G751vy would most of the time boot fine. Although boot failures where comming much frequent. And it was not like 3 sucesses and 1 failure it was like 50 sucesses and 1 failure, so it was hard to detect something was wrong. A first it would boot every time, 'cause I remeber problems with Anniversary update, which eventually installed. I was not so lucky with Creators.
First symptom was 0xc0000225 BSOD with Creators and Anniversary update, although the 950PRO would show up in nvme bios section, then lack of the device in nvme bios section, but not from the start. If I tried to copy hdd or another ssd to it, the app (i used minitool partition wizard) would freeze after 20-30 secs.
That where all the symptoms I can remember.
Eventually I bought another Sammy m.2 SSD and all was good with it.So I RMAed the 950PRO.
I know Samsung accepted the RMA and I am getting 960PRO. End of the story.

07-09-2017, 01:41 AM
interesting, with few failure we really don't have any idea how these SSD fail. Running in RAID mode we really can't read the SMART data.
I have found the best way to do these major upgrade of windows AU CU etc is to use Media Creator and then run the upgrade from within window from the USB Drive. Lots less issues with the upgrades this way.
The upgrade middle of June caused my CPU to have one core running 80% all the time and cause a few BSOD drove me crazy for awhile then update came first part of July and fixed it all?
Thanks for sharing how your M.2 NVME SSD failed. Hopefully someday Samsung will figure out how to get Magician to see through the RAID drivers