PDA

View Full Version : G752VS low performance?



kemble9900
11-12-2016, 10:47 AM
Hi, I have the G752VS (non-oc) and When I played GTA V on high settings I was only getting 50-60 fps, any ideas why my old G752VY used to play this game ast 60-70fps, any help would be greatly appreciated.

hexaae
11-12-2016, 11:17 AM
Drivers issues with 10x0 series. Take a look at NVidia Geforce drivers forum...

kemble9900
11-12-2016, 08:25 PM
Drivers issues with 10x0 series. Take a look at NVidia Geforce drivers forum...

So that means it'll be fixed soon ish?

hexaae
11-13-2016, 11:26 AM
Read here, recent topics about latest drivers releases: https://forums.geforce.com/default/board/33/

kemble9900
11-16-2016, 07:40 PM
Read here, recent topics about latest drivers releases: https://forums.geforce.com/default/board/33/


I've updated my drivers to 375.86, by my perfromance is still low :( also I couldn't find any threads on there relating to my issue they seemed to all be about desktop 1070s, any idea where/when this could be fixed? thanks.

Armesis
11-17-2016, 03:41 PM
Go into the Nvidia control panel, 3D settings - Configure surround, physx, and select the GPU as the processor. That may help.

There is also another graphics control panel which by default is set to POWER SAVING. I cant seem to remember which one, nor can i find it anymore, but i do remember it was the default setting when i got my new G752VY. Set it to PERFORMANCE, obviously. I hope you can sort this out, these laptops are a handful.

miguel pereira
11-17-2016, 04:26 PM
What are your temperatures while playing?
Is your power profile set to Performance? Are you using batery or power outlet?

kemble9900
11-17-2016, 08:33 PM
Go into the Nvidia control panel, 3D settings - Configure surround, physx, and select the GPU as the processor. That may help.

There is also another graphics control panel which by default is set to POWER SAVING. I cant seem to remember which one, nor can i find it anymore, but i do remember it was the default setting when i got my new G752VY. Set it to PERFORMANCE, obviously. I hope you can sort this out, these laptops are a handful.

I've checked my settings and I've changed a few now but still no luck unfortunately.

kemble9900
11-17-2016, 08:35 PM
What are your temperatures while playing?
Is your power profile set to Performance? Are you using batery or power outlet?

Hi, outlet all the way, and my temps are around 80-85C for the cpu (load) and 55-65C for the gpu

miguel pereira
11-17-2016, 09:08 PM
Those GPU temps are on the low side, My guess is that the GPU is not with 100% load. Install afterburner and leave it logging the activity and game for some time and after it check what was lhe load in % for that game.

One other note, could it be the g-sync active? Try to deactivate the g-sync and see what fps do you get. You have the 60hz screen or the 75hz screen?

kemble9900
11-18-2016, 07:22 AM
Those GPU temps are on the low side, My guess is that the GPU is not with 100% load. Install afterburner and leave it logging the activity and game for some time and after it check what was lhe load in % for that game.

One other note, could it be the g-sync active? Try to deactivate the g-sync and see what fps do you get. You have the 60hz screen or the 75hz screen?

I checked the tmps as you suggested and the GTA V benchmark got the temps to 75C and the firestrike to about 80-85C, also yes I do use g-sync, i'd assume this is a driver thing as i used to have a g752VY with the 980m that would do this game same settings at 60-75fps

miguel pereira
11-19-2016, 11:11 AM
Do you have this behaviour on other heavy games like witcher 3 or something like that? Or is it just GTA?
Are you sure you're not using some kind of super-sampling? Do you use game experience from NVIDIA?