View Full Version : G752VL wont finish Windows 10 upgrade after reboot.

11-20-2016, 09:51 PM
2 x Samsung 950 Pro SSD's running in BIOS AHCI mode

After the latest Windows 10 upgrade which appears to be a substantial one I rebooted and was presented with an error msg advising the process couldn't continue and would revert back.
Has anyone experienced similar? I suspect that it might have something to do with drivers for the SSD chips since they host the OS and boot drive.

Thanks, W.

11-21-2016, 04:05 AM
Download the Windows media creation tool (https://www.microsoft.com/en-us/software-download/windows10), download the windows 10 ver you have single language pro core etc. Create an Install USB. This will download the latest version of windows. So While in Windows start the upgrade by right clicking the .exe file on the USB, Select the whether to clean install or to keep your programs and data. You might have better luck using this procedure

11-21-2016, 03:01 PM
Is this something you have tried with success yourself? Bear in mind I only have SSD's
I take it this procedure will retain all of my programs, files and setting?

thanks of the response. W

11-21-2016, 04:30 PM
Yes this how I upgraded to the AU Anniversary Upgrade, on the one computer that I have upgraded to the AU, if you look on the window 10 forum you will see it is the preferred method of upgrading. Updates are another thing. Your question was for upgrading not updates?

During the upgrade set up you will be asked if you want to save you DATA and PROGRAMS it will work either way but pay attention don't click anything until your sure of what you are doing.

11-22-2016, 01:24 PM
At the moment its just a particular update that is failing on the reboot, however I do want to install the Anniversary edition upgrade which should cover this update anyway.

After running the Media Creation Tool did you select upgrade this PC or the other option to save to disk for another PC? I presume that if I save to disk I could then run it from this PC and it would upgrade. That way I would have the file in case of any issues and can run again if required without having to download it again.

Thanks, W.

11-22-2016, 02:38 PM
Yes W I would run the windows media creation tool on the Notebook that you intend to use it on. Its not necessary but suspect some drivers particular to your notebook would be incorporated in the image?
A failure of an individual update is probably caused by some other corrupted files on your notebook Many answers can be found Here (http://www.tenforums.com/windows-updates-activation/) Ten forum is the best place for update issues. Some are known issues and work arounds are figured out.

Again as you said the AU completely writes and new version windows and will leave a window.old file so that might just fix you up. However keep in mind that you are running a upgrade windows install so you could run into the same issue. In which case you'll need to figure out what's causing the problem. or clean install the AU

11-22-2016, 04:43 PM
Understood. I must admit that I have huge concerns about running into issues with being able to restart after the upgrade due to the Samsung 950 Pro SSD 512 drive in AHCI mode,
and problems encountered in threads like this: https://rog.asus.com/forum/showthread.php?88197-G752vy-W10-Anniversary-update-install-fails-on-internal-SSD-with-winload-efi-missing

I just attempted to do the update again this time from the microsoft website https://www.microsoft.com/en-us/software-download/windows10
and encountered an error on reboot winload.efi Error code: 0xc0000225
luckily it rolled back and I was able to start the computer again.

Is there something I'm missing with regard to drivers for the Samsung 950 SSD drives. There still appears to be some incompatibility with the BIOS. -W.

11-22-2016, 07:16 PM
Well I'm not sure? you said your running it in AHCI so your not using the IRST RAID Driver? otherwise your going to need the IRST Driver in the upgrade package. I'm not clear on this as at first there was no option for AHCI and then you had to have the IRST Raid Driver running to boot. You might want to go over GPX thread on installing UEFI he added a section on the G752 specifically you may get a better understanding of what the issues are http://rog.asus.com/forum/showthread.php?76993-Guide-How-to-install-windows-8-8-1-10-The-proper-way-(UEFI-based-installation)

11-22-2016, 07:22 PM
I had the same issue with my G752VL, but I don't have a SSD (m.2 or SSD HD) in my system.

The only way I could get Windows 10 AU installed was to do the following.

Try this :

1/ Make a backup of the current system (image the boot drive).

2/ Go here >> https://www.microsoft.com/en-us/software-download/windows10

3/ Select the first option 'Update now' (This will update the system to the AU version of Windows 10).

4/ Leave the PC alone while the update downloads and installs.

The above worked for me.

11-27-2016, 11:41 AM
I was able to get the Windows 10 Anniversary Edition to install on my G752VL with Samsung Pro 512 SSD installed. I can't be 100% sure why it installed but I'll note the path taken to get there.

Downloaded EasyUEFI and ran the option to 'Rebuild EFI System Partition'

Downloaded the Media Creation Tool and performed an 'Upgrade on this PC' from this link (note: Do not use the 'Update Now' option) :

After the files finished downloading, Windows restarted and began the installation and completed successfully.

Regards, W.