PDA

View Full Version : ROG Button 3D Functionality



PILGRIM
01-03-2012, 07:22 AM
How do I solve this inconvenience?

I've updated my laptop BIOS into 203. When I toggle the ROG button, an icon (i.e. a red car halfway out of a monitor)
appears on screen. However, it DOESN'T really turn on/off 3D.

I still have to go to nVidia Control Panel or start menu shortcuts just to enable/disable it.
My current nVidia driver is the 290.53 version. I've tried the other previous versions, but to no avail.

Any idea/s, guys?

BrodyBoy
01-03-2012, 07:23 AM
Have you tried re-installing the ATK Package?

PILGRIM
01-03-2012, 07:26 AM
Okay, will do that..

Update: Re-installed ATK Package 100014. The ROG button still doesn't function.

dstrakele
01-03-2012, 02:55 PM
When you re-installed ATK Package 1.00.0014, did you UNinstall first, REBOOT, then re-install?

If not, try this before you do - right-click on the ATK Package in "Control Panel - Uninstall a program" and choose "Repair" from the popup menu. Does that resolve your issue?

PILGRIM
01-04-2012, 03:11 AM
Yes, I uninstall it first, rebooted, then re-installed. I also tried to repair it under Control Panel.

Still, no success. I'm thinking mine is just an isolated case. One poster told me in his thread that
his ROG button is working..

Well, not really a problem for me. Just an inconvenience because I can still use 3D by accessing the
nVidia Control Panel. I just wished the ROG button could be of some use, so..

Thanks, guys, for lending a hand.

PILGRIM
01-20-2012, 04:54 AM
@dstrakele: Problem solved!..

Now I really understand what you were saying (your detailed explanation is on the Nvidia 3D vision?! thread).

Here's how I did it as per instructions:
1. Un-installed ATK Package 1.00.0014. Rebooted.
2. Re-installed ATK Package 1.00.0014.
3. Un-installed all components of nVidia 290.53 Version (via IObit Uninstaller). Rebooted in Safe Mode.
4. Ran Driver Sweeper and removed all driver remnants. Ran CCleaner, too. Rebooted.
5. Installed nVidia 285.62 whql. Rebooted.
6. Opened nVidia Control Panel > Set up stereoscopic 3D > ticked Enable Steroescopic 3D.

Then I tested 3D mode by running COD Modern Warfare 3.
While on game, I toggled the ROG button off, game went to 2D.
Toggled it on, went back to 3D mode. Success!..

This is a case of user-induced failure or simply not knowing the "how-to".
@ASUS, the fault is mine. I take back my words about the fault being yours..

"Maraming Salamat" (Thanks a lot) to dstrakele and BrodyBoy.

ADDENDUM:
a.) It's advisable to deal with the ATK Package first, then the nVidia driver next.
I'd been doing it the other way around without any success.

b.) Make sure all nVidia driver remnants are thoroughly removed- clean the registry,
and delete any OLD NVidia root file/s in the Windows Program Files. This to avoid different
driver version conflicts that might cause other "headaches" later.

dstrakele
01-20-2012, 05:17 AM
+1 @PILGRIM - I think your detailed steps can help others resolve not only your issue, but that of persistent "Timeout Detection and Recovery" (TDR) issues, where the screen goes blank and then recovers with a message that the video driver has recovered. They indicate there could possibly be remnants of the video driver after uninstallation that continue to cause problems after the video driver is reinstalled.

istorm
07-24-2016, 03:13 PM
@dstrakele: Problem solved!..

Now I really understand what you were saying (your detailed explanation is on the Nvidia 3D vision?! thread).

Here's how I did it as per instructions:
1. Un-installed ATK Package 1.00.0014. Rebooted.
2. Re-installed ATK Package 1.00.0014.
3. Un-installed all components of nVidia 290.53 Version (via IObit Uninstaller). Rebooted in Safe Mode.
4. Ran Driver Sweeper and removed all driver remnants. Ran CCleaner, too. Rebooted.
5. Installed nVidia 285.62 whql. Rebooted.
6. Opened nVidia Control Panel > Set up stereoscopic 3D > ticked Enable Steroescopic 3D.

Then I tested 3D mode by running COD Modern Warfare 3.
While on game, I toggled the ROG button off, game went to 2D.
Toggled it on, went back to 3D mode. Success!..

This is a case of user-induced failure or simply not knowing the "how-to".
@ASUS, the fault is mine. I take back my words about the fault being yours..

"Maraming Salamat" (Thanks a lot) to dstrakele and BrodyBoy.

ADDENDUM:
a.) It's advisable to deal with the ATK Package first, then the nVidia driver next.
I'd been doing it the other way around without any success.

b.) Make sure all nVidia driver remnants are thoroughly removed- clean the registry,
and delete any OLD NVidia root file/s in the Windows Program Files. This to avoid different
driver version conflicts that might cause other "headaches" later.

hi. i recently bough a g53jw , reinstalled windows10 everything was fine. after few nvidia update my stereo 3d COMPLETELY gone. i tried your solution but it didnt work. tried a clean nvidia install , still nothing. tried the old drivers with the standalone stereo 3d driver , still nothing. BUT , i got the stereo 3d option in windows' settings. but nothing happens. everytime i try to install the new stereo 3d driver ( only the stereo driver) it says my display doesnt support 3d options or whatsoever. its really annoying
if someone still active here please help! i want to play in 3d again :(
thank guys.