PDA

View Full Version : G74SX 91234Z 3D On Off Issues



malmallen
01-03-2012, 07:40 PM
Firstly the issue is nothing to do with the latest BIOS (which solved another 3d issue) it has that installed, and perhaps someone else has the same issue. When 3D stereoscopic is all set and working and you press the ROG enable/disable button adjacent to the power button to disable the 3D if you open IE9 browser say Google you will find it has enabled itself again which requires you to press the button again to disable it and will enable itself again when you open up a fullscreen Youtube video all of which are 2D. It seems to be a driver/button issue to me and surely disabling via the button should uncheck the driver enable/disable box in the nvidia control panel but it doesn't, and the driver does not seem to distinguish between 2D/3D images. Any help would be appreciated.

dstrakele
01-04-2012, 02:09 AM
What version ATK Package and NVIDIA driver are you running?

Do you observe issues with any of the other hotkey buttons or function key combinations?

PILGRIM
01-04-2012, 05:40 AM
@malmallen: When you enable stereoscopic 3D in the nVidia Control Panel, then try to disable it by pressing the
ROG button, do you see the (checked box) stereoscopic 3D being unchecked in the nVidia Control Panel?

I asked this question because I have a similar issue with the ROG button. It doesn't really work on my laptop.
(I talked about this on my thread: http://rog.asus.com/forum/showthread.php?8908-ROG-Button-3D-Functionality)

I can only enable/disable 3D usage by going to the nVidia Control Panel or the Start Menu shortcuts.

malmallen
01-04-2012, 07:14 PM
What version ATK Package and NVIDIA driver are you running?

Do you observe issues with any of the other hotkey buttons or function key combinations?

BIOS - 203
Nvidia - 285.62 for GTX560m
ATK - 1.0.0008

I do not use any other hotkey functions so i cannot comment on those. As I have said the driver does not seem to distinguish between 2D and 3D and the button does not disable the driver by unchecking it in the control panel although it will able/disable a 3D image or video whilst watching, so it appears to have functionality but is not in tandem with the driver by completely disabling it when required by unticking the driver in the control panel which always remains ticked.

malmallen
01-04-2012, 07:30 PM
@malmallen: When you enable stereoscopic 3D in the nVidia Control Panel, then try to disable it by pressing the
ROG button, do you see the (checked box) stereoscopic 3D being unchecked in the nVidia Control Panel?

I asked this question because I have a similar issue with the ROG button. It doesn't really work on my laptop.
(I talked about this on my thread: http://rog.asus.com/forum/showthread.php?8908-ROG-Button-3D-Functionality)

I can only enable/disable 3D usage by going to the nVidia Control Panel or the Start Menu shortcuts.

You have the same issue as me

dstrakele
01-04-2012, 07:36 PM
The other function hotkeys do simple things like turn the volume up or down, turn the keyboard backlights on, off, up, or down, or disable/enable the touchpad. For troubleshooting purposes, I wanted to see if these were also inoperative.

In "Control Panel - Uninstall a program", right-click on the "ATK Package" in the program list and choose "Repair" from the popup menu. Does this resolve your issue?

If not, go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey and double-click HControl.exe to execute it.

You believe it to be a driver problem. So do I. That is why I asked what version ATK Package and video driver is running on your system. Perhaps upgrading to a more recent version can solve your problem. If you choose to do so, I recommend downloading and extracting (if necessary) the new NVIDIA driver, booting into Safe Mode, then executing SETUP.EXE to install the driver, choose "Custom Install" and be sure to check the "Clean Install" checkbox. Booting into Safe Mode will reduce the number of running drivers that could potentially interfere with your NVIDIA driver installation. Choosing "Clean Install" will remove your current NVIDIA driver first, increasing your chances of a successful installation.

malmallen
01-05-2012, 06:34 PM
The other function hotkeys do simple things like turn the volume up or down, turn the keyboard backlights on, off, up, or down, or disable/enable the touchpad. For troubleshooting purposes, I wanted to see if these were also inoperative.

In "Control Panel - Uninstall a program", right-click on the "ATK Package" in the program list and choose "Repair" from the popup menu. Does this resolve your issue?

If not, go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey and double-click HControl.exe to execute it.

You believe it to be a driver problem. So do I. That is why I asked what version ATK Package and video driver is running on your system. Perhaps upgrading to a more recent version can solve your problem. If you choose to do so, I recommend downloading and extracting (if necessary) the new NVIDIA driver, booting into Safe Mode, then executing SETUP.EXE to install the driver, choose "Custom Install" and be sure to check the "Clean Install" checkbox. Booting into Safe Mode will reduce the number of running drivers that could potentially interfere with your NVIDIA driver installation. Choosing "Clean Install" will remove your current NVIDIA driver first, increasing your chances of a successful installation.

Thanks for the advice, I have tried your ATK repair/execute suggestions but problem still remains I have the latest version of the Nvidia graphics driver (285.62 for GTX560m) unless there is a beta version available, the ATK version is 1.0.0008 which is the latest version. As for other hotkeys they perform absolutely perfectly. I always do a clean install of the graphics driver but not in safe mode as you suggest, I may try doing that with the existing driver to see if this sorts things out.

PILGRIM
01-05-2012, 06:53 PM
Thanks for the advice, I have tried your ATK repair/execute suggestions but problem still remains I have the latest version of the Nvidia graphics driver (285.62 for GTX560m) unless there is a beta version available, the ATK version is 1.0.0008 which is the latest version. As for other hotkeys they perform absolutely perfectly. I always do a clean install of the graphics driver but not in safe mode as you suggest, I may try doing that with the existing driver to see if this sorts things out.

So now, there are two of us having this ROG button issue.

I'm currently on the nVidia 290.53 beta, for I've tried experimenting on the previous versions (280.26 / 285.38 / 285.62) without positive result. I've done all ATK repairs suggested by BrodyBoy and dstrakele both here and on my thread, but still to no avail. My ATK Package is the 1.0.0014 version. Hotkeys all work fine except this
now useless ROG button.

I'm guessing the BIOS 203 didn't fully address the 3D usability of the ROG button.

malmallen
01-05-2012, 07:04 PM
So now, there are two of us having this ROG button issue.

I'm currently on the nVidia 290.53 beta, for I've tried experimenting on the previous versions (280.26 / 285.38 / 285.62) without positive result. I've done all ATK repairs suggested by BrodyBoy and dstrakele both here and on my thread, but still to no avail. My ATK Package is the 1.0.0014 version. Hotkeys all work fine except this
now useless ROG button.

I'm guessing the BIOS 203 didn't fully address the 3D usability of the ROG button.

Yes I think this is a driver issue and as you suggest the ROG button should tick/untick the driver in the Nvidia control panel when pressed which it clearly does not. The 203 BIOS update as far as I can recall addressed a different issue to do with the ROG/Power Button where the power button was performing the ROG button function. We will probably have to wait for Nvidia to sort this out which wil take a while.

PILGRIM
01-06-2012, 02:57 AM
Another thing I've noticed: While the stereoscopic 3D dialog box was opened on the nVidia Control Panel,
I found out that Enabling 3D using nVidia shortcuts in the Start Menu works, even if the 3D
dialog box is unticked.

For me, this is a weird behavior between interactions of the nVidia Control Panel, the ROG button, and the
nVidia shortcuts in the Start Menu.

malmallen
01-07-2012, 09:50 AM
Another thing I've noticed: While the stereoscopic 3D dialog box was opened on the nVidia Control Panel,
I found out that Enabling 3D using nVidia shortcuts in the Start Menu works, even if the 3D
dialog box is unticked.

For me, this is a weird behavior between interactions of the nVidia Control Panel, the ROG button, and the
nVidia shortcuts in the Start Menu.

Yes the more I hear the more I am convinced the driver is buggy, the only problem will be the length of time it takes for the stable driver to be issued by Nvidia, probably months!!!!!!!