PDA

View Full Version : Best G74SX windows 10 drivers



alexgt
12-15-2016, 09:21 AM
I have a G74SX-TZ206V, bought used.
The previous owner had erased recovery partition so i need to reinstall everything.
Which are the best drivers for windows 10?
And which asus utility are useful?

Bill@ASUS
12-20-2016, 09:10 AM
Hello alexgt
Unfortunately, the official drivers provide by Asus only apply to Windows 7 64bit and Windows 8.1 64bit
Which you can find it here: https://www.asus.com/ROG-Republic-Of-Gamers/ROG-G74SX/HelpDesk_Download/
Are you experiencing any hardware malfunctioning on Windows 10?
Thank you

alexgt
07-22-2017, 09:52 AM
Hello alexgt
Unfortunately, the official drivers provide by Asus only apply to Windows 7 64bit and Windows 8.1 64bit
Which you can find it here: https://www.asus.com/ROG-Republic-Of-Gamers/ROG-G74SX/HelpDesk_Download/
Are you experiencing any hardware malfunctioning on Windows 10?
Thank you

Yes, i'm experiencing hardware malfunctioning (even on windows 7)
I can't find a correct nvidia gtx560m driver.
i've tried different drivers (old, new) but none of them works.
The only way i've found is disable the gtx560m, and the laptop run well.

Please tell me if You have some suggestion

C4RN1
07-25-2017, 06:21 PM
Yes, i'm experiencing hardware malfunctioning (even on windows 7)
I can't find a correct nvidia gtx560m driver.
i've tried different drivers (old, new) but none of them works.
The only way i've found is disable the gtx560m, and the laptop run well.

Please tell me if You have some suggestion

Alex it sounds like the gpu is dying.

I have sold probably 5 or 6 G74sx's with Windows 10 loaded and functioning properly with generic drivers from Nvidia. If I was you I would send out the motherboard for repair.

L2 computer repair in Brooklyn NY has an awesome automated machine that can probably fix it (either replace bad component or reball the chip). Though if you don't want to send it out you can always buy another motherboard and hope for the best.

I've used L2 several times when I owned a computer repair shop and never had an issue with them.

Here's a link to an ebay listing to repair the computer (you send the whole computer in).

http://www.ebay.com/itm/ASUS-G72-G73-G74-G75-K40-K41-K42-K43-Series-Motherboard-Flat-Rate-Repair-Service-/330921328717?

If it's not repairable they will refund you.

You can also try to buy repaired units from China, though it takes a bit longer for it to arrive.

Good luck with the repair, feel free to pm me if you have any questions.

alexgt
07-28-2017, 08:36 AM
Alex it sounds like the gpu is dying.

I have sold probably 5 or 6 G74sx's with Windows 10 loaded and functioning properly with generic drivers from Nvidia. If I was you I would send out the motherboard for repair.

L2 computer repair in Brooklyn NY has an awesome automated machine that can probably fix it (either replace bad component or reball the chip). Though if you don't want to send it out you can always buy another motherboard and hope for the best.

I've used L2 several times when I owned a computer repair shop and never had an issue with them.

Here's a link to an ebay listing to repair the computer (you send the whole computer in).

http://www.ebay.com/itm/ASUS-G72-G73-G74-G75-K40-K41-K42-K43-Series-Motherboard-Flat-Rate-Repair-Service-/330921328717?

If it's not repairable they will refund you.

You can also try to buy repaired units from China, though it takes a bit longer for it to arrive.

Good luck with the repair, feel free to pm me if you have any questions.

thanks for the answer.
I live in Italy, Brooklyn NY is a little bit too far from here :D:D:D
Motherboard is new, bought in taiwan (or in china, i don't remember).
Laptop works well if i disable the gtx560m. It can run for days.
I've found lot of people that has the same issue, but no solution.:mad:

JustinThyme
07-28-2017, 09:05 AM
Can also attest to G74SX running perfectly using windows 8.1 drivers for the most part and getting drivers from vendors sites for Graphics and Wifi

OnePiece@ASUS
07-31-2017, 06:11 AM
thanks for the answer.
I live in Italy, Brooklyn NY is a little bit too far from here :D:D:D
Motherboard is new, bought in taiwan (or in china, i don't remember).
Laptop works well if i disable the gtx560m. It can run for days.
I've found lot of people that has the same issue, but no solution.:mad:

Maybe you could contact with the local service center and to fix it.
https://www.asus.com/support/Service-Center/Italy