View Full Version : New Owner

12-09-2010, 08:02 AM
Ok so I searched around and I didn't see another thread related to this; however I'm sure this has been brought up so forgive me if this is a redundant thread.

I just got my Asus G73JW-A1 from Amazon, first off, awesome machine.

I do have a few questions though.

I've heard there are some issues out of the box with Blu-ray playback, which I have confirmed. I.E. there is none.

Also I went on Nvidias web site to update the GPU (GTX 460m) it seems they do have an updated driver out for my card (260.99) However when I go to install it, the installer tells me I do not have compatible hardware. Que pasa con eso?

The reason I bring it up is my new beast of a machine can apparently run Crysis at max graphics, but it cant run MechWarrior 4 or IL2, how sad for me!

Anyway any thoughts on this would be helpful!

12-09-2010, 05:06 PM
Have you double checked the device manager to ensure that you really have a 460M in there? It's possible that Amazon sent you a slightly different machine? Also have you tried the Nvidia automated driver detection option rather than selecting from a list?

If it really is then I remember reading about how a guy forced GPU driver installation by copying the hardware ID from the card and adding it to the manually unpacked driver files. I don't remember if it was even on this forum or another one I visit though so I'd have to do some research to find it.

12-09-2010, 05:39 PM
Yup, although when I use the Nvidia control panel to update the driver, or Nvidias computer scanner, they both come back saying that my device doesn't support that feature.


12-09-2010, 07:03 PM
I have not seen an issue with NVIDIA 460M Drivers not installing on the G73JW-A1
Can you provide me any more information on your Operating system and version?
Can you Download GPU-Z and upload a screen shot here

Also, in detail what issues are you having with MechWarrior 4 and IL2

12-09-2010, 07:46 PM
Quick one, have you tried going directly to the driver? I have found from time to time the automatic scan for driver updates takes you to the standard driver and not the mobile driver.


12-09-2010, 11:47 PM

The card just doesn't support them. They look like they are running off the mobo.

12-10-2010, 12:22 AM
BTW Yes, I am going directly to the notebook driver, I couldn't even get the scan to recognize my system. Here is the error I am getting when I try and update the GPU driver.


As far as detailed issue with MechWarrior, when I first started the program, it said that my card did not support this program. When I opened the program it looked like I was living in 1999 again LOL!

IL2 Runs on Open GL which my current driver set doesn't support.

12-10-2010, 01:06 AM
i just installed this driver and it works. but did some research internally and seems like there is a issue with the 260.99 with the g73jw. Some work some dont. Nvidia will come out with a new driver to fix this issue, so please wait patiently. for the time being, you can use the original driver.

12-10-2010, 01:11 AM
Awesome, that was the conclusion I was going to draw, I'm glad its not a hardware issue, I am in no rush!

As far as the Blu-Ray playback? How is that rectified?

12-10-2010, 01:49 AM
never heard of blu ray playback issues. cept that you may need to purchase your own playback software.

12-10-2010, 02:05 AM
I see, how lame :)

12-12-2010, 06:10 AM
Sadly I have a new issue to report. I had a few instances where my computer locked up and froze completely, it happened only twice and I thought little of it, however those lock ups have turned into BSOD.... Is that common for a G73JW-A1. Is it possible I got a bad machine?

12-12-2010, 07:08 PM
What have you updated on your machine?

12-13-2010, 12:09 AM
Everything is updated except the Graphics card. I used Drive Agent as well to double check, unless there is a better source.