PDA

View Full Version : I recently formated my G74Sx, please NEED HELP with Drivers instalation!



FelipeSAMA
01-03-2017, 05:57 AM
Good morning people!

I beg for your help guys!
Recently I formated my G74Sx notebook to install a SSD Sans Disk. Formerly it was everything okay! But now I found some problems and don't know how to fix =(

1 - My FN hotkeys are not working (So I cannot increase or decrease sound, switch between cable and wifi connection, ETC)
2 - My Wifi connection is not working! (Formerly it worked, but no longer).
3 - One of my USB entrances are not working! (There are 4 in total, only 3 working)

I have no idea how to fix that all, however I can give you some clues to help me =D
As you see on the image, when I open the device manager, there are some devices with a yellow symbol of "!". I don't know what does it mean. Is that a sign meaning the drivers are not currently installed? or what?

If I am right, which drivers should I install?
For example, When I visit the asus official website, there are listed 7 drivers for wirelles, and I don't know which one is the right. The same for USB (there are two or three differents). I am afraid of installing the wrong driver and harm the system.

And about the FN hotkeys, have no idea...
any light, please?


Thanks for all!!!

Ancients
01-03-2017, 10:50 AM
Did you install the same os you were using before?

Clintlgm
01-03-2017, 03:23 PM
Yes the ATK package should fix your Fn key stuff of lots of other things. You'll need to install and run something like Hwinfo64 to see what hardware you actually have generaly in the download section they'll have several versions of the same drivers you would install the latest. windows 7 uses a Intel driver for USB 3.0. this thread might give you some guidance it written for G75/55 but you should be able to adapt it to your G74 http://rog.asus.com/forum/showthread.php?28758-GUIDE-G55-G75-Upgrade-Notes

Insure you download drivers from Asus support Downloads (http://support.asus.com/download/options.aspx?SLanguage=en&type=1)your required to register your notebook by serial number and that way you should ge the correct drivers for your notebook.

FelipeSAMA
01-03-2017, 08:13 PM
Did you install the same os you were using before?

Yes I did. Windows 7 ultimate, service pack 1.

Unfortunatelly I don't know the reseller name, adress or email, either the Purchase Date ><
My mother bought for me when she was travelling to United States, I don't have such information. In these case, how could I register my product?

Maybe this post could help me http://rog.asus.com/forum/showthread...-Upgrade-Notes , thank you!

Julskey
01-07-2017, 04:51 PM
Good morning people!

I beg for your help guys!
Recently I formated my G74Sx notebook to install a SSD Sans Disk. Formerly it was everything okay! But now I found some problems and don't know how to fix =(

1 - My FN hotkeys are not working (So I cannot increase or decrease sound, switch between cable and wifi connection, ETC)
2 - My Wifi connection is not working! (Formerly it worked, but no longer).
3 - One of my USB entrances are not working! (There are 4 in total, only 3 working)

I have no idea how to fix that all, however I can give you some clues to help me =D
As you see on the image, when I open the device manager, there are some devices with a yellow symbol of "!". I don't know what does it mean. Is that a sign meaning the drivers are not currently installed? or what?

If I am right, which drivers should I install?
For example, When I visit the asus official website, there are listed 7 drivers for wirelles, and I don't know which one is the right. The same for USB (there are two or three differents). I am afraid of installing the wrong driver and harm the system.

And about the FN hotkeys, have no idea...
any light, please?


Thanks for all!!!


Hi there, I think you need to install the drivers for chipset (for usb/system devices), ATK package (for function keys), and WLAN (for wifi).

If you don't know your exact WLAN model, you can just do trial and error. Don't worry if you have mistakenly installed the wrong driver for your hardware, the system will not use the wrong driver.

As for your 4th USB port, it could be hardware fault (loose contact, etc?). Try using different devices for the malfunctioning usb port and try to wiggle it slightly to try to improve contact connection. Check the port if there are signs of worn or broken or dirty contacts.