PDA

View Full Version : Asus G53S model bought three months ago, problem powering up.



santeriabolan
01-05-2012, 06:58 AM
Hi everyone, this is my last resort before taking it back to the store.

So I bought the laptop, it's good I like it, a dream purchase but the only problem I've had with it, is randomly when it's off I press the power button and nothing happens, doesn't boot up. I have power in it cause the status light is green while it's plugged in so the battery is charged.

So my normal course of action is just wait five minutes and press the power again an it would work. And this became the procedure. Every time I would then it on I would press power once, not work and wait five minutes and press it again and it turns on.

Now it doesn even respond. Any suggestions would be appreciated.

Thanks for your time, and sorry for grammar and spelling errors, typing this from my phone obviously.

BrodyBoy
01-05-2012, 07:38 AM
It sounds to me like the magnetic switch problem that some G53 users have reported. There is a magnet in the lid that closes a little circuit whenever you close the computer....this is how it knows to go to sleep (or whatever action you've set it to do when closed). Sometimes, that little switch malfunctions and the computer thinks it's still closed.

There's a "hack" fix for this which works for some owners.....here's a pretty good description (http://forum.notebookreview.com/8035363-post11.html)of it.

If that works, chances are it is indeed the magnetic switch malfunctioning. Unfortunately, I think a permanent fix wold require RMA'ing it to Asus. :(