PDA

View Full Version : Battery won't charge



SingularThey
01-20-2017, 05:22 AM
Hi everyone,

I've had my RoG laptop for about eight months. I forget the model number but it's got a Geforce 970M and some kind of i7 chip.

Yesterday the fan went into permanent high speed mode even though all gpu and cpu temperatures were quite low, and the battery indicator light started flashing orange. The battery icon now says it's "plugged in, not charging." It was saying this at 99%. I unplugged it and let the battery drain some, based on something I read somewhere, then re-plugged it in. The fan is no longer running at high speed, but it still says "plugged in, not charging," at 37%. It hasn't budged from 37% all morning, and the indicator light continues to blink orange.

Any ideas what I might be able to do about this?

Clintlgm
01-20-2017, 02:13 PM
Are you running the latest BIOS for your notebook is not, I would start there you can get the latest BIOS at Asus Support Downloads (http://support.asus.com/download/options.aspx?SLanguage=en&type=1)
So Battery not charging logical either your AC Brick is failing our your Mother Board is failing, the battery charger is embedded on the motherboard. We can't get away from that. The BIOS controls your motherboard so Upgrading your BIOS actually may work, If not then your probably dealing with a hard ware issue.

xeromist
01-20-2017, 06:53 PM
Recent ROG laptops don't have user replaceable battery. If it's only 8 months old you should RMA it. If you cannot RMA for whatever reason it is possible to replace the battery but you have to take the machine apart and void the warranty.