PDA

View Full Version : Can't see Boot screen or BIOS on Z270G



mikysee
01-22-2017, 10:18 PM
When my monitor is connected to my GTX680, I cannot see the boot screen or the BIOS but once Windows starts to boot I can see the screen fine. I can see everything when my monitor is connected to the HDMI port on the motherboard. I tried changing the Primary Display option in the BIOS to Auto and PEG but it still does not work. When I go back into the BIOS, Primary Display setting shows IGFX so the setting is not saving. The POST State LED for the VGA stays on even after it boots into Windows. I am currently on BIOS version 0701.

Asus Strix Z270G
Intel 7700k
EVGA GTX 680
EVGA DDR4 3200

NemesisChild
01-23-2017, 12:53 AM
What type of connection are you making between the GTX 680 and monitor?

If it's HMDI, try a DVI connection or visa versa. Could be a faulty port on your aging 680.

mikysee
01-23-2017, 02:21 AM
What type of connection are you making between the GTX 680 and monitor?

If it's HMDI, try a DVI connection or visa versa. Could be a faulty port on your aging 680.

I was using the HDMI port on the GTX680 since my monitor only has that. I wouldn't think the HDMI port on the GTX680 would be broken as it works fine once Windows starts to boot. I'm more conserned that the BIOS setting is not saving.

f1schu
01-23-2017, 02:27 AM
Yeah I use DP connection on my Acer XR341CK but very rarely does it pick up the bios or spash screen from my R5E. I leave a hdmi lead also connected so I can switch the monitor to hdmi mode if I need to enter the bios as it always displays the bios/splash screen with out issue.

brentsg
01-27-2017, 02:38 AM
I had this same issue with a Z270 Tuf Mark 1, and now I'm having the same with the Hero board. Frequently it just doesn't want to display anything during POST from my EVGA FTW 1080 via DisplayPort. Once Windows loads it's fine. When I go back into the BIOS using the integrated graphics, integrated is selected rather than Auto or PEG. It's been driving me crazy.

I never had this issue with my Asus Z97 board that just got replaced. It's definitely some sort of bug with the current BIOS on the new motherboards.

I will finally dance around with it enough to get it working, and the first failed overclock or similar will send it running back to only working on integrated graphics.

JustinThyme
01-27-2017, 03:47 AM
Almost sounds like a seating issue on the graphics card. If it's set to auto the IGFX is supposed *to be disabled upon detection of a graphics card. I leave mine in auto in the event something goes amuck with my graphics cards I can still plug into the motherboard.*

brentsg
01-27-2017, 04:25 AM
It's definitely not a seating issue. I have seated the video card 4 separate times and it's been locked down in the PCIE slot each time, as well as anchored by the case. I pulled and re-seated everything in the original Tuf board and the issue persisted across that.. and thru the only available BIOS update. I swapped that for the Hero board and the issue has followed. Further, once the initial POST stuff and pause to go into BIOS is complete (with a blank screen) the discrete card boots into Windows perfectly fine 100% of the time.

Plus, once it's finally working all is well.. Unless the board fails to POST due to RAM timings or something while I'm tweaking. Then the cycle begins again. It's definitely related to the BIOS. Now it could be some interaction with how the motherboard detects the card, and what the card is doing at that time.. but it's not something that ever occured with my Z97 board and this video card.

Edit: I just had a repeat of this. Everything was working fine, CPU @ 5GHz.. did some stress testing with memory set slow, was fine. Rebooted and set memory to XMP. Upon reboot I didn't get any video output until I was able to boot into Windows. Again, did stress testing and everything passed with flying colors. I rebooted to see what would happen and never got any video (not even Windows). I swapped the DisplayPort cable to integrated output, booted the machine back up, got video. Went into BIOS and it was set for integrated rather than auto.

I definitely need to get the memory timings, etc tweaked and it'll help me avoid the situation, but having to swap the video cable is absurd. I also find it peculiar that booting seems to be my primary memory performance issue.

sesnut@gmail.com
07-14-2017, 04:27 PM
i have the exact same problem with my 1070 and maximus hero ix

mandark
08-01-2017, 01:44 PM
i'm having the same problem here.

I7-7700k
ASUS STRIX Z270G GAMING
Corsair Vengeance LPX CMK16GX4M2B3200C16R
MSI GeForce GTX 1080TI Gaming X (also tested with EVGA 1080 FTW)

it's frustrating. one buys top A-rated hardware and still has to deal with this kind of problems. :(

so what should i do now? anyone from ASUS here have any advice?

Chino
08-01-2017, 02:45 PM
Have you tried using the iGPU to see if you get an image?

mandark
08-01-2017, 03:24 PM
Have you tried using the iGPU to see if you get an image?

When connecting the monitor to IGFX, i can always see the boot screen.

My problem is just like OP describes it. Most of the time i don't see the boot screen or bios, if the monitor is connected to the PEG. In Windows (10) the PEG works without any problems. Furthermore the "Primary Display option" in the bios behaves very strangely. After setting it to "Auto" or "PEG", the bios seems to change it's setting back to IGFX by itself.