PDA

View Full Version : G752 not waking up after sleep - solved?



NP-complete
01-23-2017, 08:03 PM
Does anybody know what is the software responsible for making G752VY randomly crash when waking up from sleep mode? In some threads here I've read that some users have the same problem as me: sometimes it wakes up well, sometimes the screen is black forever and the only way to go on is switching off the computer, sometimes the mouse pointer appears but it's thinking forever, and even sometimes you can login again into Windows, but then the desktop does not produce any response to any click.

I think this problem is due to some software, because it never happens if you do a clean boot (https://support.microsoft.com/en-in/help/929135/how-to-perform-a-clean-boot-in-windows) and then you go into sleep mode. At first I blamed Sonic Studio II, which made all my Origin games (Sims 4 and Unravel) crash on launch. However, just removing Sonic Studio II does not solve the waking up problem, so I guess it's not its fault.

Any ideas?

BoutTime01
01-23-2017, 08:23 PM
I have had the same problem with G752VT but unfortunately have no idea as to what causes it.

Sent from my Nexus 6 using Tapatalk

NP-complete
01-23-2017, 11:14 PM
By trying one "semi-clean" boot after each other (i.e. trying different combinations of enabled/disabled programs), the program responsible for the problem could be eventually found. But this might be a very time-consuming task, as the waking up issue happens on an (apparent) random basis: with the same configuration, sometimes it happens and sometimes it doesn't. Hence, you could consider a given combination of programs safe because waking up worked fine in all your experiments, yet it could not be safe ---it was just luck.

Just wondering if someone suspects a particular program or service could be the culprit.

Armesis
01-25-2017, 01:24 PM
This happens to my G752VY as well. Since it boots up very fast anyway, i never put it to sleep anymore, i just turn it off lol.

diogogmaio
01-25-2017, 02:57 PM
This happens to my G752VY as well. Since it boots up very fast anyway, i never put it to sleep anymore, i just turn it off lol.

Same for me and for everyone who didn't disabled the sleep feature.
I don't understand the reason but that happens.
Too many times.
We need a real solution because this didn't happen before.

NP-complete
01-25-2017, 08:04 PM
I found the reason of the problem!! :o :o :o

It's ORIGIN. Do you have it installed? Do you have any Electronic Arts games? Do not let Origin launch (either at startup or later), and waking up will always work properly. At least for me!

I'm not surprised. A few days ago I discovered that my Origin games crashed at launch if Sonic Studio II was running. So there is some big incompatibility between Origin and some sofware running in my G752VY.

diogogmaio
01-26-2017, 10:05 AM
Ok. I will do the test.
With and without origin.

It could be.

NP-complete
01-26-2017, 10:27 AM
In the last two weeks, when I pressed the restart button in Windows, Windows complained so often about Origin refusing to close, so Windows had to eventually kill the Origin process by itself. If a program refuses to be closed when Windows "nicely" requests it, then maybe its full state won't be properly saved into the SSD when getting into sleep mode. Hence, when you wake up later, maybe its former state won't be properly recovered (and it will make waking up crash). It's just my theory... Does it make sense?

NP-complete
01-26-2017, 12:15 PM
I'm so sorry to inform that my solution to solve the waking up issue doesn't work in all cases. :( I thought waking up after a clean boot was safe (25 waking up operations in the last 3 days, all correct!), but it isn't. After a clean boot, I started Steam and asked it to download some large game (10 Gb) into the SSD. After 5 Gb or so, when the right side of the case was already warm (yes, the right side gets warm even without any sound, just by downloading files), I put the laptop into sleep mode. 30 minutes later, when the right side of the case was cold again, I pressed the wake up button... and it failed. Two attempts. First time I could write my password but then I was stuck in the desktop. Second time I just got the infamous black screen.

Maybe reducing the number of running programs helps indeed, but it definitely sounds like a hardware issue.

NP-complete
01-27-2017, 10:12 AM
Ok, I've installed the lastest Intel drivers for the Chipset, the Management Engine, and the Rapid Storage Technology from http://www.station-drivers.com/index.php?lang=en. Then, I've changed the BIOS from Raid to AHCI, following the steps given by hexaae in https://rog.asus.com/forum/showthrea...l=1#post588732 (I also experienced that halved transfer speed problem after waking up from sleep). Then I've repeated twice the experiment I mentioned in my previous post, and it's working: resuming after suspension isn't failing. I don't want to be overoptimistic (again!), but this could be the solution.

If I don't get back to this thread with bad news, then it means it kept working.

0Hock0
09-04-2017, 05:29 PM
Good evening Guys

Hope you dudes are rocking !
So iv had this laptop ( ROG 752VY ) for just under a year now and its a kick ass awesome,
Love it no problems really, its just this out of sleep problem that i see every one seems to be having,
Hibernate works fine, shut down and on works fine, but coming out of sleep is driving me up the wall.
Dont really want to hibernate due to kill SSD (m.2) and i use this machine every day ! going from place to place with it, i need it to sleep.
There has to be a fix for this ? why has Asus not looked into this ? why is the power management on Asus so bad ?
Any one have news on this would be super great,
It looks like a bios issue , i longer delay needed on boot for LCD to detect or respond ?

On another note, i have 3 other family members that have entry level Asus`s and also power issues , LCD flashes like crazy when running on battery, other machine just blue screens ( often ) and also flashes random, ( yes i have reloaded and updated drivers more times that i can remember)
I LOVE ASUS and wont put money on anything else , just wish these problems could be solved

Have a great day dudes !

J

The Cool Dude
09-04-2017, 05:54 PM
Hello there.

In my experience, issues coming out of sleep for any computer are almost always due to a driver issue.

On my G752VS, I have an odd issue where my touch pad is always re-enabled coming out of sleep however the issue does not occur if I shut down. Asus needs to update these drivers to fix all these weird sleep issues.

Spirery1
09-05-2017, 03:55 PM
Same with my g752vy i just turned it off

STM Consultancy
11-17-2018, 01:02 AM
Hi guys,

Found two solutions in another tread ... still have to test it haha:

https://www.asus.com/us/support/FAQ/1016000/

So it's related to the Intel Chipset. Intel Management Engine Interface ... one of the things i cannot understand that Windows is not updating this stuff automatically ... phew ...

Second solution I saw is to press "FN+F7" ... supposed also your Asus G752 has the F7 that turns off and on the screen ...

Hope this helps ...

Cheers.

Death_Machine
07-14-2019, 08:58 PM
Hello guys! I found a good way to fix this problem! I bought recently ASUS ROG Strix Hero III and this problem occured! So all you need to do is:

1. Right-click on the Start Menu, then choose "Device Manager" from the Quick Links menu. If you're into keyboard shortcuts, you can also type Win+x, then the letter 'm', which will do the same thing.
2. Scroll down the list of devices until you see "System Devices". Click on the chevron to expand this list.
3. Find the Intel(R) Management Engine Interface. Right-click on it and choose "Disable" or "Disable device".

That's it. You don't have to restart your computer, the changes will go into effect immediately. To test if the fix was effective, you can close the lid of your laptop, wait a few seconds, then re-open the lid. Your screen should flicker back to life.

Here is the original website: https://it-helpdesk.tetonscience.org...n-asus-laptops

mdudley78
11-04-2019, 08:49 AM
Indeed, we need to disable Intel ME driver, but Windows update will re-enable it ! Here how to fix that once for all:

- you need to change some "group policies" of Windows with gpedit.msc
- This tool is not available in Windows 10 Home but you can install it
- Once you have gpedit.msc you will be able to prevent Windows Update to re-enable Intel ME driver

To install gpedit.msc follow the instructions here: https://www.itechtics.com/easily-enable-group-policy-editor-gpedit-msc-in-windows-10-home-edition/

then run the .BAT as administrator. You have now gdedit.msc available on Windows 10 Home.

follow the instructions here: https://www.howtogeek.com/263851/how-to-prevent-windows-from-automatically-updating-specific-drivers/

the Intel ME driver ids are:
PCI\VEN_8086&DEV_A13A&REV_31
PCI\VEN_8086&DEV_A13A
PCI\VEN_8086&CC_078000
PCI\VEN_8086&CC_0780
PCI\VEN_8086
PCI\CC_078000
PCI\CC_0780