PDA

View Full Version : G74-SK: The Touchpad That Won't Go Away!



chrisjpopp
02-10-2017, 10:27 PM
I've been trying to get the Touchpad to turn off/go away to no avail on my G74-sx BBK7. I've tried to update the ATK, install a phantom device to trick the Device Manager to ignore the Touchpad, install new drivers... none of these have worked. F9 does nothing.

I've got an external Microsoft USB mouse that I'd rather just use without a touchpad. In the past I've been able to select "disable touchpad when using mouse" but that's not a viable solution here.

When I've tried to install the ASUS Smart Gesture software, it failed. However it's in my Control Panel but when I click on it I get "Application Not Found".

It's becoming irritating to have a touchpad that's "live" when I type, throwing my cursor everywhere.

Running Windows 10 with BIOS 204, 16 GB Ram.

Julskey
02-11-2017, 02:40 AM
Hello,
Open device manager and uninstall the old driver listed as PS/2 mouse and restart laptop.
Download and install synaptics driver from asus G75VW win 8 64-bit HERE (http://dlcdnet.asus.com/pub/ASUS/nb/G75VW/Touchpad_Synaptics_Win8_64_VER162117.zip?_ga=1.258 147274.1505666783.1477540435) (make sure you have synaptics touchpad and not the other one). Restart laptop. Assuming you already installed all other software, atk package, keyboard filter ...etc, your fn+F9 should now enable/disable touchpad. Not only that, your smart gesture should also work. Yehey.