PDA

View Full Version : RGB Line streak on Left side of Display-Asus G53SW-A1



anvancy
01-08-2012, 07:15 AM
Just after days I got my G53SW, everything was running fine till yesterday. Today morning I turned on and now this is staring at me.

5292

I am on the current beta drivers.

A thread on notebookreview states its a LCD fault.

What should be the steps taken?

Anvancy

dstrakele
01-08-2012, 07:20 AM
Where did you purchase your laptop? What is their return policy?

I recommend contacting the retailer to see if they will exchange your G53SX with a new unit. If they suggest you send it to ASUS for warranty repair (RMA), say you don't wish to do that, you would rather return the defective laptop for a refund. If you RMA it to ASUS, it then becomes YOUR problem.

What version beta video driver are you currently running? You could attempt to backrev to the driver originally installed on the system to see if it changes the issue before you attempt the return. However, it does look like an LCD hardware defect.

You could also boot into ASUS Express Gate Cloud. You are not yet in the Windows OS at that time, but in a BIOS extension. If it still displays the line streak, you'll know there is nothing you can do in Windows to resolve it.

anvancy
01-08-2012, 07:36 AM
The Laptop was purchased from Amazon USA.I live in India where this model is not available hence the foreign purchase.

Right now the laptop is with me here in India.So I dont know whether the laptop will make a journey to USA for a refund/exchange and fly back to me.

I am currently on the 290.53 driver.

How to boot into the Asus Express Gate Cloud?

Anvancy

dstrakele
01-08-2012, 07:44 AM
Amazon is good at resolving these issues. See http://rog.asus.com/forum/showthread.php?9006-Product-Replacement Give 'em a call or email.

You boot into Express Gate by pressing the ROG button instead of the Power Button. It'll boot up in about 15 seconds. That is its purpose. It allows an extremely fast boot for limited functionality outside of Windows. A hard copy Express Gate Cloud manual should be in your laptop box.

I also run the 290.53 beta driver with no laptop display issues.

anvancy
01-08-2012, 07:55 AM
I did not specify in the inital post. The laptop was purchased in November. So I am way past the 30day return policy.

I think I have no option but to give to my service center here.

Also confirmed its a LCD fault. The line is present at BIOS screen too.

Anvancy

dstrakele
01-08-2012, 08:00 AM
I see. I misinterpreted your initial post and believed you only had the laptop for a few days. You've confirmed the issue and know what you need to do now - contact the service center and begin the ASUS RMA process. Good Luck!

anvancy
01-08-2012, 08:36 AM
A question.

Does setting the "Do nothing" when lid is closed have any effect? I changed the setting from Hibernate to Do nothing.and closed the lid for a hour and went out.

Could the magnetic sensor near the trackpad cause any issue?

Just thinking of this.I have seen some Asus G screens going kaput.Any particular reason?

Anvancy

dstrakele
01-08-2012, 07:16 PM
That's how I have my lid setting configured - Do Nothing. Been running like that for 4 months with no issues. However, I have never completely shut the lid with the laptop still running. I have read about others that have in this forum however. They did not report corrupted LCD displays, but rather overheating issues. Typically, they were using an external monitor and external keyboard and mouse and did not want to have the lid open.

No reports of the magnetic sensor ever causing an LCD display problem either, only startup problems.

anvancy
01-12-2012, 01:16 PM
Update:

I went to the Service Center, Showed them the problem. They have accepted the laptop under global Warranty and will be changing the LCD panel. I have multiple times asked and told that it is a Full HD LED Backlit Panel and not the 1366 one.The reply was the Serial Number has all the info built in.So I will get the same part. I requested them that since I do not have another Laptop, ill keep the laptop.Once the panel reaches the service center Ill drop the laptop so that they can change the Panel.They agreed to this part.

Observation on the fault:
The Line actually grew and now covers the entire vertical span of the screen. Its still a single line but it has grown thick. The Screen though is still usable. While playing games where your attention is constantly shifting, the line isnt seen.

Barring the totally awful in built speakers this laptop to me atleast is a bang for the buck Beast.

Anvancy

anvancy
01-14-2012, 03:48 PM
Finally:

They changed my panel. The weird part is, they gave me not a AUO or a Hannstar panel but a "Matte" Full HD Samsung Panel. the Hardware ID is SEC314C.

I am constantly observing things. The colors look good.Blacks are decent and brightness is top notch. I think I was lucky I got a Matte Panel.

Thanks for the help guys.

Anvancy

Toruk
03-22-2012, 05:39 PM
Hello, anvancy

Im new in the forum, and I was reading and searching information about the dead pixel LCD problem on G53SW-A1, and your information It's really useful, in fact my G53SW (Date of Purchase : 2011/11/15), present the same issue since Feb/2012 (all the left side have dead pixels) and ASUS suggested to setting up a RMA, however I'm outside of US and the best choice that I have right now is to buy myself the LCD in order to replace, but my only doubt is related to the model and specification of the LCD for this ASUS, because according with the information on the internet the G53SW came with a glossy panel FHD, not a Matte, but according with your explanation they replace the LCD panel with Samsung "Matte" Full HD, so I would like to know why they change the original specification, was a factory defect? Or something else likes video card or driver issue?
At this moment, Im looking for the right LCD and the best match is the glossy full HD.

http://www.laptopscreen.com/English/model/ASUS/G53SW/

In more detail my Failure Reason:
basically the problem is related to the vertical red dots that appear all over the screen, please review the attached pictures. Also, take in consideration that the problem started with only one small line and now have more red dot lines and circle, like a progressive appearance.

Thanks in advance.