View Full Version : ROG Claymore On-The-Fly Macro Issue

03-09-2017, 11:39 PM
Hi all,

I have a ROG Claymore keyboard that I have accidentally recorded some on-the-fly macros while playing games. When I press the 'ESC' key, it is automatically pressed again ~10 seconds later. This one is not TOO bad.

The second one, when I press the 'W' key a string of 'WWWWAASAASSAAAAAAADDWWWWWWWDDADA' is pressed. I don't know how to delete these macros, which has left the keyboard next to useless, for now.

I have tried using the ROG Armoury software to erase macros, however the macros don't appear here so there is nothing to delete.

The user manual says; 'Clear CMOS - C+L+R' however, when I do this there is no notification that any memory has been wiped so I am not sure if I am doing this correctly.

Could someone please advise on how I can erase these macros so that I can actually use this keyboard again!

Thanks in advance.

03-11-2017, 06:03 PM
You can fix the button by rebinding it:

fn + alt to start making a "macro"
press escape once
fn + alt to finish making "macro"
your keyboard should be green now, with red buttons showing where macros are bound
escape again

Now your escape should act as a single esc click again. What I don't understand is you can rebind 1 button click to another, and it' not indicated by red light when binding which may come up as a surprise later.

03-12-2017, 05:26 AM
Thanks uiasdnmb, while your suggestion seemed to have worked for the macro on the 'ESC' key. It didn't seem to affect the other keys.

However, I have managed to fix it. This was done by loading the 'Default' profile within ROG Armoury. I knew it was going to be a simple solution but I can't believe that I didn't think of/find this earlier.