PDA

View Full Version : G75VW Connecting To Wifi At Only 72.2Mbps, Anyway To Connect At Higher Speed?!



mlauzon
03-20-2017, 09:21 PM
I bought a used G75VW-TS71 2 years ago...someone had stupidly put Win8 on it before I bought it, so I reinstalled Windows 7 -- I own Ultimate -- x64 to it. All drivers are up to date as of this posting. However, I only seem to be able to connect to Wifi at 72.2Mbps. Is there anyway to fix this so that I can connect at a faster speed, or am I stuck to the aforementioned speed?

xeromist
03-20-2017, 09:32 PM
Not sure if this is related but I found I needed an older version of the Intel Management Engine software on my older laptop. Newer versions caused instability and slow WiFi. Try the version on the support site.

Other than that, keep in mind that WiFi ratings are ridiculously optimistic. No one outside of a lab ever reaches anywhere near advertised speeds. Client vs AP compatibility, RF noise, obstructions, and channel crowding all degrade throughput. In my experience it's not uncommon to see speeds below 100Mbps even on recent hardware.

Bahz
03-20-2017, 09:59 PM
The speed is directly related to your distance with the router and the overall strength based on the signal quality. If you're like literally right above the router then it means you probably have a driver issue, so although it looks like you installed the correct driver but you probably have the Windows default driver installed which in most cases in Windows will have reduced performance unless you have installed the correct one. You should download the wireless LAN driver from your notebook support page and you should uninstall the old driver first then do a manual install of the INF, if the file is available.

mlauzon
04-09-2017, 09:05 PM
The AR9485WB-EG is an 802.11n card, and should be connecting at least 150Mbps, not 72.2, which is just a little faster than 802.11g (54Mbps); it's clear ASUS has done something that has fu*ked up the card.

Clintlgm
04-11-2017, 06:08 PM
Well one way to look at it. your internet connection is far less that 72mbs, My G75 only connected at 64mbs still to this day even on my new Netgear entrance point with Asus router.

JustinThyme
04-11-2017, 08:54 PM
Well one way to look at it. your internet connection is far less that 72mbs, My G75 only connected at 64mbs still to this day even on my new Netgear entrance point with Asus router.



Speak for yourself! LOL
Mine is 500 up and down. *Thats *not an issue as much as network acceess to my NAS for media streaming and backups. AC 5300 router with an ASUS PC 88 PCIe card gets me 1.6-2.1Gbps. Yes it does faster that wired Gb LAN.*

@OP, post up what wireless pci half card your machine is running. Sounds like to me your are running old N Protocol at exactly half speed in 2X2 MIMO. Sounds like you have two problems, the machine itself and competing with something else on whatever channels you are using.*

To see if there is any competition download *inSSIDer to see what your competing with and reassign channels as necessary. Most traffic is on channel 6 for 2.4GHz as it's the default and 90% of folks don't know any better.*