PDA

View Full Version : Bluetooth/Wifi on Strix Z270E not working at all



eclenic
03-25-2017, 05:52 PM
Set up my Strix Z270E this morning, wifi & bluetooth worked fine. Had some issues trying to install my MX Master via bluetooth, but there were some updates so I did those, including a BIOS update to 0801.

Restarted - no bluetooth. It's not even showing up in the list. Wifi working fine. Try a ton of stufff, nothing works.

Couple hours later, trying to set some overclock settings. Didn't work though, so I gave up for now and reset BIOS to defaults, then change a few settings back the way I like them. Boot into Windows - now the wifi isn't working either. The hell?

Any ideas on how to fix this?

Nate152
03-25-2017, 06:12 PM
Hi eclenic

Welcome to the ROG forum.

Those are two features I don't use but as for your wifi disappearing after overclocking, it sounds like your overclock could be unstable.

As for bluetooth check to see it's enabled in the bios, Advanced tab > Onboard Device Configuration.

Reset to defaults and see if your wifi comes back.

Check device manager for any yellow triangles.

eclenic
03-25-2017, 06:24 PM
Hi, thanks for replying.

Yes the overclock wasn't stable, hence resetting BIOS to default settings before booting into Win 10. *I haven't tried overclocking again yet.

I've updated the BIOS to 0906 now, issue still persists and I'm now reinstalling Win 10 for the second time today.

Device manager has one yellow triangle, 'PCI something' (not at desk just now) which google says is to do with the Intel Management engine software.

Also of note, what used to say 'Qualcomm Atheros Wireless Adapter' under networks adapters has disappeared and now there are a bunch of different 'WAN miniport' entries instead.

eclenic
03-25-2017, 07:23 PM
Update: It's working!

After reinstalling windows again didn't seem to help, I unplugged the PC from the wall to let the BIOS do a full reset. Left it like that for ~25 minutes, booted up, and bam! Wifi and Bluetooth both showing up. Wifi is working great, haven't tried the Bluetooth pairing again yet. Guess it was some glitch in BIOS somewhere. Hopefully this might help if someone else has the same problem.

Nate152
03-25-2017, 09:57 PM
Great to hear you got it working !

The PCI Simple Communications Controller with a yellow triangle means the MEI driver isn't installed, you only need if using AI Suite.

xavierzzz
11-20-2017, 07:12 PM
You are not the individual case, I searched online and found many different cases from different regions/Languages with exactly the same Problem, Bluetooth disappeared for no reasons and nothing works on recovering until cutting off the power from the Motherboard, e.g: Unplug the Main Power for some time until the LEDs on motherboard goes off then Power it backup again, The problem will be temporary fixed, or Clear CMOS will do the same trick. Some Z270i Owners also reported other Bluetooth related issues such as Bluetooth devices can not be paired etc which can be resolved using the CUT-Power trick. See References Linked Below:

https://rog.asus.com/forum/showthread.php?93816-Strix-z270i-bluetooth-problem-and-how-I-fixed-it

https://linustechtips.com/main/topic/837764-bluetooth-not-working-asus-strix-z270i-windows-10/

http://www.hyr5.com/f4/t25319

https://rog.asus.com/forum/showthread.php?92000-Bluetooth-Wifi-on-Strix-Z270E-not-working-at-all

https://linustechtips.com/main/topic/778894-asus-z270i-bluetooth-gone/

https://www.tonymacx86.com/threads/success-twsps-build-asus-z270i-strix-i7-7700k-hd-630-4k-m-2-alc1220.216999/page-2

https://www.reddit.com/r/ASUS/comments/634tcx/asus_z270e_bluetooth_not_working/

https://www.reddit.com/r/buildapc/comments/6bv9h2/z270e_motherboard_bluetooth_suddenly_stopped/

And Maybe this:

https://rog.asus.com/forum/showthread.php?87740-Bluetooth-gone-completely-after-PC-refresh-Not-in-device-manager-or-settings

Most of the cases were on ASUS Z270i Users, but also reported by other ASUS Z270 (Z270E etc.) Motherboard Users, So ASUS, Please fix your stuffs.