PDA

View Full Version : Slow Startup G752VY, Freezing



Ratchetman
03-30-2017, 09:45 PM
Just picked up this laptop and it seems to be way slower to start than my G750JZ. Today it froze with a blank screen on power up. I had to hold the power button until it powered off.

Now I shut the lid last night, this morning the laptop is warm and frozen again.

Clintlgm
04-02-2017, 03:37 AM
Sounds like your having an issue with fast start up. try disabling it and see if the issue continues. Turn off Hybrid sleep in Power Options/ Advanced/ power button. this will allow you notebook to completely shut down when you shut it down.

Armesis
04-02-2017, 11:04 AM
Me and many others have had this problem (especially when they are brand new). Start it and let it stabilize, then press the power button again to put it into sleep mode, then one more time to wake it up. Most likely its the screen or DP cable going bad, it will have to be replaced if thats the case. You will know its the screen when it starts getting pinkish. These rog laptops are horrendously unreliable but they are good value for money lol.

JustinThyme
04-02-2017, 12:00 PM
What BIOS are you running?
Also ditch the fast joke uhh I mean startup.

Ratchetman
04-03-2017, 12:42 AM
Thanks for the replies. Support suggested an newer display driver and that stopped the freezing. It still becomes powered off when I shut the lid I'm going to look at that fast start option.

As far as a hardware problem, this is my 3rd ASUS laptop and I have yet to see any problems with the hardware. I used the 750 for 2.5 years for 2 to 6 hours a day and it's working like new. My fingers have polished the keys on that thing.

Clintlgm
04-03-2017, 04:46 AM
Yes my G75 Is still working great. I did have 2 RMA's on it in the first year I had it. Still working great on 8.1 pro with much polished keys.
Window 10 seems to have its issues with out notebooks. the fast start actually on puts you notebook in Hybrid sleep, I have had nothing but problems with all my units and Hybrid sleep. Seems not all drivers get reloaded on wake up? I don't know the answer to why but I just turn them off rather than allow them to sleep or shut down to Hybrid sleep.

A lot of the black screen people are getting are due to the Hybrid sleep.

With the loading speed of these SSD's there really is no need for sleep or fast startup anyway. it was really for people with hard drives rather than SSD's.

Julskey
04-03-2017, 11:19 PM
You may also want to turn off Fast Boot in BIOS in addition to disabling the Fast Startup option in windows 10.

Ratchetman
04-12-2017, 03:43 AM
I couldn't find a fast boot option in the bios