PDA

View Full Version : ROG Gaming Center no longer works after Creators Edition update. Anyone else?



BoutTime01
04-12-2017, 11:54 PM
Not sure if it has anything to do with the recent Creators Edition update but if i press the ROG button it says Gaming Center is initializing but never actually does. And the GPU manual overclocks in Turbo Gear aren't applied.

Windows events viewer stars it's unable to locate certain files/DLLs. I've tried a fresh install but no joy.

Anyone else have issues? May just uninstall and use GPU Tweak II instead.

Sent from my Nexus 6 using Tapatalk

Clintlgm
04-13-2017, 04:17 AM
Yes If you want to use gaming center you'll probably just need to uninstall it and reinstall it. this happen to some programs after major upgrades to Windows 10

BoutTime01
04-13-2017, 06:13 AM
Yes If you want to use gaming center you'll probably just need to uninstall it and reinstall it. this happen to some programs after major upgrades to Windows 10
Did that already. Still doesn't work unfortunately. Cheers.

Sent from my Nexus 6 using Tapatalk

Dewprism
05-12-2017, 10:33 AM
I have same problem. Mine was GL533VD i have recently purchased this laptop 3 weeks ago but today ROG Gaming Center unable to work anymore he just stuck there at initializing and then after that come the black screen. i Have reinstalled like 2-3 times but no luck so far. So... what to do now?

chilinmichael
05-12-2017, 10:51 AM
Wait until Asus decides to upgrade their app

Clintlgm
05-12-2017, 03:36 PM
I think I would restore an image prior to the CU upgrade.
Then uninstall Gaming Center, Reboot
Download install media from MS Media Creation Tool (https://www.microsoft.com/en-us/software-download/windows10) Start the install from inside windows!!
Do an upgrade install, then Reboot
after this see what is working and not
Reinstall gaming center. This may work for you or not let us know.

Rolandk10
05-28-2017, 07:15 AM
I had the same issue. I found a work around after searching online for a while. I copied the d3d9.dll from C:\Windows\System32 folder to "C:\Program Files (x86)\ASUS\ROG Gaming Center"

ROG Gaming Center started normal after that.

BoutTime
06-11-2017, 03:11 PM
I had the same issue. I found a work around after searching online for a while. I copied the d3d9.dll from C:\Windows\System32 folder to "C:\Program Files (x86)\ASUS\ROG Gaming Center"

ROG Gaming Center started normal after that.

^^^^^^^^

This worked for me! Thanks for posting your solution!!

Aergon
08-17-2017, 07:24 PM
I had the same issue. I found a work around after searching online for a while. I copied the d3d9.dll from C:\Windows\System32 folder to "C:\Program Files (x86)\ASUS\ROG Gaming Center"

ROG Gaming Center started normal after that.

Thanks, that works for me too, excellent work man, you rock

D.V.D
06-14-2018, 07:00 PM
It doesn't work for me...i have a G752VS laptop...it came with W 10home edition but i upgraded to pro...it did work after the upgrade from home to pro...but as above...it stopped working after this creators edition...