PDA

View Full Version : G51J not posting



megaspeed
05-02-2017, 07:56 AM
hello all

Last week, my little girl G51J did a windows 10 update, it all went ok, then back in windows, she start playing game as usual, watching youtube and whatever, at the same time my G751 did the very same update, that night, I turned off both laptops, next morning, when she went to turn on her laptop, it just powers up with fan spinning, the 3 LED came on the keyboard, and that is it, no HDD activity, nothing, black screen, keyboard doesn't response to anything, where as the G751 is still perfect, not sure if it was the update but thats the last thing it did.I tried removing ram, cpu, HDDs, wifi card, no luck, not even a beep.

anyone got any idea what can be wrong with it out of the blue like that? the laptop was never used for anything intense, just kiddies games and youtube, she's only 8 and games she plays would run on a 486, well maybe not but just for the idea of how little power the laptop is being used for.

thanks

p.s. the g51j had the HDD upgraded to Intel SSD and the stock HDD is moved to 2nd drive, thats the only thing been done with it over a year ago.

Eleiyas
05-02-2017, 08:28 AM
Im sure I read somewhere else on the forums that the latest Windows update mucked up a load of drivers or something. Does the laptop post to an external monitor?

megaspeed
05-02-2017, 09:01 AM
I don't think it is posting at all, the keyboard doesn't response to anything either, when I try the cap lock and num lock, nothing lights up. I don't have a monitor to test with. it is actually the G51J-3D model but I don't think it matters which model of the G51j

p.s.

I even disconnected the cmos battery and all other power souce for hours, nothing changed, as if the bios not firing up at all, tried to do a blind flash with ctrl+home, nothing

Eleiyas
05-02-2017, 09:13 AM
I would see if you can't try the units on an external monitor first (maybe borrow one from a friend or something) - if that doesn't work (still no display), then I'd hazard a guess at a corrupted version of Windows or perhaps, worst case scenario, a mainboard failure.

In either case, you might need to contact your local ASUS support.

megaspeed
05-02-2017, 09:25 AM
I'm thinking it is the motherboard, but its a bit sudden as it was working fine, no warning signs or anything, just die, I don't think there is a local asus support for me here in Ireland, was hard enough to get the laptop at the first place, no one stock the ROG and it cost hundreds more to get them from any retailer here in Ireland on special order only, so I bought all my ROG laptop from UK, even the very old G71 is still working perfect with no overheating issue or anything problem with GFX.

Eleiyas
05-02-2017, 09:29 AM
I'm thinking it is the motherboard, but its a bit sudden as it was working fine, no warning signs or anything, just die, I don't think there is a local asus support for me here in Ireland, was hard enough to get the laptop at the first place, no one stock the ROG and it cost hundreds more to get them from any retailer here in Ireland on special order only, so I bought all my ROG laptop from UK, even the very old G71 is still working perfect with no overheating issue or anything problem with GFX.

We usually deal with Beaumex in Ireland. You can always try giving them a bell, if not contact an ASUS support on the mainland.

megaspeed
05-02-2017, 09:31 AM
thanks for the info, I might just have to give them a try, I been looking for a motherboard but couldn't fine any other than aliexpress which I rather buy another laptop, couldn't trust those aliexpress stuff

Eleiyas
05-02-2017, 10:39 AM
thanks for the info, I might just have to give them a try, I been looking for a motherboard but couldn't fine any other than aliexpress which I rather buy another laptop, couldn't trust those aliexpress stuff

I'm glad I could be of assistance :)

Hope you get everything working again :D