View Full Version : G60JX Touchpad not in device list & not working

05-17-2017, 11:40 PM
Long shot here as I'm still rocking my G60JX (had it packed away for about a year) it still does what I need so I havnt bothered to upgrade.

Anyway I pulled my laptop out to use and the touchpad and r / l buttons are not working; pulled out the old wireless mouse and started checking settings and found that its not listed in the device manager. Thought maybe its an issue with windows 10 so I pulled the ssd out and tossed the old hdd with windows 7 in and still no touchpad.

Just trying to see if others think the touchpad failed or if there could be something else causing the issue.

Sent from my SM-J700P using Tapatalk

05-18-2017, 02:41 AM
Mostly with or without proper driver, Left and right button should be working.. this may caused the hardware.

Did the touch field working during no driver?

Did you check you are enable touchpad by fn+f8 ?

Sent from my EVA-L19 using Tapatalk

05-18-2017, 03:19 AM
Buttons and touch do not work on win 7 or 10 with or without drivers. Doesnt show in device manager F8 only says touchpad disabled. Mouse options dont show it exists either.

Sent from my SM-J700P using Tapatalk

05-19-2017, 04:17 PM
If you don't even see the touchpad in device manager, makes me worried about the hardware, but assume you don't see any 'unknown' devices in device manager that could be related to it (Windows may normally install some kind of driver automatically though?).

Check your bios settings under the 'advanced' menu to make sure the internal pointing device is enabled and maybe reload the bios defaults settings if you can.

If you have a safe way to check the touchpad cable connection or reseat the cable that's another idea. Good luck!

05-19-2017, 04:41 PM
Thanks I'll check the bios.

Theres no unknown devices that i can find and I tried reseating the cable.

If i cant get it going I'll just try ordering a new touchpad setup from ebay and hope its not a failure on the motherboard side.

Sent from my SM-J700P using Tapatalk

05-19-2017, 05:03 PM

I don't actually repair units and don't remember ever seeing a unit with a bad touchpad, so not sure how likely this is, but remember hearing some customers running into issues with bad (keyboard?) FFC cables as well which probably would not happen if you were not disassembling the unit and re-connecting the cable very often.

If you haven't inspected the touchpad FFC cable, make sure everything looks good there and assume the plastic clips to hold the touchpad cable on both the motherboard and touchpad side look good as well.

Also, the notebook keyboard and touchpad may be related some, so more serious keyboard problems might affect the touchpad, but probably not very often.

Anyway, just wanted to run this by you as well. thanks.

05-19-2017, 05:12 PM
I've repaired a lot of laptops over the years but I've only ever seen one touchpad fail and it was due to a coffee spill.

Both the cables appear good along with the connectors. This laptop has a round multi wire cable from the mobo to the mouse button/touch sensor pcb then a flat ribbon cable from the button/touch bored to the touchpad.

In all I'm just a bit confused on this thing; everything worked when i packed it away but after setting in my closet since shortly after windows 10 came out i find the mouse not working and the battery would not take a charge (funny thing is the bios battery had died so i replaced it and now the battery charges again)

Sent from my SM-J700P using Tapatalk

05-19-2017, 05:40 PM
Yes, thinking the hardware should still be okay, but don't have more suggestions.

If you had to replace the CMOS battery, probably a good idea to check the bios settings or reload the bios defaults if you haven't already.

Anyway, curious to hear all this turns out if you want to update us later. thanks.

05-19-2017, 05:48 PM
I had went to bios and adjusted everything when i put the new battery in because date/time insisted it was 2010.

I'll probably be trying a new (used ) touchpad

Sent from my SM-J700P using Tapatalk

05-21-2017, 02:44 AM
Thanks for the suggestions. Just ordered a top plate with touchpad and power buttons from ebay thats supposed to be working. I'll report results after it shows up.

05-24-2017, 08:57 PM
Well the new parts came and i installed.
The good is mouse is now in device manager
The bad its not working. Need to figure out the driver situation.