PDA

View Full Version : Asus G751JM - WIFI troubles after Windows 10 update...



Doskol
05-23-2017, 06:28 PM
Hello there.
Last days I did update from win 8.1 to win 10. In this moment the hell happened. Sometimes my wifi got stuck its shows "Connected, no internet" to every of 3 networks I have. I am not able to do anything even to enter my router settings (192.168.1.1). I am connected and I am receiving bits, but I am not sending those.
It takes me half an our every time this problem happens to fix it, but tbh I have no idea how I am doing it.

I have updated drivers from Asus Rog official page.

TheKnight
05-24-2017, 05:59 PM
After major updates like yours sometimes Windows installs its own crappy drivers instead of the proper ones. Get the official network driver here https://www.asus.com/support/Download/3/719/0/1/H1PGPvZ0ODsnDxTf/41/ . Uninstall your current wireless network driver through Device Manager and install the one you get from the link above. Just make sure to get the correct one. if you an Intel network card then get the Intel driver, if you have Qualcomm get the Qualcomm driver etc. Most of the models have Intel network cards but double check just to be sure.

As you said you already did that but check again, you might have gotten the wrong driver.
This may also sound very silly but have you tried unplugging your router and plugging it again?

Doskol
05-24-2017, 09:41 PM
I uninstalled drivers from win10 and installed wireless drivers win8.1
Icon of Internet has changed (glitched) and shows as ethernet connection even when I am not connected by cable.
BUT!!!!! It works fine. As fine as before. Problem solved.
Windows 10 = cr@p.

ekkachit
05-25-2017, 04:09 PM
Use intel driver , do not use others like realtek

Sent from my BTV-DL09 using Tapatalk