PDA

View Full Version : G752VY - Help me get into BIOS please, solved?



davemon50
06-24-2017, 02:49 AM
As title says, I need help getting into the BIOS. F2 per the manual doesn't work, also tried DEL button. Anyone know what to do? It just keeps booting up into Windows.

davemon50
06-24-2017, 03:18 AM
OK, I finally got it. I don't know what I did wrong but finally got in. I guess I need to sleep more than the computer needs it. ;)

Clintlgm
06-25-2017, 03:19 AM
Yes you have to be fast as boot times are fast. Also insure that you are cold booting and not waking up for Hybrid sleep which is default for windows 10

cl-Albert
06-26-2017, 05:20 PM
fyi.

It can be tough with Win8/10 Secure boot to get into the bios with 'F2' or delete key after powering up.

Personally, I find tapping the 'ESC' key after powering up often works better than F2 or delete to see the boot menu with the option to select the bios setup.

Otherwise, if you find yourself in Windows, look for the 'advanced startup option' (?) or just hold the shift key while you restart Windows to see it and navigate through the menus to the bios option.

Hope this is helpful. Thanks.

davemon50
06-26-2017, 07:15 PM
On my desktop using the RVE10, Asus provides a utility called "ASUS Boot Setting for Windows", if you activate it the computer just reboots directly into BIOS on the next startup. No keys required! :) I wish it worked with the G752VY. Who knows, maybe it would work if it could be installed?