PDA

View Full Version : G752VY SD Card Read not working after creators update



ewolwerd
06-25-2017, 06:58 PM
The SD card reader is not recognized by windows 10 after the update. It shows as unknown device and when Windows attempts to install the driver through device manager, it correctly identifies the Genesys Driver but fails on install by saying it is not meant for my device.

Here is a thread of several others having the same issue, mainly with Asus products it seems. https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/card-reader-not-working-after-creators-update/58d1a617-4f65-452e-8e17-3e314faad6f8 (https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/card-reader-not-working-after-creators-update/58d1a617-4f65-452e-8e17-3e314faad6f8)

CladMaster
06-26-2017, 09:37 AM
Driver Ver = 4.5.1.2
Date = 10/03/2016

http://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=fileinfo&id=2477&lang=e


This driver from the link above should fix the problem, it has on my G752VL.

ewolwerd
06-26-2017, 03:04 PM
Driver Ver = 4.5.1.2
Date = 10/03/2016

http://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=fileinfo&id=2477&lang=e


This driver from the link above should fix the problem, it has on my G752VL.

Thanks. Can confirm this works.

Mousepad
06-30-2017, 02:53 PM
On my G751JT this does not work either and I tried those fix drivers and still nothing. I've tried manual install too and nothing. Does anybody have ideas? This has been broken since Creators garbage.

CladMaster
06-30-2017, 03:15 PM
Did you uninstall the old drivers ?

Also, disconnect from the net and reboot before you install the new driver.

Mousepad
06-30-2017, 04:01 PM
Did you uninstall the old drivers ?

Also, disconnect from the net and reboot before you install the new driver.
After I did this and put in the card it shows up as other devices unknown device in device manager. The drivers for this device are not installed (code 28). Driver is not intended for this platform.

Mousepad
06-30-2017, 04:03 PM
For the most part device manager doesn't even recognize the card reader exists.....even with drivers installed. Only when I put in an SD card does it give that there is an unknown device.

I also get this error now. Currently, this hardware device is not connected to the computer. (Code 45)

CladMaster
06-30-2017, 05:44 PM
I was getting the same error.

The drivers for this device are not installed (code 28). Driver is not intended for this platform.

Updated the USB drivers via Device Manager for the USB Drivers (search the web option) --- see picture below for driver version and date.

For the Genesys drivers use the option to search on the PC.

When the SD card is not connected the error 45 code is present.

m-gucci
07-01-2017, 05:45 AM
I am having a different problem. My driver IS NOT INTENDED FOR THIS PLATFORM . Same with other drivers. Any help?
https://s13.postimg.org/iiioqmbxz/genesis.jpg

CladMaster
07-02-2017, 01:11 PM
I found a new driver for Windows 10 Creators Build

Genesys Logic - USB - 4/20/2017 12:00:00 AM - 4.5.1.7

You can get it from the MS Catalog >> https://catalog.update.microsoft.com/v7/site/Home.aspx

Copy and paste the following into the search box.

Genesys Logic 4.5.1.7

or

Genesys Logic - USB - 5/23/2017 12:00:00 AM - 3.5.1.7

You will need to use WinZip or 7-Zip to extract the files from the CAB file.

Use Device Manager to update the driver.

Bahz
07-03-2017, 04:22 AM
This was reported a few weeks ago and our contact window from notebook side with Microsoft has passed the issue along to them and hopefully they will provide us with a solution soon. Meanwhile I recommend to try the workaround solution mentioned in this thread.

D_Pain
08-06-2017, 06:59 AM
On my G751JT this does not work either and I tried those fix drivers and still nothing. I've tried manual install too and nothing. Does anybody have ideas? This has been broken since Creators garbage.

I have a G751JT-CH71 and I updated using this driver and it fixed my issue. It's a newer driver than the one stated in the other posts. Actually released really recently.
http://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=startdown&id=3025&lang=en

Danger Sica
12-25-2017, 04:57 PM
Thanks. Can confirm this works.

Nice direction. I have the same problem and it works.

rachcampitos
07-23-2018, 03:18 AM
Driver Ver = 4.5.1.2
Date = 10/03/2016

http://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=fileinfo&id=2477&lang=e


This driver from the link above should fix the problem, it has on my G752VL.


Is working, thanks a lot!

burgie
08-12-2018, 03:15 PM
This driver worked for me. Thanks. :)
I downloaded, opened in file explorer, selected ALL, sent to a folder, doubleclicked the Genstor.inf, and rebooted after the install.