View Full Version : G73jh VGA Driver update question.

01-14-2012, 03:14 PM
I'm sorry if this has been asked before, and it probably has. But I'm having alot of trouble trying to run Battlefield 3, and most importantly, minecraft. Battlefield 3 simply will not load, and When I try to start minecraft, i get the infamous hss_err_pid message.

I've read all over the place that both of these games have trouble running on older ATI drivers. But to my knowledge, ASUS has yet to release a new version of the radeon Hd 5870 driver.

this is what I have done so far.

0. uninstall and reinstal java (minecraft)
1. flashed my bios
2. upgraded to bios version 213
3. tried both the 11.12 and 10.8 Mobility Radeon driver from AMD site, and neither of them install correctly.

Does anyone know what I have to do to get this machine to run minecraft? Or am I just out of luck?

01-14-2012, 04:31 PM
Hi there Bradlyeon,
Was wondering did you also update your vbios? until you do the newer ati drivers will end in error.
Asus has not updated anything. Once you update the vbios then you can download the newest drivers. Either from this forum or from ati.
That is what I did. Hope this helps. The vbios update is on the driver update page on this forum.

01-14-2012, 05:10 PM
yes, I flashed the vbios. However, I did not have Service pack 1 for my copy of windows 7. so I got that, and tried everything again. Now, after I "update" the driver from AMD, I am left with CCC not opening, windows "classic" theme, and a maximum resolution of 1152x864

01-14-2012, 05:40 PM
before you attemp to install ccc did you uninstall the old video drivers? the is a crap cleaner in the driver thread let windows install what it thinks is the right driver then run the install for ati 11.12 i think is the latest

08-08-2012, 11:14 AM
I'm having the exact same error with minecraft as listed above. My drivers are up to date according to ASUS. I'm lost! Very frustrating.