PDA

View Full Version : G73SW-XN2 GPU Fan Broken



aidenn
01-14-2012, 05:48 PM
Hello all,

My G73SW-XN2 purchased from Newegg has been running pretty well. Aside from the fact that the touchpad is still somewhat laggy and in order to compensate I use a wired razer most of the time, My GPU fan just died. I use speedfan to monitor temperatures and Idle gpu temperatures run at 70-80 degrees Celsius. I have tried resetting the BIOS back to original settings, Reinstalling my Nvidia drivers, contacting Asus and following their instructions, but none of these have worked.

Does anyone have any software-related ideas that I could try to fix the fan before sending it in for RMA?

Thanks,
Ryan

EDIT: I can clearly hear the cpu fan running and feel the air being blown out, but cannot hear the gpu fan or feel and forced air coming out.

fostert
01-14-2012, 06:03 PM
Try getting a can of compressed air from an electronics shop (e.g. The Source, or any computer shop), and stick the nozzle+extension up into the air intakes as far as you can, and blast away. A vacuum cleaner at the other (exhaust) end sucking while you're blasting would help dislodge additional dust too and suck it up as it comes out.
If you can open the laptop and access the malfunctioning fan, all they usually need is a couple good shots of WD40 in the bearings to rejuvenate them for a good long time. I have repaired many a fan this way, and they are still going 5-10 years later!

Sorry, I know this advice is not software-fix related, but this is how I would attack the problem before RMA. I am not sure what else to try.