PDA

View Full Version : Overwatch FPS Problem



BlueEyes
08-26-2017, 09:15 PM
Sooo i recently bought overwatch and felt weird as I played it, soo after a while I finally figured to turn on the fps counter to see whats going on, and I was really surprised when I saw my fps being 16 at Ultra/Epic settings... Soo i checked a settings guide on youtube and put my overall graphic on EPIC but reduced all the advanced stuffs on LOW, even after throwing away my pride and accepting to play on low graphics, its still mostly around 40 fps, it hits 144(I capped it at 144) only in first 20 seconds of a match, after that it just drops down super hard.
Im not a pc specs expert, but my G752VT's specs are beyond overwatch's recommended settings and should run at high without any trouble, and im also pretty sure my ''cooling system'' should be able to handle itself for the game.

Im using a G752VT model;
- 1TB HDD
- 8 GB DDR5 RAM
- I7 6700HQ @2.60GHz
- Nvidia GeForce GTX 970m

Faberge
08-26-2017, 11:51 PM
You have a max 75Hz monitor refresh rate on those G752XX notebooks, you really wont get any benefit from 144 FPS in game. Even in Overwatch.

BlueEyes
08-27-2017, 08:31 AM
You have a max 75Hz monitor refresh rate on those G752XX notebooks, you really wont get any benefit from 144 FPS in game. Even in Overwatch.

Idk it just feels more smooth to me, but okay, thats my last concern, lets say I lock it at 75FPS, im still getting under 75FPS

Faberge
08-27-2017, 06:40 PM
Check the CPU & GPU temperature then. make sure u dont have any cooling problems, update Nvidia drivers, try diffrent games. Thats the very first of what u can do and I can think of. Also u dont have an SSD, right? The problem may be in that 5400 RPM HDD is too slow and its a bottle neck of the your system.