View Full Version : ROG G74SX very bad FPS with Star Wars The Old Republic

01-16-2012, 08:56 PM
Hi.. i've got a big problem with my fps at Swtor..

I've got the G74SX (brandnew..i already sent one back, because i thougt it is a hardware problem):

i7 2670QM

nVidia GTX 560M

16 GB Ram

With this system should Star Wars the old republic work on max. settings without fps problems.. but ive got 10-20 frames.. and with 3d mode max. 10 fps..

With bloom and shadow off : ~30 fps.. sometimes 40, but never over 50..

I tried everything.. fps limiter, beta driver, updates, .ini changes..

Crysis 2 works on max. settings fine and Mass Effect 2 , too..

I dont know where the problem is.. Somebody with the same issuses?

Ty for your replys..

01-16-2012, 09:00 PM

How is it with updating to the latest drivers for your notebook?
(WiFi card (atheros, if you got it) chipset, nVidia graphics and microsoft update)

It could be a CPU Throttle (http://rog.asus.com/forum/showthread.php?2329-ATTENTION-G73-53SW-Owners-CPU-Throttling-to-798mhz-and-how-to-fix-it) issue, but I don't want to say it is that before confirming the updates :)

01-16-2012, 10:28 PM
Hi, thanks for your answer!

Soo i updated atheros now but it didnt fix it.. all other drivers are up to date. ( nvidia is the beta version, but i already tried the regular one, but this one decreased the graphic card in the windows benchmark by 1 point.. i dont know why.. )

A friend of me has a G74SX ,too.. but he has only 8g ram but the other specs are the same, and he has no problems with swtor..

I hope those informations will help you to analyse the problem..

If it is a cpu throttle issue, i only have to run the Throttlestop thing? should i try it anyway or can it cause damage to my system?

Thank you!

01-16-2012, 10:42 PM
Hmm, that's weird :S It could be because of some other software that he has installed and you don't but there is many factors too look at :/

If it is because of the CPU Throttle issue, just look at the link and read it ;)
That guide is good, it's straightforward with good info about how to use it, and with the video you can see the difference.

01-16-2012, 10:43 PM
i downloaded throttlestop 4.0 and tried to fix the problem... without success :( i ve got it open in background, and running swtor in fullscreen mode with everything on max... max. 20 fps :(

It confuses me because my friends G74SX has no problems..

01-16-2012, 10:51 PM
You have ThrottleStop set up to do basically nothing.

If you want it to try and control CPU throttling then try checking the two different Clock Modulation boxes and set those to 100.0% and also check the Set Multiplier box and make sure that is set to Turbo.

Now check the Log File box and go and play a game so you have an accurate record of your CPU's performance. Upload ThrottleStopLog.txt to www.mediafire.com and post a link here or email it directly to the ThrottleStop author. Remember to exit ThrottleStop before uploading or sending the log file so all data can be written to it.

CPU throttling might not be the source of your problems but it needs to be investigated further. The G73SW has some known throttling issues so you need to have a good look at the log file and know what to look for to figure this out. Provide lots of data while your computer is throttling and dropping the FPS to a crawl.

This is from another thread (http://rog.asus.com/forum/showthread.php?9432-ASUS-G73SW-bad-FPS-drops-playing-League-of-Legends./page3) from here, a guy that has issues with FPS drops in LoL on his G73, make sure that you have it turned on :)
I don't have my notebook atm, so I cannot do much to help without gathering info from other threads :p

01-16-2012, 10:55 PM
hm that is very strange..

He got his G74sx at the same time ( last friday ) and has no other software installed :S..
I searched everywhere for help but i didnt find anything.. some people say that it is a issue of swtor, because they did something wrong with shadows but without shadows its max. 50 fps, and i think this isnt what it should be with this system.. the most confusing point is, that the other g74sx has no problems.. and the only difference is that my one has 8gb more ram and 3D ( what is turned of )..

01-16-2012, 10:56 PM
+1 Good Point, @fuzon! Throttlestop can't help you if it's not set up right...

@Bigingxxl - you got a system to compare against. I recommend finding out the exact differences between yours and your friend's system. I don't believe 8 GB RAM and 3D is the only difference...

Clean Windows Install vs. ASUS Factory OS
Antivirus, AntiMalware, Firewall, and Remote Access software
other software installed
Driver versions for all drivers
NVIDIA configuration
game configuration
Power profile settings
Windows Updates installed
Services loaded on startup
running processes
Desktop configuration (Classic, Aero, slideshow)
DPC Latency

Alternatively, you could try a clean Windows 7 installation with only the ASUS ATK Package drivers and the most recent drivers for everything else.

01-16-2012, 11:03 PM
hehe jep first i set it up wrong :P, but now i tried with the right settings, and no difference :S..

i uploaded the log file, too : http://www.mediafire.com/?hpv1ln35wsd83pb

maybe you can see something?! i dont get it ^^


mh jep, there could be more differences with the software.. i ll try to compare them next time..

but my main worry is if i should sent it back and get my money back ( if its a hardware issue ) or if i should keep it and wait for updates or finding a software issue that causes the problem..

01-16-2012, 11:31 PM
As you've seen, configuration is very important. Glad to hear you worked it out!

01-17-2012, 02:05 AM
I find this post interesting because I run SW:TOR on MAX settings with zero slowdown on my G74SX. I also make sure that I am running at 120Mhz, so be sure to check that as well.

01-17-2012, 06:04 PM

i compared now the g74sx and the only difference ( beside the hardware ) is the AV.. ive got norton 360 and he free av avira..

but i dont have any firewall blockings that could cause the problem..


01-17-2012, 06:59 PM
I find this post interesting because I run SW:TOR on MAX settings with zero slowdown on my G74SX. I also make sure that I am running at 120Mhz, so be sure to check that as well.'

Only one model comes with the 120hz screen.. which I assume is what you're refering to as I know of no other part that runs at 120Mhz

01-17-2012, 07:21 PM
I have a G53SX and I have the exact same issue that you are having. The only way I got it working better was shadows off and shaders low. Game looks crapy now but it runs. Not only that but when I watch fullscreen videos on hulu I get horrid screen tearing.

How do full screen videos work for you?

Oh and a friend has the older g53jw; no problems with swtor on his machine.

01-17-2012, 09:26 PM
I actually have the same issue, though it never drops under 10fps, even though I have shadows off, it maintains about 12fps.

Im sitting on a G74SX with 8 gig RAM, without the 120hz screen.
I have tried a clean install, with only the necessary drivers, and throttlestop, at first I thought it was better, but that was just placebo.

I can run skyrim on Ultra, and Mass Effect 2 on highest settings, it really is strange....

01-17-2012, 11:32 PM
okay.. this solaces me a little bit.. but i figured something out..
My friend, with the "working" G74SX was here and we compared the graphic card Adapter Information (Desktop->Rightclick->..->Extended Graphicsettings ( dont know the english layout)
ive got:
Total Aviable Graphics Memory: 6900MB
Dedicated Video Memory: 3072MB
System Video Memory: 0MB
Shared System Memory: 3828MB

he got:

Total Aviable Graphics Memory: 4095MB
Dedicated Video Memory: 3072MB
System Video Memory: 0MB
Shared System Memory: 1023MB

I dont really know what that means.. Weve got exactly the same grapic card..
Maybe my additional 8GB ram is the point?

Something else we found out:

On a Benchmark ( 3D Mark06)
Ive got a processor speed of 2084 mHz
and he got about 2840 mhz.. but the strangest thing was, that my processor was rated better and ive had more fps in this benchmark.?!!

but the last straw that breaks the camel's back is:

his laptop has bad fps at swtor, too... but only when he is at my house.. We thougt its could be the wifi, so we tried lan, but nothing changed.. my internet is okay, becaus i can play swtor with the same cable on my Desptop PC without bad FPS..

... I am at my wit's end..
but thank you very much for helping me :)

01-19-2012, 11:30 AM
Not all Nvidia drivers are the same. I have found 90% of them suck posterior and just because they are nwere doesn't mean they are better. I tried several drivers and the best one I found so far is version 258.38. I would also download MSI afterburner so You can over clock the cpu if needed....

Just an example of crappy drivers..... 290.53 gave Me horrid frame rates at lowest settings in between 20 and 30 fps.

258.38 gave me 30 to 50 with everything maxed in Deus Ex. I can also play skrim with everything maxed out with these drivers also.

02-22-2012, 05:41 PM
hey! i sent my laptop to asus support and they replaced the mainboard.. now everything runs smooth with excellent fps !

Thank you all for your help!