PDA

View Full Version : Asus G752VS G Sync Issues and V Sync Settings



FreshPrince15
11-01-2017, 05:31 PM
Hey all,

i just purchased an Asus G752VS and im happy to join the ROG Community. I just have a question to the G Sync Function of this Notebook: In the games i play i have sometimes a flickering Screen. For example in Xcom 2 or Starcraft 2. In other games, for example Diablo 3, Crysis 3 or Elex, this flickering does not appear or it only appears rare. I heard that flickering in loading Screens is normal, but as i said in Starcraft 2 and Xcom 2 it flickers also in the game, its an effect like when you close and open your eyes. The Screen doesnt go black. I have a 17,3 " Panel with G Sync and 120 hz, WideView. Ive also searched this Forum and also saw a Topic, but without a solution.

The second question i have affects the V Sync Settings: Do they Need to be turned on in the Nvida Settings on my Notebook and also on in the game i play? Or do i Need to shut the V Sync Settings off in nvida Settings and also in the game ? I dont know the right Setup for V Sync when you have a G Sync Monitor in your Notebbok.

My current Nvida Driver Version is 388.13

Thanks for your Attention. Looking forward to your answers.

Torgars
11-02-2017, 04:32 PM
Hi FreshPrince15,

Welcome here ;-)

I'm actually in the same case concerning my new Asus GL702VS and G-Sync option: in many games (maybe all I think) I got the same flashing issue (like an eye blink you're right ;-) ), the only solution is to desactivate G-sync totally or do an alt-tab then go back in game (according to G-sync indicator it still activated) and it's ok, it's really strange. I'm unable to determine if it's a driver problem (tried the 3 last without change) or an hardware one (actually thinking of asking a RMA). Can't find any solution on the internet (but it seems we're not the only one with this trouble).

Concerning the V-sync it seems that you have to force it activated in Nvidia Control Panel and desactivate any V-sync / buffering in games options. Look at this https://www.blurbusters.com/gsync/gsync101-input-lag/ if it help you. When you activate V-sync in Nvidia Control panel it's "a special one" intended to work with G-Sync. But to prevent some input lag when you reach your screen refresh cap (120HZ / FPS in my case) it seems that using an external FPS limiter is the best and set it 3/4 FPS under this limit.

Hope this help you and that we find a solution!

CerealKillerGuy
11-02-2017, 06:58 PM
You have to force adaptive v-sync in Nvidia Control Panel (if your GPU has it, my 980m doesn't). It's a special kind of V-sync that kicks in above your maximum refresh rate to get the benefits of both worlds (G-sync and V-sync)

FreshPrince15
11-02-2017, 09:48 PM
Hi FreshPrince15,

Welcome here ;-)

I'm actually in the same case concerning my new Asus GL702VS and G-Sync option: in many games (maybe all I think) I got the same flashing issue (like an eye blink you're right ;-) ), the only solution is to desactivate G-sync totally or do an alt-tab then go back in game (according to G-sync indicator it still activated) and it's ok, it's really strange. I'm unable to determine if it's a driver problem (tried the 3 last without change) or an hardware one (actually thinking of asking a RMA). Can't find any solution on the internet (but it seems we're not the only one with this trouble).

Concerning the V-sync it seems that you have to force it activated in Nvidia Control Panel and desactivate any V-sync / buffering in games options. Look at this https://www.blurbusters.com/gsync/gsync101-input-lag/ if it help you. When you activate V-sync in Nvidia Control panel it's "a special one" intended to work with G-Sync. But to prevent some input lag when you reach your screen refresh cap (120HZ / FPS in my case) it seems that using an external FPS limiter is the best and set it 3/4 FPS under this limit.

Hope this help you and that we find a solution!

Thanks for your warm words! Yeah, i read this case in many other Forums! One guy said he had changed his Asus G752VS three times for a new one but he always had the same issue! When G Sync is off, no Problems! So i personally think this has something to do with the Drivers or Settings. As i said, in Stacraft II the flickering is really heavy, in Crysis 3 or Diablo 3 i have no Problems. In Xcom 2 it occurs sometimes.

Yeah i have heard about that FPS limiter, but which Software do i Need for that ? Its not implemented in the Nivida Center right? I will check the Forum link you have posted, thanks.

FreshPrince15
11-02-2017, 09:50 PM
You have to force adaptive v-sync in Nvidia Control Panel (if your GPU has it, my 980m doesn't). It's a special kind of V-sync that kicks in above your maximum refresh rate to get the benefits of both worlds (G-sync and V-sync)

I have only four Options in Nvidia Control Panel: On, off, fast or Use 3D Game Settings. There is no Option for adaptive. My GPU is a GTX 1070 8GB.

CerealKillerGuy
11-02-2017, 10:02 PM
In that case, from my experience, enable both g-sync and v-sync in Nvidia Control Panel. Gsync overides vsync if you get frames under your monitor's refresh rate in most games. And disable v-sync in the game.

FreshPrince15
11-03-2017, 02:43 PM
In that case, from my experience, enable both g-sync and v-sync in Nvidia Control Panel. Gsync overides vsync if you get frames under your monitor's refresh rate in most games. And disable v-sync in the game.

I will try that later this evening, thanks for your advice.*

FreshPrince15
11-03-2017, 02:52 PM
Hi FreshPrince15,

Welcome here ;-)

I'm actually in the same case concerning my new Asus GL702VS and G-Sync option: in many games (maybe all I think) I got the same flashing issue (like an eye blink you're right ;-) ), the only solution is to desactivate G-sync totally or do an alt-tab then go back in game (according to G-sync indicator it still activated) and it's ok, it's really strange. I'm unable to determine if it's a driver problem (tried the 3 last without change) or an hardware one (actually thinking of asking a RMA). Can't find any solution on the internet (but it seems we're not the only one with this trouble).

Concerning the V-sync it seems that you have to force it activated in Nvidia Control Panel and desactivate any V-sync / buffering in games options. Look at this https://www.blurbusters.com/gsync/gsync101-input-lag/ if it help you. When you activate V-sync in Nvidia Control panel it's "a special one" intended to work with G-Sync. But to prevent some input lag when you reach your screen refresh cap (120HZ / FPS in my case) it seems that using an external FPS limiter is the best and set it 3/4 FPS under this limit.

Hope this help you and that we find a solution!

By the way: Which games are mainly effected for you? *

Torgars
11-03-2017, 04:19 PM
It seems that the mainly affected games are the one who's running at the higher framerate (100/120 FPS) like HoTS or Overwatch but others like TW Warhammer / Rise of Tomb Raider (60/80 FPS) are affected too, but maybe less often. Already tried to cap the FPS at 116/117 (in case the blinking is due to FPS hitting my monitor frequency) without success. Maybe I'll try some older drivers but if it don't resolve the problem I'll get my laptop to RMA, maybe a Gsync module problem in the monitor.

FreshPrince15
11-03-2017, 07:50 PM
It seems that the mainly affected games are the one who's running at the higher framerate (100/120 FPS) like HoTS or Overwatch but others like TW Warhammer / Rise of Tomb Raider (60/80 FPS) are affected too, but maybe less often. Already tried to cap the FPS at 116/117 (in case the blinking is due to FPS hitting my monitor frequency) without success. Maybe I'll try some older drivers but if it don't resolve the problem I'll get my laptop to RMA, maybe a Gsync module problem in the monitor.

I have some interesting Information: I just purchased Halo Wars 2 and have set up V Sync in the Settings to "2". The Options you have are "Off", "1" and "2". On "2" the game runs like a dream. So this flickering Thing has something to do with the Games you Play i think! Just tested Total War: Warhammer 2 and i also dont have any issues with flickering! Maybe i Need to reinstall SC 2 and Xcom 2 so they run better with G Sync?

Torgars
11-05-2017, 02:24 PM
Hi there !
It seems that the flickering occured more when I hit my monitor refresh rate so I think that's why when you play TW Warhammer 2 you don't see that much (like me in Warhammer 1). Yesterday thought that I had find the solution when changing Power Plan Mode in Nvidia Panel (Maximal Perf instead of Optimal) but finally not :( Today I bring back my laptop to change it by a new one and hope it solve the problem! Give you news in the week!

Torgars
11-09-2017, 05:32 PM
Hi FreshPrince15 !
Here is some news, I received a new laptop yesterday and the problem of screen blinking is present (maybe a little less but still).. I think it's not hardware related but what's the solution? Have you found some interesting things to help us?

FreshPrince15
11-09-2017, 10:00 PM
Hi FreshPrince15 !
Here is some news, I received a new laptop yesterday and the problem of screen blinking is present (maybe a little less but still).. I think it's not hardware related but what's the solution? Have you found some interesting things to help us?

Hey Torgars, thanks for the update. Yeah, i was already quite sure that this is not a Hardware Problem. At the Moment i am trying a fps limiter. Im using Nvidia Inspector, turned the fps Limit to 119 (because of my 120hz Screen) and i think i experienced a positive development. For example while playing Elex, i dont get any blinking Screen, except of Dialogues with NPCs in the game. Only in this Scenario i get the blinking sometimes. In Halo Wars 2, Warhammer II: Total War i do not experience any blinking, same in Diablo 3. Only sometimes in Starcraft 2 and XCOM 2. But i think in SC 2 and XCOM the blinking is really reduced.

Maybe at the Weekend i will try out an older NVIDA Driver. Some People told that this can fix this G Sync issue. Others say the blinking in games at some spots, like in loading Screens etc., is quite normal.

An official Statement in this case would be helpful i think.

FreshPrince15
11-18-2017, 02:23 PM
I have just tested another game with G-Sync on! Rainbow Six Siege. In this game i dont get any "Flashing" effects. Seems like this Problem only occurs with specific games!

Torgars
11-19-2017, 04:58 PM
Hi FreshPrince15 !

It seems that this flicker doesn't occur with 382.78 Nvidia driver (the one that come at default with laptop).
Installed the 388.31 as Express install (keep last driver configuration) and flicker reappeared.

FreshPrince15
11-20-2017, 12:53 AM
Hi FreshPrince15 !

It seems that this flicker doesn't occur with 382.78 Nvidia driver (the one that come at default with laptop).
Installed the 388.31 as Express install (keep last driver configuration) and flicker reappeared.

Yes, that also worked for me. I have installed an older Driver from the Asus Support Website for my G752VS. Its the Version 369.56 ! It works for me so far ;) Hm its an old Driver, i dont know if Asus will put a new Driver on the Website, which also works good with G-Sync!

chrisafguy
11-20-2017, 08:25 PM
I have just tested another game with G-Sync on! Rainbow Six Siege. In this game i dont get any "Flashing" effects. Seems like this Problem only occurs with specific games!

Can you confirm that this driver version has completely fixed your problems? I've been experiencing this black screen flicker issue for over a month and haven't found a single solution that works.

FreshPrince15
11-21-2017, 12:20 AM
Can you confirm that this driver version has completely fixed your problems? I've been experiencing this black screen flicker issue for over a month and haven't found a single solution that works.

Hi! Yes, right now i dont have any black Screen flicker issues. I have downloaded the Driver from the asus Support Website for the g752vs. I choosed the second Driver in the list. It had a description with something like "fixes Panel splash Screen".

Torgars
11-21-2017, 12:47 AM
Can you confirm that this driver version has completely fixed your problems? I've been experiencing this black screen flicker issue for over a month and haven't found a single solution that works.

For me too with 382.78 from Asus. But they are old drivers :( Installed 388.31, some screen flicker but I think that performance difference for last games is important (maybe I need to test more before saying that ;))

Torgars
11-25-2017, 09:22 PM
Any news or solutions instead of running very old drivers?

FreshPrince15
11-26-2017, 03:45 PM
Any news or solutions instead of running very old drivers?

Hey man, yeah i am still using the old drivers. It would be really helpful, if an Admin or someone who has knowledge in this case could give us a reply. Did you try out the newest Nvidia Driver or will a new driver be released in the next days?

Torgars
12-08-2017, 11:18 PM
Good news ! Seems that last 388.59 fix Gsync flicker problem (list in release note) just test 1/2 games and it seems to be ok (but it seems that I have some tearing now ;)). Stay tune :)

FreshPrince15
12-10-2017, 04:10 PM
Good news ! Seems that last 388.59 fix Gsync flicker problem (list in release note) just test 1/2 games and it seems to be ok (but it seems that I have some tearing now ;)). Stay tune :)

Cool, that sounds nice ! I have just downloaded the new driver and will test it laters ;)

kekkooo87
12-11-2017, 10:19 PM
Guys, I get the 388.59. No problem with games, but Youtube's videos and other browser (edge) videos flicker a lot, but only in full screen mode. I solved the problem with the "Use software rendering instead of GPU rendering" option. Have problems like that?

FreshPrince15
12-12-2017, 12:55 PM
Guys, I get the 388.59. No problem with games, but Youtube's videos and other browser (edge) videos flicker a lot, but only in full screen mode. I solved the problem with the "Use software rendering instead of GPU rendering" option. Have problems like that?

The new driver 388.59 works perfect for me. No more issues at the moment. The problem with Edge or YouTube Videos is not existing at the moment for me. Maybe I need to test these both use cases more.*

Greetings. **

sl0519
12-13-2017, 08:18 AM
Guys, I get the 388.59. No problem with games, but Youtube's videos and other browser (edge) videos flicker a lot, but only in full screen mode. I solved the problem with the "Use software rendering instead of GPU rendering" option. Have problems like that?

Same to me. Drivers before flickering in games like crazy, now with 388.59 flickering is gone, but then youtube video fullscreen is screwed up. Why is G-Sync creating so much problem?

kekkooo87
12-13-2017, 11:30 AM
The new driver 388.59 works perfect for me. No more issues at the moment. The problem with Edge or YouTube Videos is not existing at the moment for me. Maybe I need to test these both use cases more.*

Greetings. **

Mmmm.... Have you Windows 10 full updated?

sl0519
12-13-2017, 06:42 PM
Mmmm.... Have you Windows 10 full updated?

by the way my windows 10 is clean installed, latest fall creator update (1709)
Is there anyway we can report this problem to NVidia?

FreshPrince15
12-14-2017, 12:18 AM
by the way my windows 10 is clean installed, latest fall creator update (1709)
Is there anyway we can report this problem to NVidia?

I cant believe it ! I just tested some random YouTube Videos in Fullscreen and the Screen is flickering terribly ! What the hell? They fix one issue to cause another one? We really Need to inform Nvidia about this, i did not find anything to this case in Google search. Maybe someone else had more luck? Just unbelievable and dissapointing....

kekkooo87
12-14-2017, 12:22 PM
by the way my windows 10 is clean installed, latest fall creator update (1709)
Is there anyway we can report this problem to NVidia?

Same situation: Windows 10 clean installed and last update. I think there's a connection with this issue..

OnePiece@ASUS
12-15-2017, 09:10 AM
Is there any video could provide us to confirm it?

sl0519
12-17-2017, 11:14 PM
Is there any video could provide us to confirm it?

I have a recorded a 5 sec clip from my phone, whats the best way to upload it here?

greenwraith
12-18-2017, 07:40 PM
Guys, I get the 388.59. No problem with games, but Youtube's videos and other browser (edge) videos flicker a lot, but only in full screen mode. I solved the problem with the "Use software rendering instead of GPU rendering" option. Have problems like that?



Disable G-sync, you have no flicker in YouTube Videos on fullscreen

g-sync have a problem

75hz and g-sync no problem

120 hz and g-sync problem

144hz and g-sync no problem

sl0519
12-19-2017, 01:16 AM
Guys, I get the 388.59. No problem with games, but Youtube's videos and other browser (edge) videos flicker a lot, but only in full screen mode. I solved the problem with the "Use software rendering instead of GPU rendering" option. Have problems like that?



Disable G-sync, you have no flicker in YouTube Videos on fullscreen

g-sync have a problem

75hz and g-sync no problem

120 hz and g-sync problem

144hz and g-sync no problem

Disable G-sync does nothing.
I only have 60hz option in my NVidia panel, it didn't work either
Here I've uploaded a clip from google drive, not sure if it's done right. Hopefully everyone sees it.


https://drive.google.com/open?id=1bzFXt7ELI0z-d5sGHSaUPdzSNiZy4YPL

horsima
12-20-2017, 03:52 PM
I have the same issues with flickering internet videos in full screen mode on the internal display of my G752VSK since installing the new Driver 388.59 in Windows 10 with fall creators update 1709.

It is independent from the used browser and also not only limited to Youtube videos. I have tried it with Edge and Chrome. As SL0519 stated, the use of software rendering instead of gpu rendering in the internet options (Edge) respectively disabling of the GPU acceleration in the Chrome settings helps to provisionally "solve" the problem.

Unlike the previously described flickering within games, which seems to have been fixed by this driver release, this issue can not be prevented by disabling G-Sync.

The most interesting thing for me is that the flickering disappears if another window is moved in front of the internet browser window.

horsima
12-20-2017, 09:53 PM
Guys, I get the 388.59. No problem with games, but Youtube's videos and other browser (edge) videos flicker a lot, but only in full screen mode. I solved the problem with the "Use software rendering instead of GPU rendering" option. Have problems like that?


Problem with flickering videos in full screen mode is fixed with the new driver 388.71 :)