View Full Version : usb ports problem

12-16-2010, 04:19 PM
While just surfing or general computer use the usb ports will stop working. All I have attached is a mouse and a usb key. When I would restart or shutdown after the usb ports stop working, it would either hang at the "shutting down" screen or I see a BSOD. Does anybody else have this problem. I have the G73JH-BST7 model from BB. The only thing I have installed on the laptop currently is all the windows updates and firmware updates from Asus.

12-16-2010, 06:00 PM
Is there any system message when it stops working? Are you able to see anything in the device manager indicating a fail code or do the devices disappear completely?

12-16-2010, 11:10 PM
when the usb ports stop working you can still see the usb key attached, but if you try to access it, nothing happens. I am currently not near my laptop, but when I get home I'll check the event viewer logs and report back here. Thanks Xeromist for responding.

12-17-2010, 01:04 AM
Yes, the event viewer and also try to check the device manager. Sometimes you'll have an error code in the device properties that can help you figure out what might be happening. If it's completely disappearing from the device manager then I wonder if there is a loose soldering connection inside somewhere.

12-17-2010, 01:27 PM
I just got up and it's 7 am. I walked over to my computer and of course the usb drive and usb mouse is not working. when i try to see if it's listed in device manager, device manager stops responding. In "computer" i can see the usb key drive listed it but also stops responding if I try to open it. In event manager the an error was listed as "the driver detected a controller error on \device\harddisk1\DR1". I hate how random it happens.

Yesterday I was away from my computer starting at 2:30p until 9pm. The event viewer showed to unexpected shutdowns at 3:23p and 7:48p. The only warnings listed prior to the shutdowns was the error "LMS service cannot connect to Intel MEI driver." I just don't know if its a windows 7 problem or a hardware issue. Im afraid of RMA it, but it hasn't worked properly since I got it on 11/15/2010.

12-17-2010, 04:09 PM
I guess you could try uninstalling the Intel drivers and see what happens. If that doesn't fix it though I think that I would RMA. It's a pain but I wouldn't want to have an unpredictable PC that was supposed to be working perfectly when I bought it.

12-17-2010, 06:12 PM
when the usb ports stop working you can still see the usb key attached, but if you try to access it, nothing happens.

If you unplug the devices and plug them back in do they start to work again?

What about using just the mouse or just the keyboard (with the other unplugged)....does it still happen?

Does your keyboard and/or mouse have drivers available from the manufacturer? If so, are you using up-to-date versions of those?

Also, have you tried changing the power options for USB? A couple options to try:
1) For your selected power plan, under advanced settings/USB settings/USB Selective suspend setting - try setting it to disabled.
2) In device manager, under Universal serial bus controllers, turn off the "Allow the computer to turn off this device to save power" option for all the USB Root hubs.

You could also try toggling the legacy USB device support option in the BIOS setup.

Just trying to see if it's a funky device and not your system - before you enter the painful RMA world to wait for your new motherboard :) I just set up a neighbor's new Asus (not a G73) and was surprised to find their Microsoft Intellimouse Explorer 4.0 would not work after resume/boot without unplugging and plugging it back in - known issue (and it worked fine on their old laptop). I was surprised, since I use the 3.0 version of that mouse on all my systems and it works fine.

12-17-2010, 08:36 PM
the usb devices do not work if I unplug and plug them back in. The other usb ports that wasn't in use no longer work also. It happens with just the mouse plugged in. I don't recall anything happening with nothing plugged into the usb ports except a sudden restart with no BSOD. I have played with the power options in usb settings and it didn't help. I just tried the optinos in the usb bus controllers on saving power and will report in a few hours to see if anything happens. I haven't tried the legacy support in bios. Will try that after a few hours if the usb ports stall again.

How long of a wait is it for a new motherboard? I won't be sending it in until Jan 2011 because it's the holiday season and people just want to be home. I think the techs will concentrate more after the holidays.

12-20-2010, 08:14 AM
I'm having the same issue. I am using my laptop as a desktop replacement, so I have a G15 keyboard, trackball mouse, winTV 950q all plugged in, and once or twice a day, the usb ports will seem to short or something and either my laptop will freeze or none of the usb ports will work. Also, while trying to shutdown and reboot, it will hang on the shutdown screen also. I have tried reformatted the laptop twice making sure to use the most up-to-date drivers and I still get the usb issue. I definitely know it's the usb ports that are causing the issue because sometimes I can cause the problem by plugging in a new usb device (like my android phone). One thing I do notice is that every so often (many times a day), my G15 keyboard's lights will flicker really fast as if it lost power and quickly regained power. Hoping to find a solution that doesn't entail getting an RMA. I will try the "Legacy" setting in the bios and see if that makes a difference.

*edit* By the way, I have a G73jw-XA1

12-20-2010, 06:35 PM
I've had similar things happen on my g15 with a flaky KVM switch that I use. Honestly if you have reformatted twice already it sounds like you are having a hardware problem.

12-21-2010, 02:31 AM
Yeah I tried everything. I did numerous clean windows 7 installs and Asus recovery back to original factory settings and it's the same outcome. Now should I RMA the laptop with the current clean windows 7 install or should I just recover the laptop to it's original factory settings. Or does it really matter?

12-21-2010, 05:19 AM
I'm not sure of the procedures once they get something for RMA but usually they at least check to see if there is a problem. I'd restore it so that there's no doubt that this is a hardware issue and not a conflict with something the owner did after purchase.

12-23-2010, 06:49 PM
I got a replacement and this new one has the same issues also. So that's two that have the same exact issue. Basically the USB ports seem to be shorting out and in randomly. My mouse will lag for like 2 seconds as if unplugged, my G15 keyboard will lose it's lcd screen and flash it's lights (caps lock, num lock, insert) as if it was unplugged. Even when I type, sometimes it will lagg then I will get repeating letters without exessively pressing it. So there is definitely something wrong with Windows7 and the G73jw. I'm thinking most people don't get the issue because they don't use the usb ports enough? I don't know. I'm using all 4 of my usb ports at a time, and my hdmi port. Could there be a power issue by using too many external ports? I will have to try ubuntu or something and see if it happens in there.

12-25-2010, 06:46 PM
Sounds like bad hardware to me, too. Do you have any kind of a powered USB hub that you could plug your devices into temporarily, just to eliminate them as a potential culprit?

If the powered hub solves it, then try to narrow it down to exactly which USB device triggers the issue. The more information Asus has, the easier it'll be to diagnose. It might be just as simple as a power supply problem.

I'd also call Asus and start the RMA process. Hopefully they'd be able to fix it quickly.

12-26-2010, 09:16 AM
Ok so I've come to figure out that anytime I have more than 2 usb devices plugged in, I have the usb shorting issue. It's as if there is not enough power going to all the devices. If I only plug in one or two devices, I do not have any issues. I use my laptop as a desktop replacement, so I am also using the HDMI port to a monitor, usb G15 keyboard, usb trackbaall mouse, WinTV 950Q, Android phone. If I don't plug in the last two devices, the usb ports never "short"

For those having usb issues, how many devices on average are you using when you have usb issues? Also, do you use the HDMI port during those issues also?

12-29-2010, 01:22 AM
This may or may not be relevant: Within about a week of getting the X1 I got a BSOD. On reboot, I got a "Missing Operating System".

It turned out that the USB drive I was using was fried and the machine was trying to boot from it. Removed the drive and all was swell.


01-15-2011, 04:09 PM
I am also having this USB issue with my G73JH. The USB just stops working, sometimes Windows will tell me about it and other times the only way I can tell is that the mouse (my Razer Naga) no longer does anything. Unplugging any USB device and plugging it back in, or trying another mouse, etc, results in nothing useful happening. Sometimes the lights on my devices still function when this happens, other times they don't. I've tried different USB ports, unplugging different devices, etc. I typically use 2-3 ports, one for the Naga, one for my G13, and one for my Android phone.

Rebooting is the only way I've found to fix it. Even if someone doesn't have a permanent solution to this, I would be much happier to just find a way to reset it without rebooting. I guess I haven't tried disabling the USB controllers in the device manager, so maybe I'll give it a try next time this happens and my keyboard doesn't stop working too.

I have two G73JH's -- both Best Buy versions. The older one currently has no problems with anything. It previously had the overheating problem (corrected with thermal compound) and some of the other common issues (corrected with drivers, BIOS, etc), but now it's working great. Second one is the newer Best Buy model, 211 BIOS, downloaded ATI Catalyst drivers last week to fix a GSOD, and I have to constantly reboot because my laptop freezes in the middle of the night and USB stops working a few times daily.

01-15-2011, 07:27 PM
Did you update the vBIOS on that 2nd G73JH?

01-21-2011, 02:57 AM
Update: I RMA my G73JH on 1/3/2011. Got it back on 1/18/2011. The sheet that came with it says they replaced my motherboard with a new one. After a day of using it the same problem occured, intermittent usb functionality. Sigh. I just finished talking to Asus service on the phone and they supplied me a new RMA number to send it back in. Initially they wouldn't agree to paying for shipping back to them, even though the email they sent me with the RMA number on it says if it's within the warranty period they will email a prepaid Fedex shipping label. They mysterious got disconnected from our 55 minute phone call and emailed me the fedex label. This is exactly what I hoped not to happen with the RMA process.

01-27-2011, 10:08 AM
I'm also having a problem with USB devices and the G73 not responding. I have a Razer Naga and, sometimes, an iPhone connected.
Last night I came back to my laptop, after disconnecting my iPhone, and noticed the clock on my laptop said 7:09pm.
The correct time was 7:29pm.
Razor Naga unresponsive, can't remember if it had lights (sorry)
Ctrl-Alt-Del would not bring up Task Manager
No mouse cursor
Touch pad also not responsive

A hard boot got me back up and running, but this isn't the first time I've had this happen.

I went to the Intel driver download page to get drivers for the HM55 chipset (http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19596&keyword=%22HM55%22&lang=eng), but I noticed the following disclaimer: **Important**

Some other info:

Razor Naga is connected to USB port closest to me on the left side
My iPhone, when connected, uses the port furthest from me on the left side
Intel makes our USB root hubs, according to the device IDs in Device Manager

EDIT: I went ahead and installed the Intel drivers this morning. I'm also going to install the 11.01a Hotfix 01/26/11 for Mobility. I've already installed the VBIOS update ... that's what brought me to these forums in the first place :D

EDIT X2: Just installed 11.1 Mobility. I'll leave the 11.1a hotfix for another day.

EDIT X3: So far, so good.

02-16-2011, 02:49 AM
My usb ports have been randomly shutting down, playing games, surfing the web. I am using a Belkin USB 2.0 hub with it's own power adapter and my usb is still shutting down. Now the interesting part, my battery is perfectly fine, holds 100%. When the USB shuts off I disconencted the power adpater from the laptop and it instantly shutdown rather than continue on battery. This definately indicates a motherboard issue.

Mine is the BestBuy G73 model also.

02-16-2011, 02:50 AM
My usb ports have been randomly shutting down, playing games, surfing the web. I am using a Belkin USB 2.0 hub with it's own power adapter and my usb is still shutting down. Now the interesting part, my battery is perfectly fine, holds 100%. When the USB shuts off I disconencted the power adapter from the laptop and it instantly shutdown rather than continue on battery. This definately indicates a motherboard issue.

Mine is the BestBuy G73 model also.

02-16-2011, 02:50 AM
Sorry for double post, gave me page could not be displayed after first submission.

02-23-2011, 01:29 AM
Well, looks like I'm still having the same issues. I only use my G73 when I'm away from home, and this is the first time since my last post.

When my USB ports stop working, I can't do anything with the laptop
When I unplug the AC adapter, the computer shuts off
Maybe this issue has to do with power management

Here's what I'm doing now:

Uninstalled all ASUS applications
Ran all Windows Updates (including Win 7 SP1)
No more keyboard lights, which will not do
Reinstalling ATK Package 1.0.0007 (http://dlcdnet.asus.com/pub/ASUS/nb/Drivers/ATKPackage/ATKPackage_WIN7_32_WIN7_64_z100007.zip) (from Chastity's drivers and apps sticky (http://www.asusrog.com/forums/showthread.php?1150-G73-Series-Driver-and-Application-Reference))

02-23-2011, 02:37 AM
Here's a link, with pictures, for disabling USB Selective Suspend (http://maximumpcguides.com/windows-7/disable-usb-selective-suspending-in-windows-7/).

Below are the steps, just in case that link stops working:

Open the Control Panel from the Start menu.
Open Power Options in the Control Panel.

Note: If Power Options is not available, change View by to Large icons at the top right of the Control Panel.
Select Change plan settings next to the power plan you want to edit.
Select Change advanced power settings.
Select Change settings that are currently unavailable.
Set USB selective suspend setting to Disabled under USB settings and then click OK to save the changes.

02-26-2011, 07:43 AM
Hey 94sportsedan,

Looks like we have the exact same problem. My usb ports would shutdown for no reason what so ever and when I pull out the power adapter it shuts down. Also when I try to shutdown the laptop it hangs during the shutting down screen or it goes to blue screen.

Here's the scary part. I have RMA the laptop for that same very problem 4 times now. First time they replaced motherboard, second time they replaced the audio card, and the third time they said they updated the bios, but the bios was already the updated version. Sigh.

I can't tell you how many times I've done clean installs and perform recoveries to original factory settings and it's all the same. This last RMA they had me send it to the Fremont, CA service center because the Indiana location wasn't able to fix it. I just checked the status and it states "Waiting-[WF9] Wait for Customer Confirmation-NTF" but I haven't received a phone call or email. NTF from what I can gather means "no trouble found". Sigh. Do I need to setup a Youtube video of my problems to prove that it exists. Obviously the problem exists because why would they have changed my motherboard out the first time. All my desktop computers that I have built all have ASUS mobo in them and not once have I had any problems with them. This is my first Asus laptop and it makes me very sad. I don't get it. I'm trying to be patient but it has been 3 months now. I got this laptop in Nov, 2010 on my birthday and haven't been able to use it yet. I also have the bestbuy G73 model also.

94sportsedan did you send it for RMA? and were they able to fix it?

Can anybody help me?