View Full Version : G73jw problem with Wifi connection

12-16-2010, 09:12 PM
Hello there,
I just brought mine laptop yesterday(G73jw xr1)
everything seem to be working fine, after browsing internet for awhile after just got home...
so i decided to install games, only stream for call of duty BO and BFBC2
and i start to observed some problem with my wifi connection, it start to drop randomly(and i have my old laptop next to me to compare, if both went down that is okay(which happens sometime since i been using my old laptop)...however, my g73 would just drop and not having a connection/or getting connection but no internet or getting a yellow icon along with wireless trayicon.

so I went online look up drivers from internet
MY wifi adapter is : Atheros AR9285 wireless network adapter(from my device manage)
after update to new driver (which is,originally it was 2 something which i dont remember)
My internet start to have stable connection but I seem to have problem sometimes and when i try play a game , i would have a very bad ping(compare to my old laptop which run smooth,tho it was running at lowest setting due to old hardware)

So. i want to know if anybody came over this issue before? what driver version are you using? if you have updated and get a stable working wifi for gaming please let me know where to download too!

I find out that many people recommended to change wifi card.
note: AR9285 has two antennas after i pull out the back cover to check it out...

Thank you in advance, if need any more infos please tell me, i try to be as informative as possible!

12-16-2010, 09:32 PM
another note: After trying to update my BFBC2 to latest version(which is massive download), my connection would drop with yellow icon and i would get internet back in 10 secs...this happen 3times already

12-17-2010, 08:14 AM
Problem solved , if you happen to have wifi problem please look up here
i tried afew version of 9.... doesnt work at all
after getting to v8.0.0.351... It works...stable

12-17-2010, 04:11 PM
Good to know, thanks!