View Full Version : G501VW No boot

12-04-2017, 05:21 AM
Has anyone had the same issue as mine? I just got to the office today and I tried turning the laptop on but it just won't boot. I don't have any display on the screen at all. I only have the CAPS LOCK light on and the Airplane Mode LED blink twice every time I try to power it off. When I hold the power button to try and turn it off, it just turns back on to the same situation again. I tried holding the button for roughly a minute but I still don't have anything. Any help is appreciated. Thank you!

ASUS ROG G501VW Purchased April 2016.

12-05-2017, 05:46 AM
Try holding the power button a little less.
Should be jsut hold it down until the light on the button itself goes out then let go and leave it sit for several seconds then power up again.
They didnt make this one easy to trick a BIOS reset by pulling the ram but if you are industrious enough to get the bottom off you are looking right at the CMOS battery, just unplug that and the battery pack if if the power down mentioned above doesn't work and leave it sit for 15 mins or so.