View Full Version : ASUS Maximux X Hero - GPU doesn't work properly

12-24-2017, 08:39 AM

I've a problem with my new Maximus X Hero. When I use my dedicated GTX 1080 Ti the display of monitor goes on/off the whole time. The board came with the default BIOS 0402 (?). I updated the UEFI to the lastest version (0802). But this didn't fix the problem. After that I tried both PCIe-Slots and in either case the problem existed. Well, after that I tested the GPU in another system (Ryzen AM4 with a Crossfire VI Hero) and everything worked fine.

If I use the integrated GPU from the 8700K there are no problems at all.

12-24-2017, 08:59 AM
Maybe the Pressure from the cpu cooler is to high.
Test if you loose a little bit the cooler screws.**

12-24-2017, 10:06 AM
That's excluded. Screws are finger-tight. I think it's a problem with the board because the CPU with iGPU works.

12-24-2017, 11:53 AM
Given it works fine with the iGPU, I'd look at sync issues between the graphics card and monitor. It's possible the cable you're using isn't capable of sustaining the applied resolution or refresh rate. Outside that, memory instability can cause the driver to crash/recover, but that would usually show issues on the iGPU, too, as it's more sensitive to memory stability.


12-24-2017, 12:16 PM
Try this.

Disable windows update driver download, so that windows is NOT messing with youre drivers. (Many tutorials on youtube)

Download DDU, uninstall the driver when the pc is booted to safemode.
Restart the computer, then go to youre device manager and see iff you can find youre graphics card, and then uninstal it from there aswell. Again, restart youre computer and install the latest driver. Do not do a express inst, also check of the clean instalation iff possible.

Also, make sure you uninstall the intel gpu, and disable it from youre bios.

Remmember, the driver update function trough windows uptade is a pain in the ass..

Also, make sure you have all the correct plugs conected from youre power supply to the GPU. If this does not work, i would consider trying another GPU in youre MB just to close out MB defect.

12-24-2017, 01:08 PM
The GPU works fine with a Crossfire VI Hero and Ryzen R7 1700X. No problem with DP´, monitor or cable. Same GPU with the Maximus X Hero and 8700K does not work. The GPU is not the problem here. It's the Maximus Hero X motherboard or the 8700K. You can't use the 1080 Ti because the display's monitor goes on/off every single second.
I tried both PCIe 3.0 slots. Nothing changed.

I'm not talking about windows. This problem even appears when you are in UEFI.

So I see two options:

Maximus X Hero is broken or the PCIe-Controller within the CPU has problems.

12-24-2017, 01:13 PM
Try swapping the power supply...

or reseat the cpu, check for bent pins, etc.

12-24-2017, 03:06 PM
That is a weird issue you are having and must be extremely frustrating, can you boot to UEFI using the iGPU with the Video card installed without the flashing? if so does the bios recognize the 1080ti correctly as Gen. 3 X 16 in the correct slot? Have you tried all the DP ports on the 1080ti?
are you positive the Video card is seated fully, I have had seating issues before and bending the pcie bracket a tiny bit allowed the card to seat fully, PC cases are not always manufactured perfectly or can get tweaked slightly during shipping causing mounting issues, usually with inexpensive cases

12-24-2017, 03:41 PM
I know this is a long shot but, check to see if you have any bent pins in the CPU socket. I had a the same thing but mine was only on the desktop flashing on and off caused by the latest windows update.

12-24-2017, 09:31 PM
Thanks for your replies. I had checked the pins from the LGA socket before I assembled the CPU. This is not my system I just assemble the parts. Things I already did:

-I dismounted my Ryzen system and used all parts from the Intel PC except of motherboard and CPU. Everything worked fine.
-I put the GPU into the last PCIe slot from the motherboard (lanes come from the chipset and not CPU if I'm right) and there were no problems.
-Flashed BIOS 0802 via USB Flashback without CPU, GPU and RAM.
-When using the iGPU there are no issues at all.

I think the PCIe controller within the CPU is broken. *