PDA

View Full Version : Asus ROG Strix z370-e Gaming Bios Ver. 0605 - need some help please.



awsapero
12-29-2017, 02:48 AM
Hello,
I have just put a new build together with mostly newer parts and few older ones. While I am not the smartest person when it comes to building PCs, I can usually spend hours of googling to figure out a resolution. However I am having two issues I can not seem to figure out.

First When I power on, I do not see my motherboard splash screen that says "Press F2 to enter Bios". If left alone it does boot into Windows 10 with no issues. If I do press F2 during the boot I feel it goes to Bios settings but stays a black screen. My reasoning for this is when sitting at the black screen I can press ctrl+alt+del to restart system. I can sometimes get the splash screen and Bios setting screens to appear if I: Power down, turnoff/unplug PSU and short the pins that clear out CMOS settings.

Second I have a cheaper SanDisk x300 m2 in the M.2_1 and M.2_2 slots. The M.2_1 slot (one under the heatsink) gave no issues what so ever. It recognized the m.2 drive with no problem. The M.2_2 slot (one above GPU and below CPU) has been a problem. I read that I must change some settings in the Bios to be able to use this m.2 slot. However, any guide I have looked at for this process has not helped. Either the description or the screen shots of the Bios do not line up with what I see in my Bios.

I truly would appreciate any help. Please let me know if I should post any other information about my system. Also, if you think it might just be better to get on Asus live chat to try and resolve these issues.

Carbonicdk
12-29-2017, 11:37 AM
The m.2_2 slot only supports PCIe interface drives and the SanDisk x300 m.2 drive uses the SATA interface. Your SanDisk x300 drive wont work in the M.2_2 slot. You can buy a pci-e adapter card if you need more than one m.2 SATA drive connected.